PDA

View Full Version : [ubuntu] Compiz '3D Windows' not working



Mars1996
November 23rd, 2012, 04:49 PM
The 3D windows of my compiz manager is not working.

Whenver I rotate the desktop cube, the cube does not show up and the windows do not display properly.

stinkeye
November 23rd, 2012, 06:24 PM
The 3d windows plugin no longer works. Disable.(The cube still works just not with the 3d windows plugin)
You will see some plugins fail as Canonical focuses compiz functionality just for unity.
See HERE (http://ubuntuforums.org/showpost.php?p=12369441&postcount=4) if you need to reset compiz/unity.

monkeybrain2012
November 23rd, 2012, 08:10 PM
It has been broken since 11.10 and is still broken in 12.04. But it works in 12.10, so either wait for a Unity upgrade in 12.04 (most likely in 12.04.2 in late jan) or upgrade to 12.10.

If you are already using 12.10 then it may be your hardware or your configurations.

Mars1996
November 24th, 2012, 01:14 AM
It has been broken since 11.10 and is still broken in 12.04. But it works in 12.10, so either wait for a Unity upgrade in 12.04 (most likely in 12.04.2 in late jan) or upgrade to 12.10.

If you are already using 12.10 then it may be your hardware or your configurations.

I am currently using 12.10. What do you mean by the configurations ?

monkeybrain2012
November 24th, 2012, 03:05 AM
I am currently using 12.10. What do you mean by the configurations ?

I have attached a screenshot of my cube. The window appears to be a bit odd (it forms 4 walls outside the cube instead of surrounding the cube) but the cube is definitely there.

By configuration I mean settings in ccsm.

stinkeye
November 24th, 2012, 03:44 AM
I am using 12.10 and the 3d windows plugin does not render correctly
using the nvidia or nouveau drivers.
In my 12.04 install 3d windows plugin renders fine.
Your experience may vary depending on your GFX card and the way
proprietary drivers implement OpenGL.

For some explanation see a compiz developers blog.
On the future of Graphics Drivers (http://smspillaz.wordpress.com/2012/06/08/on-the-future-of-graphics-drivers/)

Maintainers for the unsupported plugins (http://smspillaz.wordpress.com/2012/09/07/maintainers-for-the-unsupported-plugins/)

monkeybrain2012
November 24th, 2012, 03:49 AM
I am using 12.10 and the 3d windows plugin does not render correctly
using the nvidia or nouveau drivers.
In my 12.04 install 3d windows plugin renders fine.
Your experience may vary depending on your GFX card and drivers.

For some explanation see a compiz developers blog.
On the future of Graphics Drivers (http://smspillaz.wordpress.com/2012/06/08/on-the-future-of-graphics-drivers/)
Maintainers for the unsupported plugins (http://smspillaz.wordpress.com/2012/09/07/maintainers-for-the-unsupported-plugins/)

Never tried 3d windows on 12.04 because the cube itself is not working (flashing while rotating and windows don't carry over with cube while rotate. I stick to the default in 12.04) I use Nouveau because of this bug https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/729979

johnnydas
April 27th, 2013, 01:54 PM
I have attached a screenshot of my cube. The window appears to be a bit odd (it forms 4 walls outside the cube instead of surrounding the cube) but the cube is definitely there.

By configuration I mean settings in ccsm.

Hi there.
Did you manage to solve the issue with the 3d windows showing outside the cube, and if yes in what way?

Frogs Hair
April 27th, 2013, 02:12 PM
3D windows are included with the compiz plugins in 13.04 and are working .I disabled mouse rotate in order to test and the windows are distanced from the cube until mouse rotate is enabled. I am not familiar with the plugin though.

monkeybrain2012
June 1st, 2013, 11:56 PM
3D windows are included with the compiz plugins in 13.04 and are working .I disabled mouse rotate in order to test and the windows are distanced from the cube until mouse rotate is enabled. I am not familiar with the plugin though.

What do you mean by "mouse rotate"? If you are referring to the binding options in the rotating cube they are disabled by default, see attached screenshot.

bbaaxx
July 6th, 2013, 05:31 PM
I'm getting the exact same behavior as the pics on Mars post using 13.04, I think it has something to do with the ATI propertary driver for my 7700 AGP because on my other laptop (INTEL AGP) 3D windows won't work at all.