View Full Version : [SOLVED] 12.10 - disable compiz??

November 22nd, 2012, 01:08 AM
I recently installed crossover, which has helped greatly with installing and running some Windows programs I still needed. I've also been able to install a couple of slot machine games. A third one is having a bit of a problem, but I don't think it's the program, crossover or wine.

If I run the program in my default desktop - unity/gnome - it apparently tries to initialize the screen somehow and says something to the effect of can't reset device. If I go to a terminal and type metacity --replace, it will run fine with the mouse. However, doing so I lose the task bar and the unity menus (obviously) and also can't type in the terminal window any more. I actually have to do a physical reset on my system.

I installed kde so I could select it at log in, and the program runs fine in it as well, but to be honest I'm just too used to gnome/unity to want kde.

So, with it working in kde, working when I do the metacity --replace, but not working in default unity/gnome, I'm assuming it's a unity/gnome thing.

Is there a way to set to metacity and still get control of my entire machine? Is there a way to set something up, possibly in one of the various xorg config files that would let this run (although this seems doubtful to me considering kde is using X as well)?

November 22nd, 2012, 03:39 AM
Firstly if you kill compiz you will always kill Unity as you have noted. Unity is merely a compiz plugin for creating the desktop features you know as the Unity desktop, that sits atop a gnome3 base.

Could you please name the game/application for us or check its status on the --winehq.org database-- (http://appdb.winehq.org/) for known video problems? With the nature of Wine I'd actually check out for problems at this level before messing with compiz (pretty much essential for Unity as you've noted). Wine only works with some Windows apps, and some applications can be pretty fickle to use under it.

It is possible to install AWN dock and create launchers on it for compiz and metacity, I have been known to do it here (switching WMs "on the fly" -) and definitely advise against it, particularly for newer users, the system can get very strange very quickly.

November 22nd, 2012, 08:44 AM
KDE works because they elegantly solved this problem by disbaling special effects when fullscreen is run. this can't be done with Unity as it is "a special effect" in itself. in older versions you could disable compiz, but now you can't. even in the older gnome some fullscreen games behaved kind of strange in wine.

perhaps an option could be a short script that would change the desktop environment to run the programme :-) or simply when you need it log out and login to different desktop environment when you plan to use wine/crosswover. you could use somehting super light for that (a window manager like openbox or IceWM) would be enough)

November 22nd, 2012, 09:58 AM
Well, I already know it's not on the wine list - to little of a known program.

I did try a script before, but decide to try it again just slightly modifying it - that does seem to work. metacity --replace, sleep 5, the program, compiz --replace and sleep 5

So, for now I guess this is solved.

Thanks everyone!