View Full Version : [ubuntu] 12.04 LTS > 12.10 Graphics Not good enough?

November 20th, 2012, 07:37 AM
Okay, I fixed my computer through my BIOS. The problem was that I had tried to upgrade to 12.10 from 12.04 but due to lack of disk space, I had an installation error. I am fixed and DELETED the entire installation and re-installed 12.04 so now I have PLENTY of free space as I've only installed gnome-do and Docky. When I go to upgrade to 12.10 I receive this message:
Running the 'unity' desktop environment is not fully supported by your graphics hardware. You will maybe end up in a very slow environment after the upgrade. Our advice is to keep the LTS version for now. For more information see https://wiki.ubuntu.com/X/Bugs/UpdateManagerWarningForUnity3D Do you still want to continue with the upgrade?

I was just wondering, if Unity 3D has already worked fine on my desktop, then shouldn't it work in 12.10?? If there is some kind of crazy 3D upgrade needed by a superior card, then I won't update, but I just assume that since I'm already using the 3D mode fine in 12.04, I am SHOULD be able to use 12.10 fine. Any suggestions or notes(other than the guy that's gonna tell me to try to run it live first to try it out)?

November 20th, 2012, 10:37 AM
What graphics card do you have?

If it's an ATI 2/3/4xxx series card then you will end up with worse performance.

This is because ATI has dropped support for these cards and wont release a driver for them that works with 12.10, whereas on 12.04 you can still use the old ATI driver.

This means that instead of having hardware 3D acceleration the OS will fall back to software rendering giving a massive performance hit in the graphical department.

November 20th, 2012, 10:43 AM
Hi!, lemonoid,

On my computer running 3D Ubuntu with a GT 7650 nvidia card, successfully in 11.10, and 12.04, when I upgraded to 12.10 I got a similar message to the one you reported.
/usr/lib/nux/unity_support_test -pshowed nouveau in operation &: '3D not supported/Not Software Rendered'.

However, it logged in to Ubuntu 3D and everything worked correctly after the nvidia driver was installed, and the 'test' script showed '3Dsupported ? - Yes'.

So running from a LiveCD/USB will not necessarily tell you if it will run OK in a clean install, though it does [may] not from an upgrade.

As far as I can see, the fault is in 12.10 Nouveau with certain cards, and the answer is: " Suck it and See!".

Chao!, bogan.

November 20th, 2012, 11:47 AM
Hi ,

this same message I had when attempted upgrade from Ubuntu 12.04 to 12.10 (at my Desktop). This was due to nouveau driver (I suppose) , because my graphics card is Nvidia GT430 with 2GB GDDR3 memory.

When I installed nvidia-current the message disappeared and upgraded successfully*
So check if this is problem due to graphics driver.

*PS: Even when I upgraded with nvidia-current installed , I had a problem with environment , but was due to a problem with drivers for Nvidia in 12.10 (linux-headers .. etc). I used nounveau (in 12.10) for a month or so , without problem. Now I have install the newest beta Nvidia drivers.