PDA

View Full Version : [ubuntu] .ICEauthority



nevyn2345
November 20th, 2012, 01:21 AM
Hey,

Pretty new to ubuntu, only had it for about a week before the error cropped up

I get to the login screen and enter my password and the screen goes black for a while and then a message pops up saying "Could not update ICE.authority file /home/sam".

I have tried a couple of things but it hasn't seemed to work

I can however login to LXDE

Don't know if its relevant but i'm duel booting with windows 7 starter.

Bashing-om
November 20th, 2012, 01:34 AM
nevyn2345; Hi ! Welcome to the forum.

See if this works for you (did you misuse "sudo" ?)


1. At the login screen, press Ctrl+Alt+f1 to get to the console.
2. Log in there.
3. Check if ".ICEauthority" is owned by you:

ls -al .ICEauthority4. If it isn't (but possibly by root), change it to you:

sudo chown USERNAME:USERNAME .ICEauthoritywhere USERNAME is your actual login username.
5. Switch back to the login screen by pressing Ctrl+Alt+F7 or F8
6. Try again to log in.
If it worked, see here about a possible cause:
http://www.psychocats.net/ubuntu/graphicalsudo


just try'n to help <== BDQ

nevyn2345
November 20th, 2012, 12:06 PM
Hey thanks for the fast reply :)

when I type ls -al .ICEauthority I get:

-rw------- 1 sam sam 954 Oct 18 23:15 .ICEauthority

tried doing the sudo chown anyway but it made no difference, still getting the error

Bashing-om
November 20th, 2012, 08:35 PM
Well, let us suppose the .ICEauthority file is messed up.
Remove it ,,,will be re-generated upon a reboot.

sudo rm .ICEauthority
sudo shutdown -r now

what are the conditions after the reboot ?


still try'n to help <== BDQ

nevyn2345
November 21st, 2012, 01:35 AM
Well the commands seemed to work as it didn't flag any error messages, howeve I am still getting the sam error message when trying to log in

Bashing-om
November 21st, 2012, 01:52 AM
OK then, now try in terminal:

where again "user" is your actual username


sudo chown -R user:user /home/user
sudo chmod 755 /home/user
does that work ? <== BDQ

steeldriver
November 21st, 2012, 02:15 AM
^^^ hmm a bit queasy about recursively setting mode 755 - do you really want execute perms for the user set on EVERYTHING?

If you're trying to make sure the user's home dir is writeable for the ICEauthority file, a NON-recursive chmod of the directory should be enough


sudo chmod 755 /home/userIf you really must go recursive, IMHO it would be better to use the symbolic form


chmod -R u=rwX /home/usersince afaik the capital X will only apply the execute bit to dirs and files with execute permission already set

Bashing-om
November 21st, 2012, 04:25 AM
Thanks steeldriver, duly noted..much better implementation.

nevyn2345 --> see steeldriver's instructions.

still learning even after all these years ==> BDQ

steeldriver
November 21st, 2012, 04:38 AM
TBH if the OP can start an LXDE session the dir should be writeable - I wonder if it's something session-specific? maybe in ~/.cache?

That or it's something deeper with the whole ICE mechanism

nevyn2345
November 21st, 2012, 09:52 AM
Wow thanks guys, this line worked:


chmod -R u=rwX /home/user

Can now log in again :)

Bashing-om
November 21st, 2012, 09:53 PM
@nevyn2345;
Outstanding, pleased you have all back in order.
Please mark this thread as "solved" from the thread tools; enable others seeking similar solution.


@steeldriver I welcome any and all occasions to learn more in regards to my operating system of choice. My pitiful efforts of study does indeed reveal that ICE runs deep. Also have not taken the time to study which files are effected by the chmod command that can effect the resolution to a situation as presented in this thread (seen it several times on this forum).

Learning this system as opposed to another "open source" system takes time and small bit of effort -similar but different often bites me in the rear ! - Gradually I am learning to think ubuntuish -to place my thoughts where the operating system is at -> file system hierarchy rules .

Comments/guidance always welcome ==> BDQ