PDA

View Full Version : [ubuntu] 12.04 MacBook Pro 7,1 Display Driver Issues



steeban
November 7th, 2012, 03:56 AM
Greetings all,

I've recently installed 12.04 on a MBP 7,1 tri-boots with osx/win7 and mostly every device works great; except the display. It's got an Nvidia GeForce 320M card that doesn't seem to like any driver I throw at it. No matter what after I install any driver and reboot I get the first ubuntu logo to load then BAM black screen and have to boot to recovery and uninstall the driver just to get back to the desktop again :( Tried the current stable, proprietary, experimental

Has ANYONE got a working driver for this video card? I have little hair left to pull out. Any help would be much appreciated - please and thank you!

jlangvand
November 7th, 2012, 08:13 PM
I had the exact problem on my Macbook 7,1, not pro. The graphics card is the same, though. The solution for me was to switch to 12.10. It worked out of the box with the proprietary Nvidia driver in Software Sources.

steeban
November 8th, 2012, 08:05 PM
Thanks for the reply, since the initial post I've installed 11.10 on the same machine and had the exact same problem again!

I've tried installing 12.10 via USB and DVD and gotten errors while installing (I/O related)
Tonight I'll try it again after burning another DVD at the slowest speed.

steeban
November 10th, 2012, 10:36 PM
Installed 12.10 with a slower burned DVD.. installed package updates

rebooted

installed nvidia proprietary driver

rebooted

text mode only :(

sudo apt-get autoremove nvidia-*
sudo apt-get purge nvidia*

reboot

and I'm back to square 1

Seems as if ubuntu doesn't like this video card too much ...

jlangvand
November 12th, 2012, 05:34 PM
Have you tried booting with nomodeset? I remember this worked for me once when I were stuck at the black screen.

http://ubuntuforums.org/showthread.php?t=1613132

steeban
November 12th, 2012, 07:28 PM
I just added nomodeset to the kernel boot options, saved the grub file, updated grub, and then it booted into text mode and then froze...

So I removed nomodeset, saved, updated grub, and now it booted with lots of gfx artifacts and then froze. It freezes when I try to do anything. Now I'm worse off than before! :(

Does adding nomodeset change anything else?