PDA

View Full Version : [SOLVED] Server will not update



Dmaxx67
November 1st, 2012, 11:42 PM
HAving this isssue for a week now. I run sudo apt-get update and get this:
Err http://security.ubuntu.com precise-security InRelease

Err http://security.ubuntu.com precise-security Release.gpg
Temporary failure resolving 'security.ubuntu.com'
Err http://us.archive.ubuntu.com precise InRelease

Err http://us.archive.ubuntu.com precise-updates InRelease

Err http://us.archive.ubuntu.com precise Release.gpg
Temporary failure resolving 'us.archive.ubuntu.com'
Err http://us.archive.ubuntu.com precise-updates Release.gpg
Temporary failure resolving 'us.archive.ubuntu.com'
Reading package lists... Done
W: Failed to fetch http://us.archive.ubuntu.com/ubuntu/dists/precise/InRelease

W: Failed to fetch http://us.archive.ubuntu.com/ubuntu/dists/precise-updates/InRelease

W: Failed to fetch http://security.ubuntu.com/ubuntu/dists/precise-security/InRelease

W: Failed to fetch http://security.ubuntu.com/ubuntu/dists/precise-security/Release.gpg Temporary failure resolving 'security.ubuntu.com'

W: Failed to fetch http://us.archive.ubuntu.com/ubuntu/dists/precise/Release.gpg Temporary failure resolving 'us.archive.ubuntu.com'

W: Failed to fetch http://us.archive.ubuntu.com/ubuntu/dists/precise-updates/Release.gpg Temporary failure resolving 'us.archive.ubuntu.com'

W: Some index files failed to download. They have been ignored, or old ones used instead.

I followed this site and hardened my server security. http://www.thefanclub.co.za/how-to/how-secure-ubuntu-1204-lts-server-part-1-basics
It worked after i did all those things. Anyways I am running a static ip and Wildblue as my service provider. I cant set my own dns becuase their modem overrides it. Tried to upgrade to 12.10 and it says no new release. I can install packages like logwatch and such though and i have pinged google and its all there but no apt-get update. Any help is appreciated.

chadk5utc
November 2nd, 2012, 05:42 AM
This looks like 2 issues... Has anything on your Network changed? Has your ISP changed anything??
The following indicates a DNS issue
Temporary failure resolving 'security.ubuntu.com'
Err http://us.archive.ubuntu.com precise InRelease

Also package management issues
W: Failed to fetch http://us.archive.ubuntu.com/ubuntu/...ates/InRelease
W: Failed to fetch http://security.ubuntu.com/ubuntu/di...rity/InRelease

Have a look at this hopefully it will point you at least in the right direction:
http://askubuntu.com/questions/91543/apt-get-update-fails-to-fetch-files-temporary-failure-resolving-error

Dmaxx67
November 2nd, 2012, 11:44 PM
Problem solved I had to put my Wildblue Dns addresses under networkinterfaces.

Vegan
November 3rd, 2012, 01:34 AM
my isp was having all kinds of problems with their DNS servers so I upped my DNS server and now use that

along with a boat load of forwards