PDA

View Full Version : HOWTO: Making your windows look super sweet in Hoary (compositing)



Pages : 1 [2]

elgx
October 3rd, 2005, 02:32 PM
Do all of the xorg.conf stuff, then open the KDE control panel.
look for the "windows decoration" thing. The last tap will be "transparancies." Turn them on and restart KDE.

well but if i go to the window decoration thing i cannot see that tag ("transparencies")!
here you are:
http://img251.imageshack.us/img251/9339/windec6ja.png
is there something wrong in here? _''

razor7
October 3rd, 2005, 07:49 PM
any chance to get this to werk automatically on KDE?

Thanks...

poofyhairguy
October 4th, 2005, 12:12 AM
well but if i go to the window decoration thing i cannot see that tag ("transparencies")!
here you are:
http://img251.imageshack.us/img251/9339/windec6ja.png
is there something wrong in here? _''


If you lack the transparacies tab, then that means you did not set up your Xorg file correctly. Do that part of the how to.

poofyhairguy
October 4th, 2005, 12:13 AM
If you lack the transparacies tab, then that means you did not set up your Xorg file correctly. Do that part of the how to.


And looking at it, you are in the wrong place. That why I kinda don't use KDE, its GUIS are confusing.

poofyhairguy
October 4th, 2005, 12:20 AM
any chance to get this to werk automatically on KDE?


Like "out of the box?" I don't lead the Kubuntu team, but that will never happen. Why?

1. Its not stable. Not even clsoe. Randomly with both the KDE version and xcompmgr the xserver will crash. No way around it.

2. You need an Nvidia card AND its closed drivers to work well. A no-no is OSS land.

3. In the future, a better method will be used to have eye candy so this stuff will be obsolete soon. Xcompmgr and its KDE cousin are toys. Simple toys. They are not the future. Xcompmgr has not been worked on since 2004.

4. Did I mention that no compositor in any of the environments are stable? Good. I pick Gnome and xcompmgr over using KDE's or XFCE's built in ones because at some level they all suck, but in Gnome with the script found in this thread its easy to turn off and on xcompmgr.

bryan986
October 4th, 2005, 03:34 AM
When I add the



Section "Extensions"
Option "Composite" "Enable"
End Section


to my xorg.conf and restart x, kde will not start at all, just leaves me at a console until I remove that section, any idea why?

poofyhairguy
October 4th, 2005, 03:44 AM
When I add the


Section "Extensions"
Option "Composite" "Enable"
End Section

to my xorg.conf and restart x, kde will not start at all, just leaves me at a console until I remove that section, any idea why?

Did you do the "glx with composite" part doo in the device section?

bryan986
October 4th, 2005, 03:48 AM
Did you do the "glx with composite" part doo in the device section?

Thanks for the ultra quick reply, but I got it to work now by doing something esle. I commented out the "GLCore" part in the modules section and it is working great!!

lusepuster
October 4th, 2005, 10:26 AM
#10:

Have you enabled Universe and Multiverse package repositories? You need to do that.

By the way: It also works for me fine on the Breezy Preview Release, except that when I try to logout from a session with xcompmgr running, the system would freeze end I'd have to force it down by using the Power button.

Any idea what should be done?

bryan986
October 4th, 2005, 01:59 PM
If you lack the transparacies tab, then that means you did not set up your Xorg file correctly. Do that part of the how to.

It is in System Settings -> Desktop -> Window Behavior

you can also get to it if you right click on any window title bar and click "Configure Window Behavior" and then select "Transparency"

these settings will apply for all windows

elgx
October 4th, 2005, 04:31 PM
It is in System Settings -> Desktop -> Window Behavior


yeah... here it is.
Thank you very much.
http://img249.imageshack.us/img249/8562/transp18vt.th.jpg (http://img249.imageshack.us/my.php?image=transp18vt.jpg)

luxactor
October 11th, 2005, 11:03 AM
It won't work for me. I have color stripees on my screen, and GNOME freeze on splash-screen. I'm using Breezy and ubuntu nvidia drivers. Can someone help me please?

btw: sorry, if the the answer for my question is allready in the thread

poofyhairguy
October 11th, 2005, 11:02 PM
It won't work for me. I have color stripees on my screen, and GNOME freeze on splash-screen. I'm using Breezy and ubuntu nvidia drivers. Can someone help me please?

btw: sorry, if the the answer for my question is allready in the thread

It won't work in Breezy like in Hoary. You must get into Gnome using the failsafe version, and put xcompmgr further back than 0 in the sessions tool. I use position 49.

Fyrzen
October 25th, 2005, 06:07 PM
I've been following this topic for a while now. So far i've managed to get by on my own but now i've hit a snag. Here's my story:

I'm running a Duron 933mhz, 256mb, ti4200. Like everyone else i couldn't get full shadow support with the latest drivers(I used 7667). Fading and simple shadows worked, log out crashes all the same but that's not an issue thanks to aladdin89's shell script. Thanks to Spelley's suspicion I downgraded to 6629. Whaddaya know, it works, shadows look and work great. This was when i started gnome after installing the driver.

But after a reboot X failed to load the Nvidia kernel module. I've been down this road before, install other driver, edit xorg.conf yada yada yada... I opted for a solution instead, luckaly this particular problem is mentioned in the 6629 readme (ftp://download.nvidia.com/XFree86/Linux-x86/1.0-6629/README.txt), "(EE) NVIDIA(0): Failed to initialize the NVIDIA kernel module!".

A simple workaround is to log in at the console and type "sudo modprobe nvidia", then restart gdm. It works this way, i just don't understand why it won't load the module by default. I'm out of ideas. The xorg.conf file is fine, the X log file says it's using xorg.conf. Nothing i change in the configuration has any effect, not even disabling "EnableGLXwithcomp...". Solutions mentioned in the readme don't work either.

Is there a simple way i could just have the system run these two commands without me typing them and the password?

kamstrup
October 27th, 2005, 03:10 PM
Fyrzen:

http://www.ubuntuforums.org/showpost.php?p=89594&postcount=18

Fyrzen
October 27th, 2005, 03:56 PM
Works like a charm! Thanks! :smile:

Xealot
January 13th, 2006, 12:13 PM
I've been testing xcompmgr with various WMs, they all work with it but some run better than others. For example:

xfce - has a major bug where if certain windows are resized to be bigger, it won't redraw the new part of the window until the window is moved. This bug is also present in GNOME.
fluxbox - seems to work OK, although I'm having problems with fluxbox being stupid :p
openbox - Works very well when xcompmgr is on, but has a major bug where, after it turns on (or off,) apps don't come back as visible--you have to kill them through a console. This is using the verison in the hoary universe repository, I think it's out of date though
icewm - didn't have alot of time to look at it, but it seems to work OK.

So far, I'd recommend openbox (with fbpanel) except for the horrible "windows will disappear" bug.


As far as i can tell, the window-will-disappear bug in openbox only affects windows
present on the current workspace, which means if you onlu have ONE terminal open on say workspace 4, and you enable xcompmgr in that terminal, it will disappear and you have to kill it.. But the rest of the windows on the other workspaces will be fine..

Also, just a small notice.. im using a Dell latitude D505 laptop model with the graphics card: (onboard)

Section "Device"
Identifier "Intel Corporation 82852/855GM Integrated Graphics Devi$ Driver "i810"

and all of the xcompmgr effects seems to slow it down alot..
Oh, and the laptop got a 1500 MHz cpu.

If i can get it to work better, il re-post here later on.

bogoliubov
January 16th, 2006, 04:13 PM
Hmm, I wasn't gonna post anything here since most things have been said at least one time already. But I was looking for a way to use transset automatically on all windows; so if I open, say, a terminal it'll automatically have 0.9 (for instance) in opacity. Does anyone know if this is possible?

In general it works ok. But I can't put xcompgr in the startup for my account. If I do, I get a gray background and a splash screen when logging in, nothing more.
Other have written about this problem when using xcompmgr, but I couldn't find any solution here..., Any ideas?

And, my main question: Does anyone know if/when this will be "naturally" implemented in Gnome, so that you can set this up in systems-prefs-windows (or something similar)?

giannisapatis
February 22nd, 2006, 05:29 PM
very nice how to but i dont see any diffirence in my windows?????
does any1 may know why?