PDA

View Full Version : [ubuntu] 12.04 - Stuck at blank purple screen after boot - Macbook Pro 4,1



sstickeler
October 23rd, 2012, 09:16 PM
I installed 12.04.1-desktop-amd64.iso last night via ReFit. The install went fine and the system rebooted. After I select "Ubuntu" from Grub now I am just stuck at a blank purple screen.

I tried the "nomodeswitch" kernel parameter but all that did was drop me into a text based login prompt.

I also tried the mac specific .iso but I couldn't even get the installer to run.

Any ideas?

Josh1
October 24th, 2012, 05:00 AM
Having the same issue as you (though I'm on the 27" i7 iMac). Have you installed any video drivers?

http://ubuntuforums.org/showthread.php?t=2075064

2F4U
October 24th, 2012, 09:10 AM
What is your graphics hardware? On my MacBook 4,1 with Intel graphics Ubuntu 12.04 runs without any issues.

sstickeler
October 24th, 2012, 04:55 PM
The Macbook Pro 4,1 has an Nvidia GeForce 8600M GT

martinbures
December 1st, 2012, 04:51 AM
I have the same problem with the added twist of only getting a text mode installer.

I have a MBP 3,1. The machine previously had OS X 10.5/Ubuntu 10.04. I replaced the drive and upgraded to OS X 10.6. The DVD drive failed and I am using the USB install option.

peezee13
December 2nd, 2012, 12:18 AM
Had the same problem or similar (major part of screen blank and purple stripe on the left), and even though I don't have the same model Mac it also features an NVidia graphics chipset, therefore you may want to have a look at what worked for me (at least as a workaround if not a fix) here :

http://ubuntuforums.org/showpost.php?p=12379641&postcount=15

LuisGMarine
December 3rd, 2012, 04:57 AM
I had a similar problem not to long ago, except that it tried to get past the purple screen and just got this terribly distorted black picture. I could not get a working desktop, but I was able to get a working desktop booting with nomodeset. It was a fresh install, so I knew the system had been installed, and I could not get to it due to something going wrong with the video drivers.

Step 1: Involves you going to this website and reading the part that is labeled "Black/purple screen after you boot Ubuntu for the first time". Use this part to hopefully get a working ubuntu desktop or atleast something close to it.

http://askubuntu.com/questions/162075/my-computer-boots-to-a-black-screen-what-options-do-i-have-to-fix-it/162076#162076

If you are able to get a working desktop awesome, if you end up just getting the background (other than purple) try opening up a terminal window with Ctrl + Alt + T.

Type the following code to install the nvidia drivers for our video cards(I happen to have the same exact one)


sudo apt-add-repository ppa:ubuntu-x-swat/x-updates
sudo apt-get update
sudo apt-get install nvidia-current

After this, all I did was reboot the computer, in the case that you are stuck in a command line environment, this should do the trick:


sudo reboot

Once everything is done, you *should* have a working desktop.