PDA

View Full Version : [ubuntu] 12.04 upgrade issue after transferring passwd



kodb
October 19th, 2012, 10:24 PM
All,
I run a small office network with about 14 machines and about 9 users. Previously we were using 10.04. I just started upgrading to 12.04.1. In the course of this I had to do 3 new installs on ASUS notebooks and did so using the 12.04.1 cd.
My problem came as I tried to transfer my users to the new machines. Previously I had simply copied /etc/passwd, group, shadow, gshadow without issues. Now when I did this I first ran into the "lowgraphics mode error" and when I went through fix via tty1 cli. The machine now boots up to a gdm based greeter screen but there are no users displayed and no way to login other than a CTRL-ALT-F1. This works and I can login and do anything from the command line but can't seem to fix this issue.
I've searched google and here and maybe I'm missing something....
Any help greatly appreciated.
Thanks,
Bob

Slim Odds
October 19th, 2012, 10:28 PM
10.04 and 12.04 have different defaults for the starting user ID. I don't remember which is which, but one starts at 500, the other uses 1000.

So you might have a little work to do to change from one to the other.

kodb
October 20th, 2012, 08:47 PM
Slim Odds,
Thanks for the hint but when I checked the userid on the systems both my previous versions of passwd from lucid and the new one from precise are starting at 1000.
Still stumped!
Bob