View Full Version : [lubuntu] hard drive not visible for installation of os

October 6th, 2012, 04:34 PM
I have tried multiple distro versions and only slacko puppy will install to the hard drive, however my system requirements are barely adequate for it to operate.

Would like to try Lubuntu to see if it will run smoother. Lubuntu operates from the Live disc fine.

Problems occur when I reach the screen for partitioning the hard drive, my hard drive is not there to choose. I have partition options but the space for the hard drive is blank. If I click to proceed it says no root file defined.

October 6th, 2012, 04:40 PM
This usually happens if the disk has been used in fakeraid before and the raid meta data is still left there. The installer ignores it.

Boot into live mode from the cd first, and in terminal remove the meta data with:
sudo dmraid -E -r /dev/sda

After that it should work fine. NOTE: Don't do this if you are actually running a raid and want to install on it. It will break the array. You install on raid in a different way.

October 6th, 2012, 05:28 PM
No raid arrays to worry about ill give it a try thanks

October 6th, 2012, 07:34 PM
invalid option -- is all I get and nothing happens

any other ideas

October 6th, 2012, 07:37 PM
Make sure the hdd is /dev/sda, it might be different device name especially if you are booting from usb stick.

If you are not sure, check the devices with:
sudo fdisk -l (small L)

That will show the hdd device name.

Also, make sure you type the options correctly, exactly as I posted. Linux makes difference between small characters and capitals.

That message sounds like you either used the command with wrong syntax, or the hdd is not /dev/sda. It might be /dev/sdb or similar.

October 6th, 2012, 07:40 PM
google helped with the format sudo dmraid -Er did the trick now trying the install again hope for the best

October 7th, 2012, 04:54 PM
problem solved that worked thank you for the help