PDA

View Full Version : [ubuntu] 12.04 CD being ignored at boot



one_iota
October 1st, 2012, 11:39 AM
My husband has Natty Narwhal on his Dell Inspiron 1525 laptop.

He wants me to wipe the hard drive and install 12.04 from a CD. He has backed up all his files.

I have downloaded 12.04 and successfully burnt it to a CD (I used my Win 7 laptop to do this, in case this is relevant).

I have changed the boot order on the Dell laptop to make CD the first bootable option.

With the 12.04 CD inserted I rebooted the laptop but it will not boot from the CD. It just whirs a bit then ignores it and boots to the normal Natty Narwhal desktop. I've restarted several times but it keeps ignoring the CD.

Is there something I'm doing wrong? :(

drmrgd
October 1st, 2012, 12:26 PM
The most obvious problem (although you may have already thought of this) is that you just copied the .iso file to the CD rather than using it to make a bootable CD. There should be a function in your burning software that will be called something along the lines of "create disc from ISO image" or something. Be sure to choose that rather than just making a data CD from the ISO.

If you've already considered that, then the other thing to check is that the .iso was not corrupted during the download process. Use the checksum posted where you downloaded the .iso and verify it's intact. Also, something could have gone awry during the burning process. So, you might try making another boot CD just to see if that cures it.

This problem to me sounds like the bootloader is trying the CD, finding no bootable system, and then moving on to the next boot device in the BIOS order.

one_iota
October 1st, 2012, 01:58 PM
Thank you very much for your reply.

That was a good point about whether I had created a CD or just made a data CD so just to be sure I tried burning it again and made sure to select 'Create a disc from ISO'.

I'm not sure whether it matters but I am having to use a DVD disc as the ISO image is too large for the CD disc that I have.

I tried rebooting with the new disc that I created, but it did the same thing - whirred briefly then ignored it.

I don't know if this helps/is relevant, but when I insert and play the new 12.04 disc that I just created, it displays this message:


Unable to mount Ubuntu 12.04.1 LTS i386
Error mounting: mount: block device /dev/sr0 is write-protected, mounting read-only
mount: wrong fs type, bad option, bad superblock on /dev/sr0,
missing codepage or helper program, or other error
In some cases useful info is found in syslog - try
dmesg | tail or so

one_iota
October 1st, 2012, 02:44 PM
I managed to get round the problem by creating a bootable USB stick. 12.04 seems to be successfully installed on the other laptop now (although it seemed extremely quick considering I selected to wipe the hard drive!) Now all I have to do is find out how to get the wireless Internet back working as it hasn't automatically recognized it! *off to google* :lol:

drmrgd
October 1st, 2012, 10:30 PM
Glad to hear you got that worked out. It's a bit strange that 12.04 didn't fit on a CD, but then again, I haven't burned it to a CD in a long time. I'm guessing something went off during the DVD burn. Sounds like you're in (or very close to be once you get the wireless issues sorted) good shape.

one_iota
October 3rd, 2012, 10:30 AM
Thanks! :) In the end, sorting the wireless out turned out to be as simple as flicking the wireless switch off on the laptop and rebooting and luckily it just found the connection when the switch was flicked back on!