View Full Version : [SOLVED] APT Package

September 28th, 2012, 04:45 PM
So my apt package broke and I was having issues running it and was unable to reinstall it using synaptic package manager. So I removed it completely planning on reinstalling it manually from source. However I am having issues doing so.

root@Xavior:~/apt-0.8.16~exp12ubuntu10.3# ./configure
configure: error: cannot run /bin/bash buildlib/config.sub
root@Xavior:~/apt-0.8.16~exp12ubuntu10.3# make
make: autoconf: Command not found
make: *** [configure] Error 127
root@Xavior:~/apt-0.8.16~exp12ubuntu10.3# make install
make: *** No rule to make target `install'. Stop.

any ideas?

September 28th, 2012, 04:50 PM
You only "make" when you are compiling source. You can't do it with a package, you have to use a package manager or open a downloaded package in one.

September 28th, 2012, 04:59 PM
why not download it from here and install it with dpkg -i

September 28th, 2012, 05:14 PM
I did what you said and got the following

matthew@Xavior:~$ sudo dpkg -i apt_0.8.16~exp12ubuntu10.2_amd64.deb
(Reading database ... 392009 files and directories currently installed.)
Preparing to replace apt 0.8.16~exp12ubuntu10.2 (using apt_0.8.16~exp12ubuntu10.2_amd64.deb) ...
Unpacking replacement apt ...
dpkg: dependency problems prevent configuration of apt:
apt depends on libapt-pkg4.12 (>= 0.8.16~exp12ubuntu10.2); however:
Package libapt-pkg4.12 is not installed.
dpkg: error processing apt (--install):
dependency problems - leaving unconfigured
Processing triggers for man-db ...
Errors were encountered while processing:

September 28th, 2012, 08:00 PM
I found the right package and now everything works. thanks

September 28th, 2012, 09:30 PM
I found the right package and now everything works. thanks

if that solved the problem please mark thread as solved.
Good Luck :)