View Full Version : [ubuntu] 12.04 will not install over existing version

September 24th, 2012, 05:17 PM
Installed 12.04 from ISO on CD replacing the Windows 7 and wiping the entire disc. Worked for a couple of days but then wouldn't boot, so did another install again replacing the existing OS.
Again ran into problems so tried another reinstall - buit now VERY slow and seems to get to the bit where you select the language then hangs with the little wheel thingy just rolling round and round.
It is going on to a recent SONY VAIO laptop with 320G HDD amd though it willboot in Ubuntu from the CD it would simply ain't keen on installing onto the HDD.
Any suggestions please??

September 24th, 2012, 05:29 PM
It maybe a problem with UEFI and Secure Boot.

Try Ask Ubuntu (http://askubuntu.com/questions/91484/how-to-boot-ubuntu-from-efi-uefi)

Hope this helps

Wim Sturkenboom
September 24th, 2012, 05:38 PM
Did you check the CD for defects before the latest install? Did you run memtest? Did you run diagnostics tools of the HD manufacturer?

September 24th, 2012, 05:52 PM
memtest returned all OK (took ages though) Can't do any other tests as have no OS on the laptop apart from Ubuntu.
It is simply hanging at the preparing to install Ubuntu screen
Afraid I've no idea what UEFI or secure boot means - machine will boot up and the "install Ubuntu" icon appears on the desktop but you can't get further down the line than that - pretty frustrating!

Did wonder about installing an earlier version to clean the system then installing 12.04 over that, but can't find any earlier downloads - all roads appear to lead to 12.04.

Bucky Ball
September 24th, 2012, 06:11 PM
Thread moved to Installation & Upgrades

Perhaps you could try booting from the CD to a desktop, launch Gparted and delete everything on the partition so it is all free space and try again.

You are clicking 'Something Else' when you get to that part of the install and partitioning manually?

September 24th, 2012, 06:13 PM
Looking for an earlier ISO image?

Try here:



September 24th, 2012, 06:35 PM
Some great ideas there guys - thanks

September 24th, 2012, 07:39 PM
Thanks - it had one huge 200Gig unallocated partition and two tiny ones which looked it looked like the Ubuntu OS had gone into and was trying to reinstall there. I deleted these using Gparted and it has now successfully installes 12.04 (again). But am backing both horses and also have a V10 downloaded to burn onto a CD if necessary!
let's see?:)

Wim Sturkenboom
September 24th, 2012, 09:38 PM
memtest returned all OK (took ages though) Can't do any other tests as have no OS on the laptop apart from Ubuntu.
'Checking the CD for defects' is a functionality on the CD. And the HD manufacturer's diagnostic tools often are available as liveCD as well.

But glad you got it working.

Bucky Ball
September 25th, 2012, 03:46 AM
Great news. Remember: Four partitions is the limit for one physical drive. But an extended partition can hold as many logical drives (effectively partitions) as your hardware can handle. So, three primary partitions already? Add extended. ;)

Good luck, enjoy the learning curve and the OS, and please 'Mark thread as Solved' from Thread Tools if it is.