PDA

View Full Version : [ubuntu] Can't switch desktops / window managers in 12.04 precise



rifter
September 24th, 2012, 12:28 PM
I'm using Ubuntu 12.04 (precise) AMD64.
It used to be that if you installed multiple window managers/desktop environments, you could select them at the login screen. You could also choose multiple options for a given environment (like gnome).
I have installed several window managers, but I don't even see on the new login screen any kind of session options AT ALL. No place for them to even show up. On the left hand side there is a list of users to pick, and if you pick one you get a password field, but no option to change what desktop to use.
I've done a lot of searching but I can't find any site or forum post that explains how to fix this. This is how it was out of the box. It seems like Unity is being forced on me. I would like to go back to fvwm if I can, and I have it installed, but I can't choose anything at login.
Where is this supposed to be? I have looked under every nook and cranny of the login screen and see nothing there that even relates to this.

jerrrys
September 24th, 2012, 08:12 PM
At login, what happens if you click on the icon in the upper right hand corner?

rifter
September 26th, 2012, 06:33 AM
At login, what happens if you click on the icon in the upper right hand corner?

Nothing happens as I recall. I kind of went mad clicking on everything on the screen and not finding anything that did anything useful to me. However, I did find out logging in tonight that the ubuhtu symbol by the username does bring a list of desktops. I could swear I had clicked on everything before, but whatever. It seems to be that that is the place to change it.

I'm not sure where you would change the default anymore though. There used to be an option on the login screen to do that, I thought. Maybe it just remembers the last thing you picked. I'll be trying it in awhile.

jerrrys
September 26th, 2012, 10:55 AM
How bout this
http://www.tejasbarot.com/2012/05/17/howto-change-default-user-session-ubuntu-12-04-lts-precise-pangolin-login-session-desktop-environment/

grahammechanical
September 26th, 2012, 07:28 PM
The last User Interface chosen becomes the default. Just click on the Ubuntu icon on the password panel at the log in screen. By the way, there was information about this months and months ago when 12.04 first came out.

I have fvwm-crystal installed on the 12.10 versions that I am using. Clicking that Ubuntu icon at the password panel brings the menu up for me. It worked when I tested out other desktops because Unity 2D is removed in 12.10 and I wanted a fall-back mode. I have settled on fvwm-crystal.

for those using pre-2012 versions of Ubuntu and thinking about upgrading to 12.04, then expect massive design changes all the way to 14.04.

Regards.