View Full Version : [ubuntu] Google Chrome in 12.04 Install Errors

September 23rd, 2012, 01:19 AM
Having problems installing Google Chrome...

Errors were encountered while processing:

$ sudo apt-get install google-chrome-stable
$ E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

Tried a bunch of potential solutions I found Googling, but no go. I suck at Linux so it could be something stupid... Help please :)

September 23rd, 2012, 03:32 AM
Didn't you (?) already get the answer over at askubuntu.com (http://askubuntu.com/questions/191791/chrome-install-failed-on-ubuntu-12-04)? There it was suggested that you get Chrome from Google's site rather than from wherever you seem to be trying to get it from.

September 23rd, 2012, 04:00 AM
I have tried that actually.

September 23rd, 2012, 04:22 AM
I have tried that actually.
And what happened? You should get into verbose mode if you want a solution :)
The more you explain what happened, even if it's a bunch of nasty-looking errors, the more likely it is that someone may figure things out for you.

"I have tried that actually" just isn't enough.

September 25th, 2012, 04:11 PM
Maybe I can interject as I am having the same problem. I have tried downloading the 32-bit installer from Google's website to the "Downloads" folder. I renamed the *.deb file to chrome.deb and then tried using Terminal and entered the following:
cd /Downloads
sudo dpkg -i chrome.deb

(See attached image).

It did not work. And to be more verbose, it only states that errors were encountered while processing. It appears after processing triggers for man-db.

Any ideas ubuntu gurus? For both of us?

September 25th, 2012, 04:30 PM
(See attached image).
In such cases, don't post an image; it shows only a limited number of lines. Next time copy the entire output and paste it here between code tags (the # symbol above the text area).

Delete whatever you've downloaded. Start afresh and please follow exactly what the download page recommends. I suggest you visit dl.google.com. Also, accept the suggestion to let Google install a ppa.

And when you have the .deb, just right click on it and choose install via Ubuntu Software Center (or words to that effect). No need of terminal heroics ;)