View Full Version : [SOLVED] Avahi, CUPS, Ubuntu!

August 29th, 2012, 02:09 PM
I have Ubuntu Server running on a computer in the back room and a Mac as a client in the living room. Everything is working fine between the two. I can print, share files, everything that you would expect. Recently, I tried to set up CUPS and Avahi so that I can print from my iPad. To do this I have had to create another printer, which I called Airprint. I can see Airprint from my Mac and even print to it. This tells me that I'm not having a CUPS problem and that everything is configured correctly. However, I cannot see Airprint from my iPad. I believe I have Avahi configured wrong but I can't figure out where to go from here. The .service file that I made is below:

<?xml version="1.0" standalone='no'?><!--*-nxml-*-->
<!DOCTYPE service-group SYSTEM "avahi-service.dtd">
<name>HP PhotoSmart Airprint</name>
<txt-record>ty=HP PhotoSmart Airprint</txt-record>
<txt-record>note=HP PhotoSmart Airprint</txt-record>
<txt-record>product=virtual Printer</txt-record>

August 31st, 2012, 02:28 AM
I could not get it to work with the auto generate avahi service script that keeps coming up if you google it. I was, however, able to get it by manually editing the .service file based on this link after much googling