PDA

View Full Version : [SOLVED] 12.04.1-alt-amd64 fails integrity test



znorris
August 26th, 2012, 04:46 PM
1. Download ISO
2. Verify MD5 hash (GOOD)
3. Copy to USB drive (tried Unetbootin and Live Linux USB Creator, also tried two usb drives)
4. boot and run Integrity Test
5. (FAILED) The ./pool/main/x/xserver-xorg-video-ati/xserver-xorg-video-ati_614.99~git20111219.aacbd629-0ubuntu2_amd64.deb file failed the MD5 checksum verification.

Thoughts? I'm at a loss I've verified the ISO, and the USB drives to be good. It's only the alternative CD I'm having problems with.

[EDIT] I also tried http://cdimage.ubuntu.com/daily/current/quantal-alternate-amd64.iso (Aug 24th). And It fails the integrity check as well:
xserver-xorg-video-radeon_6.99.99~git20120713.6ef1ad6a-0ubuntu1_amd64.deb

Thanks,
Zach

Bucky Ball
August 26th, 2012, 04:50 PM
What happens when you try to install it? Choose the 'nomodset' option, from memory, by hitting F6 at the install screen.

* If you want to be certain grab the torrent file and get the ISO that way. The MD5sum is checked on the way.

znorris
August 26th, 2012, 05:49 PM
I get:
"Installation step failed"
An installation step failed. You can try to run the failing item again from the menu, or skip it and choose something else. The failing step is: Select and install software

Syslog:

Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of incoming.
The following information may help to resolve the situation:
The following packages have unmet dependencies:
xserver-xorg-video-all : Depends: xserver-xorg-video-ati but it is not installable
Depends: xserver-xorg-video-nouveau but it is not installable
E: Unable to correct problems, you have held broken packages.

Bucky Ball
August 26th, 2012, 06:32 PM
Are you selecting the software to install? Doesn't look that way. It's asking for things you haven't installed. I've got it right you are using the alternate ISO? It is different to a regular desktop install. May I ask why you're taking this path? To learn more about Ubuntu/Linux?

Also, again, you may need to set the 'nomodset' option before installing.

znorris
August 26th, 2012, 06:43 PM
I'm not selecting anything it's just part of the normal installation process.
Yes I'm using the alt install. The reason is to utilize encrypted LVM.

I'm not sure how nomodeset will help. It's not until I've setup a usr, partitioned and started installing packages that the installation fails (the graphical installation works fine, which I believe is what nomodeset is used to fix).
[EDIT] Even though I didn't think it would help I did try 'nomodeset'. Install fails as usual.
The real problem is the ATI package is failing an integrity check but the ISO is not. Perhaps this ATI package is bad in the repository?

znorris
August 26th, 2012, 07:45 PM
I'm able to replicate this over and over again so I went ahead and submitted a bug report.
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1041911

Bucky Ball
August 27th, 2012, 04:18 AM
Why don't you just install packages? That is what the alt install is for, which is what I'm saying.


sudo apt-get fglrx fglrx-amdcccle ... will Install the ATI packages. You should make a list of what you want on your system then install that after the base install has finished and it asks; 'What packages do you want to install' or whatever. Please read up here:

https://help.ubuntu.com/community/Installation

And here:

http://www.wikihow.com/Install-Ubuntu-Linux

On reboot you should be looking at a command line system (which is what is supposed to happen as you haven't installed a DE yet):


sudo apt-get install xorg xterm wdm fluxbox
... replacing fluxbox with the DE of your choice ...

To this you might add 'brasero gcc git synaptics gimp' ... whatever you like. As I say, plan this. Good luck.

jibawakee
August 27th, 2012, 04:19 AM
try using the boot flags at boot up

znorris
August 27th, 2012, 04:51 AM
Thanks for your suggestions!

* I used Live Linux USB Creator to create a bootable 12.04.1-desktop-amd64 drive.
* I then used that ubuntu install (on second thought leaving it in live mode would have been smarter).
* Then used dd to copy the alt iso to the usb drive.
* I then booted that drive, ran a disk check which completed successfully.
* Installation went fine.

What the hell? I'm confused because while I would be happy to blame windows it still doesn't make any sense. Why would it always be the ATI deb file that was corrupted? I tried multiple drives so that couldn't have been it.

So if you're having odd problems like me, try booting into linux and making the USB drive with dd instead of fancy GUI apps.

If anyone has thoughts I would love to hear them. I'm really scratching my head here, it's working but this will drive me nuts.

omn
September 6th, 2012, 02:59 AM
I can verify that I had the same problem with creating a live USB with the AMD 64 alternate Ubuntu 12.04 and 12.04.1 images

I didn't have a working linux box to use to make the live USB with 'dd' but I was able to successfully use OSX to achieve the same thing.

I had trouble finding a good post on how to do this (I found several conflicting instuctions), so here's what I did:


diskutil list

insert usb drive


diskutil list

check what the DRIVE address for the USB is, mine was /dev/disk2


diskutil unmountDisk /dev/disk2

sudo dd if=/path/to/ubuntu-12.04.1-alternate-amd64.iso of=/dev/disk2 bs=1m

distutil eject

and you're good to go.


Thank you very much znorris, I struggled with this on and off for a couple of weeks and made no progress until I found this thread.

psychok9
February 3rd, 2013, 03:23 PM
I confirm this bug!
Every USB makers I've tried, have this problem.
If you try to install it, it stops at "xserver-xorg-video-ati/xserver-xorg-video-ati_614.99~git20111219.aacbd629-0ubuntu2_amd64.deb" file and you can't complete the installation.

Thanks for the DD workaround!

Ubuntwerp
February 18th, 2013, 05:48 PM
I confirm this problem. I had created a usb boot of the alternate amd64 image from within Windows with the pendrive installer and the installation process would halt all the time at this step 'selecting and installing software'

I tried the suggestion to use dd to write the install image to the usb-stick and the installation process went flawlessly.
Thanks!

There is something funny going on with the creation of usb boot disks in windows. Earlier, I tried to make a usb-boot of winxp with BartPe and this would also run into problems when booting. Then, I read the suggestion to actually write the usb-disk while using winxp itself (before i used win7) and then it worked well.
I wonder if writing the amd64 alternate image from a windows xp environment would yield the same problem. But, since these OS's are so different it probably won't make any difference. The similarity with regards to that it actually matters in which environment you write your usb-image is striking, though.