View Full Version : [SOLVED] Changing /home partition

August 24th, 2012, 04:34 PM
I started using Ubuntu on my macbook back at the beginning of this year and though 50Gb would be plenty of room for everything. I'm getting close to the point where I'm running low ~75% space used. I have a huge chunk of space available on the disk, but there are other partitions in the way. Take a look at my partitions and let me know what the best option is. I would like to combine my current /home partition with that huge free space, but I'm not sure if that is an option.

The other option is to just use the big free partition as my /home.
Could I just do
dd if=/dev/home/partition of=/dev/new/partition
Then change my /home partition in fstab?


August 24th, 2012, 06:19 PM
Moved to Apple sub-forum.

I do not know Macs but with gpt do not use any dd type programs. With Windows in a Mac you have to have the hybrid MBR/gpt configuration. The Mac is an older UEFI system and Window is still in BIOS with MBR. Paritions for the Mac are gpt but Windows only boots from gpt with a newer UEFI or BIOS/MBR.


The author of gdisk posted once here not to use dd as gpt partitions have internal structures that cannot be bit by bit copied without creating issues.

Someone with a Mac should really comment, but I would think you can copy with rsync.

To move /home uses rsync- Be sure to use parameters to preserve ownership & permissions

August 25th, 2012, 03:11 AM
Thank you. Very useful to know before I go ahead and try it only to make a mess of everything. Any apple users have any knowledge?


August 27th, 2012, 05:38 PM
Following this,
I got as far as renaming /home to /old_home, but terminal says that device or resource is busy and it can't mv it.

Not sure what to do.

Here's another shot of my partitions.


August 27th, 2012, 06:14 PM
Did you change to / ?

cd / && sudo mv /home /old_home && cd / && sudo mkdir -p /home

August 27th, 2012, 07:43 PM
Yes I did. Eventually I just changed fstab to not mount my old /home partition and instead to mount the new one. I've been using the new /home partition for an hour or so without problems now. I'm just going to reformat the partition I don't need anymore and leave it empty for now. I'm ending up with about the same result.

For reference if anyone else encounters this issue I'm attaching my original fstab and the modified (current) fstab, along with a snapshot of my current partition layout.


Thank you oldfred


August 27th, 2012, 09:39 PM
Glad it worked. :)