PDA

View Full Version : [SOLVED] MySQL problems



jpcjr
August 19th, 2012, 04:37 AM
Hi all,

I had a functional lamp, mail and samba server until the hdd croaked =(

I have replaced the drive and installed esxi host this time and installed the lamp server, gotten email functional. But after I installed the vmware tools inside the vm mysql has quit working. All attempts to bring it back up fail. Please help

I have a screenshot of the error

spjackson
August 19th, 2012, 09:38 AM
It looks like you have no /tmp directory.


ls -l /
ls -l /tmp/

LHammonds
August 19th, 2012, 03:59 PM
The only times I ran into problems running my server is when I have run out of space. Make sure the important partitions are not full.


df -h

LHammonds

jpcjr
August 19th, 2012, 06:08 PM
Thanks for the replies and sorry it has taken me so long to reply. I did delete the tmp directory when vmware tools had an install issue that I finally resolved. I guess I am still used to windows where the tmp directories get recreated.

I have now made a new tmp directory and am rebooting the server.

What permissions does the /tmp/ directory need?

LHammonds
August 19th, 2012, 06:43 PM
What permissions does the /tmp/ directory need?All of them including the sticky bit.

IIRC: chmod 1777

jpcjr
August 19th, 2012, 06:45 PM
Thank you both so much! I had just finally found that command through my seemingly endless google search, lol. I am back in business.

You guys rock! :guitar: