View Full Version : [PPC] Lubuntu 12.04 - No Sound After Suspend

August 15th, 2012, 02:45 AM
I installed Lubuntu 12.04 onto my iBook G4, and while everything's fine and dandy, but there's one annoying problem, and that is that there's no sound after resuming from suspend. If I restart the computer the sound comes back on, but nothing else works. I tried:

rmmod snd_powermac, but it says that it's being used
alsa force-reload, but it fails to unload some modules, including snd_powermac
Restarting alsa-utils, but that doesn't even exist!

So, anyone has a solution/suggestion or am I stuck with half-working sound?

August 15th, 2012, 10:28 AM
Have you tried something very simple like opening alsamixer and checked if some kind of setting for some weird reason has changed?

August 15th, 2012, 06:28 PM
Yeah, I checked alsamixer and it doesn't seem like anything's muted. I also installed pavucontrol to monitor sound-playing applications and it plays as if nothing is wrong.

August 15th, 2012, 07:02 PM
Very strage, I have not ran into the same issue my self, and cannot think of a thing that can cause it. I had trouble with no sound right after lubuntu install, there was no alsamixer in thermial, not a thing. I had to reinstall alsamixer and I was guided to a ppc *** page with suggestion for fixed. I ran some sudo commands I cannot remember at the moment and sound has been fine since. I also have a G4 iBook. Here (http://ubuntuforums.org/showthread.php?t=2020131&highlight=G4+iBook&page=2) is a link to the help I was given, if it applies to your situation.

August 16th, 2012, 03:42 AM
Thanks for the help, but that doesn't seem to be the issue. Everything is working absolutely great, and that glitch is the only problem on this computer.

August 22nd, 2012, 04:09 AM
I have the exact same issue. A solution would be great :)

I am using sound blaster live card

November 9th, 2012, 04:32 AM
Has anyone had any more insight on this issue? I am experiencing exactly the same thing, with my PowerBook G4 and the standard sound card -- audio works fine until I suspend, then it stops working. After a restart, it works fine.

However, I did notice a tiny bit of sound coming out of my speakers while playing an mp3 in VLC. Sure enough, after I boosted the preamp in the EQ settings, and plugged the computer into an external stereo amp, and cranked the volume up all the way, there was my mp3 playing, very, very quietly!

So, at least on my system, the issue is technically very very quiet sound after suspend. Any ideas on what would make that happen?

November 20th, 2012, 05:33 AM
Exactly the same issue in Lubuntu 12.04, ibook G4 1.07 ghz. Sound is muted on waking from sleep, barely audible. Reboot fixes the problem. Any solution greatly appreciated.