PDA

View Full Version : [ubuntu] Changing the keyboard layout language



rophys
August 15th, 2012, 12:55 AM
Hi all,

I just installed the Ubuntu 12.04 in my laptop and I'm having some problems to add a new keyboard layout. I tried the "keyboard input method" but there is no languages in the list. How can I solve this issue ?
Thanks

OM55
August 15th, 2012, 01:34 AM
Go to: "System Settings -> Keyboard Layout" (there are two icons starting with the name 'Keyboard' so make sure you select the correct one).
Select the "Layouts" tab and then click on the "+" sign at the lower left corner.
This will allow you to add an additional language layout to the keyboard.

Warning: Before you select the "Layouts" tab, the initial screen shows a list of a few languages. Those are the interface languages.
BE VERY CAREFUL NOT to click on any of the languages because the change is made as soon as you highlight it, but will become into effect only after reboot. However, unless you are fluent with all the those languages, you might find yourself with a foreign language interface without the being able to read the text in order to change it back to English...

If you need to define specific shortcuts to change between keyboard layout, you can goto "System Settings -> Keyboard" (notice that this is a different selection than the first one).

rophys
August 15th, 2012, 01:03 PM
OM55, thanks for this. Your tip was very useful and the keyboard layout is working now.
Cheers

OM55
August 15th, 2012, 04:20 PM
Glad I was able to help!

(Now you can change the status of this thread to 'Solved' for others to see...).