View Full Version : [SOLVED] 12.04 stuck in Partial Upgrade

August 14th, 2012, 09:55 AM
When I run update manager in 12.04, it wants to do a partial upgrade for some reason. When I commit it I get the following "Can't guess meta-package error"...


If I remove ubuntu-desktop then try again I get an error with it trying to remove unity when its on a blacklist, looks like it might be trying to remove a lot of packages on my system :S

Frogs Hair
August 14th, 2012, 02:51 PM
It reads like you have removed some key desktop dependencies. Are you receiving only recommended updates ?

August 14th, 2012, 02:56 PM
Yes I am, any way I can fix these dependencies?

Frogs Hair
August 14th, 2012, 09:52 PM
You can try the following command but I don't understand the part about unity and blacklist.

sudo apt-get install --reinstall ubuntu-desktop

August 16th, 2012, 09:16 AM
I managed to do some upgrades, but after those it went back to wanting to do a partial upgrade with the same error :(

August 16th, 2012, 09:20 AM
Seems like
sudo dpkg --configure -a and
sudo apt-get -f install are the magical commands.

sudo apt-get update after you run those two commands.

August 16th, 2012, 09:28 AM
Tried the commands and when I launch update manager it still wants to do a partial update, here's a screenshot of what it wants to install...


August 16th, 2012, 09:35 AM
Review your software sources, and remove any unused or outdated repositories.

Try one (or more) of these:

(remove unmet dependencies)
sudo apt-get -f install

(remove .deb archives from packages no longer installed)
sudo apt-get autoclean

(clear files from Aptitude cache: /var/cache/apt/archives )
sudo apt-get clean

Post the output of an update & upgrade:

sudo apt-get update && sudo apt-get upgrade


sudo apt-get install aptitude

and then run

sudo aptitude

Or Install Synaptic if you don't have it and in the edit menu run "Fix broken packages" . If that doesn't work I'm out of ideas.

Best of luck.

August 16th, 2012, 09:48 AM
Seem to have found the problem, our work repo was trying to push some squeeze packages to my box, once disabled the problem has gone. Thanks for your help! :)

August 16th, 2012, 09:51 AM
Happy to help. Mark this thread as solved from thread tools.