View Full Version : [ubuntu] Wow...Missing dev

August 11th, 2012, 01:25 PM
Okay...Totally lost here. Decided to use a 12.04 installation cd (AMD64) to upgrade my 11.10 (AMD64) system. I didn't want to wait for it to download everything because I mainly work off of the ubuntu system. Well, genius here, started the upgrade and when it tried to find profiles for me to suck into 12.04 it couldn't find anything. Wellllllll, I decided to cancel the upgrade (series of button clicks) and just try the download another day (wanted my profile). I then get an error saying something to the effect that it couldn't find a way to start up ubuntu which led me to believe that the sdb2 was improperly unmounted (i.e. stuck). I got a live-cd (11.10) and tried to mount and chroot sdb2 but failed. Upon some exploring on sdb2, behold I don't have a dev directory!!! I see everything else, my profiles in home and happy files that I don't want to loose. Of course, I'm asking how the &@%!!*$ did that happen and then what #%**^%^@ do I do? LOL

Any help would be appreciated.

August 11th, 2012, 05:44 PM
no /dev means you can do a fresh install now :P it's the best and fastest solution; might not be a problem if you still have a separate /home partition.

August 11th, 2012, 06:00 PM
"happy files"
I loled too hard on this :)
I am with dino99 !
A fresh install is always a good and fast way to solve problems that you created yourself.