PDA

View Full Version : No sound in flash? Try this.



calx
June 26th, 2006, 03:59 PM
After weeks of searching for a solution, this has finally got sound in flash working for me. :-D

https://launchpad.net/distros/ubuntu/+source/flashplugin-nonfree/+bug/29760


# Flash also looks for /usr/lib/libesd.so.1
sudo ln -s /usr/lib/libesd.so.0 /usr/lib/libesd.so.1

# Flash expects /tmp/.esd/socket to exist.
sudo mkdir -p /tmp/.esd/
sudo touch /tmp/.esd/socket

Dr. Nick
June 26th, 2006, 05:58 PM
Thanks for this,

I was sorta stumped as to why sound worked in firefox but not epiphany. That fixed it all up for me

mustang
June 26th, 2006, 10:54 PM
Oh my god! You are my saviour!!! I have tried for hours and I always got choppy sound when playing flash video. It is finally fixed. I can now watch youtube and google videos without having to download them and convert.

Thank you so much calx. You made my day!

flibble
June 26th, 2006, 11:31 PM
Yeeee Haaaaaaa! I've read so many posts about this, including all the "can't be fixed, wait for flash 9, yadda yadda". This fix works perfectly for me on dapper. Now I can watch all that pointless, moronic flash content! Thank you.

souled
June 27th, 2006, 02:56 AM
I'm currently using this asound.conf to get my optical out working:
pcm.!default {
type plug
slave.pcm "dmixer"
}

pcm.dmixer {
type dmix
ipc_key 1024
slave {
pcm "hw:0,1"
format S32_LE
period_time 0
period_size 1024

# increased buffer_size because in my system 1024 cause bad
# audio performance (for totem media player and mplayer)
buffer_size 8096

rate 44100
}
bindings {
0 0
1 1
}
}

ctl.dmixer {
type hw
card 0
device 1
}

#


The commands provided in this howto don't enable sound for me in Flash. Can anyone help me with this?

bluecrayon
June 27th, 2006, 04:13 AM
THANK YOU! I've tried so many different tips on this forum and this finally worked. Now to get surround sound working...

Dr. Nick
June 27th, 2006, 05:50 AM
Very odd.

Before running this I had sound with flash in firefox but not epiphany.

After I have sound in epiphany but now no sound in firefox.

Its not a huge problem now, just a bit puzzled. Anyone notice similar, or have ideas as to a fix? I may just undo it for now since I use FF more than epiphany

mohasr
June 27th, 2006, 06:22 AM
I also had no sound in flash videos , but I noticed that if I played some audio file in totem then watched the flash video the sound works ...

BlacKsheep88
June 27th, 2006, 07:58 PM
Now I can't play flash videos period

userundefine
June 27th, 2006, 08:31 PM
Impressive work !

Edit: I'm experiencing out-of-sync audio with flash sound, it's off by about a half-second. Anyone else getting this?

popdog
June 27th, 2006, 08:50 PM
Excellent, this worked perfectly for me thanks! I think in my case having two soundcards (one Audigy 2 ZS and an onboard one) caused the problems.

krye
June 27th, 2006, 11:41 PM
Worked PERFECTLY here. Thanks a lot!!

BlackwaterPark
June 28th, 2006, 02:09 AM
Impressive work !

Edit: I'm experiencing out-of-sync audio with flash sound, it's off by about a half-second. Anyone else getting this?

Yeah I am too, you can notice the lag issue when you are playing something and you close the tab - the sound keeps going for that fraction of a second

MetalMusicAddict
June 28th, 2006, 03:29 AM
Works here also.

Impressive work !

Edit: I'm experiencing out-of-sync audio with flash sound, it's off by about a half-second. Anyone else getting this?
For me some things go out of sink but somethings dont.

unixping
June 28th, 2006, 05:17 AM
I agree with these guys, your commands fixed the problem of getting sound. But now it's all out of sync.....anyone?

DTPHawk
June 28th, 2006, 07:07 AM
I am currently experiencing the same problem. I was browsing videos at youtube.com and noticed a sync problem immediatly. Hope we see a fix soon. Thanks alot

markmark
June 28th, 2006, 07:27 AM
I am currently experiencing the same problem. I was browsing videos at youtube.com and noticed a sync problem immediatly. Hope we see a fix soon. Thanks alotOut of sync sound in flash has been a problem for a loooooooong time. This (http://ubuntuforums.org/showthread.php?t=186594) is a solution that worked for some people.

kjkrum
June 28th, 2006, 04:22 PM
Edit: I'm experiencing out-of-sync audio with flash sound, it's off by about a half-second. Anyone else getting this?

Yes. But I also get the exact same problem with Firefox on WinXP.

Xzallion
June 28th, 2006, 08:25 PM
This didn't work for me. :(

monomaniacpat
June 29th, 2006, 11:58 PM
I tried the aoss solution but couldn't get it to load with firefox automatically. This worked first time - thanks!:grin:

spockrock
June 30th, 2006, 02:06 AM
this works thank you so much!

spockrock
July 4th, 2006, 06:09 AM
ok I have to do this everytime I reboot anyway I can do this without having to do it everytime at I restart ubuntu?

nrayever
July 15th, 2006, 07:31 PM
it's not working for me. i have a intel hda sound card on my laptop, and i have to restart firefox several time before listening to flash sound.

Polygon
July 16th, 2006, 08:28 AM
ok I have to do this everytime I reboot anyway I can do this without having to do it everytime at I restart ubuntu?

i also have to re-enter the commands every time i reboot, oh well, 1 minutes is enough to have flash working again!

CronoDekar
July 16th, 2006, 01:28 PM
Try putting the commands in /etc/rc.local to get it working on bootup . I had got a different set of instructions which got Flash sound working for me (though still with frequent lag), and this is what I put in it:

mkdir /tmp/.esd ln -s /tmp/.esd-1000/socket /tmp/.esd/

lnicolao
August 1st, 2006, 12:14 AM
Great solution!
Changing firefox config to aoss or calling "aoss firefox %u" would eventually crash my FireFox. This seems to be working so far.

mkquist
August 28th, 2006, 09:45 AM
[-o< just a quick Thankyou, that much closer to being all sorted out.. \\:D/

rko618
August 28th, 2006, 10:34 AM
I only get no sound in flash if I am running another application that has sound (like a music player). If I close the music player and restart firefox then flash sound usually works. Will this fix my problem?

Scythe!?
August 28th, 2006, 03:16 PM
Impressive work !

Edit: I'm experiencing out-of-sync audio with flash sound, it's off by about a half-second. Anyone else getting this?

Yep, I'm getting out of sync audio too.

Scythe!?
August 28th, 2006, 03:20 PM
Try putting the commands in /etc/rc.local to get it working on bootup . I had got a different set of instructions which got Flash sound working for me (though still with frequent lag), and this is what I put in it:

mkdir /tmp/.esd ln -s /tmp/.esd-1000/socket /tmp/.esd/
How do I put the commands into /etc/rc.local? what do i have to do?

cvmostert
August 30th, 2006, 10:27 PM
After weeks of searching for a solution, this has finally got sound in flash working for me. :-D

https://launchpad.net/distros/ubuntu/+source/flashplugin-nonfree/+bug/29760


# Flash also looks for /usr/lib/libesd.so.1
sudo ln -s /usr/lib/libesd.so.0 /usr/lib/libesd.so.1

# Flash expects /tmp/.esd/socket to exist.
sudo mkdir -p /tmp/.esd/
sudo touch /tmp/.esd/socket

Thank you, it worked for me aswell... now i just have to get my screen to stop blinking when i start and stop playing a video file....

cheers

rynop
October 4th, 2006, 12:57 AM
THANK YOU!!!! i have searched for this fix for so long its not even funny

VCSkier
October 5th, 2006, 06:07 AM
this worked great for me. thanks!

chakkid
October 21st, 2006, 11:01 PM
a 1000 thanks for ya!:) :) :) i subscribed this thread, hoe you don't mind:P.

askreet
November 17th, 2006, 03:09 AM
Worked for me, thanks a bunch!

uboltun
January 1st, 2007, 11:55 PM
Thanks a bunch, worked for me too.

wilem
January 11th, 2007, 04:37 AM
This worked for me as well.

<3

HiP.P
January 18th, 2007, 03:45 PM
Cheers man worked for me


After weeks of searching for a solution, this has finally got sound in flash working for me. :-D

https://launchpad.net/distros/ubuntu/+source/flashplugin-nonfree/+bug/29760


# Flash also looks for /usr/lib/libesd.so.1
sudo ln -s /usr/lib/libesd.so.0 /usr/lib/libesd.so.1

# Flash expects /tmp/.esd/socket to exist.
sudo mkdir -p /tmp/.esd/
sudo touch /tmp/.esd/socket

mohdridha
January 23rd, 2007, 03:03 PM
but my files point to other files



kapla@mrn: /usr/lib$ ls -l libesd*
-rw-r--r-- 1 root root 37834 2006-03-28 19:43 libesd.a
-rw-r--r-- 1 root root 833 2006-03-28 19:43 libesd.la
lrwxrwxrwx 1 root root 16 2007-01-03 04:14 libesd.so -> libesd.so.0.2.36
lrwxrwxrwx 1 root root 16 2006-12-12 05:35 libesd.so.0 -> libesd.so.0.2.36
-rw-r--r-- 1 root root 37400 2006-03-28 19:43 libesd.so.0.2.36


i dont have this file libesd.so.1

so i cant make this link:
sudo ln -s /usr/lib/libesd.so.0 /usr/lib/libesd.so.1



# Flash expects /tmp/.esd/socket to exist.
sudo mkdir -p /tmp/.esd/
sudo touch /tmp/.esd/socket


Is this a must do thing?:confused:

uboltun
March 22nd, 2007, 02:35 AM
Worked for version 7 but vesion 9 - still no sound ...

dcroxton
March 25th, 2007, 02:24 AM
I still get no sound.

I just discovered this way to get IE running on Linux: http://www.tatanka.com.br/ies4linux/page/Main_Page. And Flash works fine in IE -- weird.

I'm glad I have a way to view flash content in Linux now. However, it is frustrating to have to run IE to do it. I will be glad when this issue is sorted out.

Sincerely,
Derek

treeby
May 2nd, 2007, 01:56 AM
now i have no sound AND no video...how do i undo this? thanks anyway...

avelez89
July 22nd, 2007, 01:17 AM
I also experienced no sound in Flash although sound seemed to worked in all other applications.

If you have 2 sound cards this might be the cause of your problem (it was the cause of mine.) I have an Intel Integrated sound card and an Audigy2 sound card. Although i had selected Audigy2 sound cards as my default through System >> Preferences >> Sound the issue still persisted.
I then had to change my default sound card through the Terminal using the following guide:
http://ubuntuguide.org/wiki/Ubuntu:Feisty#How_to_change_default_soundcard

SLA_leandrin
July 29th, 2007, 11:40 PM
Hi.
I've tryied everything, but the only solution that worked for me is installing PulseAudio, now flash sound works excellent in youtube.
Give it a try.

I've followed this guide (http://ubuntuguide.org/wiki/Ubuntu:Feisty#How_to_setup_PulseAudio_Sound_Server )

Bye!!!:)

aaaantoine
August 5th, 2007, 01:56 AM
Hi.
I've tryied everything, but the only solution that worked for me is installing PulseAudio, now flash sound works excellent in youtube.
Give it a try.

I've followed this guide (http://ubuntuguide.org/wiki/Ubuntu:Feisty#How_to_setup_PulseAudio_Sound_Server )

Bye!!!:)

The libflashsupport file they link to is for i386. From what I've seen, there's no AMD64 version.

I tried to compile the source of libflashsupport but it requires some header files:



flashsupport.c:193:25: error: openssl/ssl.h: No such file or directory
flashsupport.c:218:17: error: esd.h: No such file or directory
flashsupport.c:225:26: error: pulse/simple.h: No such file or directory
flashsupport.c:226:25: error: pulse/error.h: No such file or directory

Xizorbg
September 8th, 2007, 11:27 PM
Hey Guys-

This is my asound.conf-


using SPDIF cannot get sound on flash using this fixit.....

any ideas?
# asound.conf for an M-Audio Revolution and an Audigy.
# (The Audigy/emu10k1 stuff should be easy to remove if you don't need it...)

pcm.revolution {
type hw
card 0
}

pcm.emu10k1 {
type hw
card 1
}

# ICE1712 dmix:
pcm.ossmix {
type dmix
ipc_key 1024
slave {
pcm "hw:0,0"
format S32_LE
period_time 0
period_size 1024
buffer_size 9000 # buffer size < 6653, but pow(x, 2)
rate 44100 # we want to play CDs only
}
bindings {
0 0
1 1
}
}
#######################################
# Allow reading from the default device.
# Also known as record or capture.
pcm.dsnooper {
type dsnoop
ipc_key 2048
slave.pcm "revolution"

bindings {
0 0
1 1
}
}

# This is what we want as our default device
# a fully duplex (read/write) audio device.
pcm.duplex {
type asym
playback.pcm "ossmix"
capture.pcm "dsnooper"
}

pcm.softvol {
type softvol
slave.pcm "duplex"
control {
name "PCM Volume"
card 0
}
}
#######################################
# Everything running through softvol -> dmixed, so redefine "default":
pcm.!default {
type plug
#slave.pcm "ossmix"
slave.pcm "duplex"
slave.pcm "softvol"
slave.pcm "spdif"
}

# OSS via aoss should d(mix)stroyed:
pcm.dsp {
type plug
#slave.pcm "ossmix"
slave.pcm "duplex"
}

ctl.mixer {
type hw
card 0
}

bitwise5
November 8th, 2007, 06:16 AM
Common solution I've seen is to try and use esd; I was hoping to avoid this. I had flash working fine under fiesty, using ALSA, so why not with gusty?
Because my old config files were still hanging around my home directory. oops.


~$ mv ~/.asoundrc ~/.asoundrc.old
~$ mv ~/.asoundrc.asoundconf ~/.asoundrc.asoundconf.old


Restart firefox, that's it.

Defrector
November 8th, 2007, 04:25 PM
ack.

I've been wrestling with this problem ever since upgrading to kubuntu 7.10. Tried the firefoxrc fix, it seemed to work, then sound in flash broke again for firefox. Thought the conf file was reverted somehow but it was the way I left it.

I tried the eossd wrapper or whatever it is called and that didn't work.

Tried some other tricks found on the forums involving linking and moving directories around... again it fixed it, then after some everyday desktop use it randomly broke again. It's as if the fixes were one-shot and some gremlin in the system found another way to break it!

So far the #1 solution for me has been to just use Konqueror for sound-related flash. It seems to work fine in there.

... but this has gotta be fixed sometime... From what I've read in other posts, the implementors and developers are aware and working on the issue... though they all seem to have their own flavor of temporarily fixing it until the issue is ironed out!

Defrector
November 9th, 2007, 05:57 PM
I spoke too soon. Flash sound on Konqueror just went out as well. I think it may have to do with using wine for other programs and then launching a browser, maybe with grabbing the dsp or sound daemon or something; don't know for sure. I double checked to see if flash in firefox had sound again but alas it didn't.

In a last ditch effort I got IE4Linux and am using that for flash-based stuff. It's working quite well, for now. Perhaps it is immune to the issue until the flash->firefox/mozilla sound issue irons out. Perhaps windows firefox will run in wine w/o flash sound issues too? Something to try. If THAT manages to fail then I think I need therapy. :)

JustAboutRealJAR
November 9th, 2007, 10:15 PM
After weeks of searching for a solution, this has finally got sound in flash working for...

Updated for Gutsy at http://ubuntuforums.org/showthread.php?t=590989

helpdeskdan
December 10th, 2007, 01:21 AM
Another Thkx - worked great

ladgrove
February 12th, 2008, 02:15 AM
For 64-bit Ubuntu users who still have no sound in Flash after trying all the aforementioned solutions, it may prove worthwhile to visit www.alsa-project.org & download & install the newest:

alsa-driver-1.0.16
alsa-lib-1.0.16
alsa-firmware-1.0.16.

For anyone uncertain on how to do this, it's just a matter of extracting the downloaded files either graphically by right clicking on the file and choosing extract, or in the terminal by typing:


tar -jxvf alsa-driver-1.0.16.tar.bz2

Once the files are extracted, change to the appropriate folder, there'll be 3 in this case for the driver, lib & firmware, and start by doing


sudo ./configure
sudo make
sudo make install

This will update your alsa firmware, drivers and libraries. Also, I tried another solution, which did not work prior to doing this update, but as I now have sound for flash in 64-bit Ubuntu, I may as well include it. Edit your firefoxrc file by doing:


sudo gedit /etc/firefox/firefoxrc

and edit the line that says


FIREFOX_DSP=""

to


FIREFOX_DSP="aoss"

Again, I'm not sure this is actually helping, but as it worked for my setup, it may as well be mentioned.

Then, in Menu/Preferences/Sound, choose autodetect or manually select your soundcard and reboot.

Hopefully, you may now have sound working in Flash. If you don't, keep searching Google, because I tried every other solution available and this was the only one that worked for me, so I'm not certain I can offer further advice, but I hope this works for you.

ladgrove
February 12th, 2008, 08:32 AM
As an update to my previous post above, after updating the ALSA components as mentioned, I now have 2 choices for Device in Sound/Preferences. Interestingly, when I select the ALSA mixer, I get sound in all other applications but not flash & when I select the OSS mixer, I get sound in flash and all other applications except for view mpegs etc in MPlayer.

This is not so bothersome for me, and as I don't use flash all that much, I'm happy to manually switch whenever it suits my needs, that's the price you pay for using 64-bit. However, I'm not much of a hacker, but I'm quite certain these preferences could be automatically switched somehow when FireFox or Mplayer are loaded.

If I find a solution to this, I'll post it ASAP.

Cheers, sorry for the dual posts.

neroblue
May 5th, 2008, 11:29 AM
Hi,
I had a similar problem and all the fixes I found wouldn't work for me. In the end a not very smart but easy solution worked!

I didn't have any problems with the sound in Flash until I messed around different audio plugins to listen to online radio stations.

Next day I start the laptop and there's no sound any more in Flash videos. Rhythmbox and VLC media player were fine.

I uninstalled all the real media, windows media and gstreamer plugins I had installed (gstreamer "bad" being one of them, the only one I remember because of the funny name). It still didn't work. Then I uninstalled Totem Video Player and voila! I could play Flash movies with sound!

I had to install also gstreamer "ugly" later for my music player to work too, and thatś it.

Hope this helps anybody,

Cheers!

cim
May 13th, 2008, 10:20 AM
I have another solution to this, I have Ubuntu Hardy 8.04 installed and found another way to fix the no sound problem.

1. System > Administration > Synaptic Package Manager
2. Search: pulseaudio
3. Check the box of libflashsupport
4. Apply

You may or may not restart Firefox, enjoy.

kladdert
May 14th, 2008, 03:18 PM
Thanx man. Cheers :)

Worked perfectly after rebbot. Recommended!

cim
May 15th, 2008, 08:55 AM
No problem, I am a newbie also so I am just trying to help out lol.

amisdar
May 21st, 2008, 03:24 PM
I have another solution to this, I have Ubuntu Hardy 8.04 installed and found another way to fix the no sound problem.

1. System > Administration > Synaptic Package Manager
2. Search: pulseaudio
3. Check the box of libflashsupport
4. Apply

You may or may not restart Firefox, enjoy.

Great! This trick fixed my Ubuntu Hardy 8.04 sound problem! :-)

Thank you!

cim
May 28th, 2008, 03:06 PM
You are welcomed! =]

psyke83
May 29th, 2008, 03:54 AM
For Hardy users, this guide is obsolete. With the inclusion of PulseAudio, Flash has some issues that are not yet resolved officially, but my guide gives a "preview" of official fixes. Please see my guide here: http://ubuntuforums.org/showthread.php?t=789578

mastersync
June 3rd, 2008, 08:46 AM
It works but my default sound (mp3s, videos) doesn't work. How do i reverse this ?

Dedors
June 18th, 2008, 04:56 PM
fix worked

thanks

nachosDP
July 18th, 2008, 05:13 AM
i did this and now flash is not working at all and tried everything i could think of to get it back( which is uninstalling and reinstalling it in different ways). i am faily new to ubuntu. if i go to a flash video it says install the missing plugins. ok . then it says adobe flash player and i click next then it says adobe flash player -- not avalable and install is grayed out and there is only a manual install option which takes you to adobes web site and i follow the instructions for a tar.gz copy and paste the code to the terminal and it says NO! you are useing a 64bit and then nothing. please help

JustAboutRealJAR
July 19th, 2008, 08:37 PM
Adobe still refuses to compile their flash player for 64 bit linux, so you have to run the 32 bit version of flash instead. needless to say, it's a bit of a hack, but it works just fine.

There are instructions on how to do it over here: http://ubuntuforums.org/showthread.php?t=772490

hope it helps... :)

nachosDP
July 21st, 2008, 04:43 PM
i did this and now flash is not working at all and tried everything i could think of to get it back( which is uninstalling and reinstalling it in different ways). i am faily new to ubuntu. if i go to a flash video it says install the missing plugins. ok . then it says adobe flash player and i click next then it says adobe flash player -- not avalable and install is grayed out and there is only a manual install option which takes you to adobes web site and i follow the instructions for a tar.gz copy and paste the code to the terminal and it says NO! you are useing a 64bit and then nothing. please help

this worked to get flash back but only in 64bit firefox:

sudo aptitude purge mozilla-plugin-gnash && sudo aptitude install flashplugin-nonfree libflashsupport

****this is all one line of code*****

iaskedalice09
August 30th, 2008, 10:39 PM
The OP's fix didn't work for me, but this did.

In terminal, type

sudo apt-get install libflashsupport

Restart Firefox, and voila!

r337ard
October 12th, 2008, 07:04 AM
The OP's fix didn't work for me, but this did.

In terminal, type

sudo apt-get install libflashsupport

Restart Firefox, and voila!

Woot, this worked perfectly for me. Thank you!

Blinkiz
October 16th, 2008, 08:22 AM
The OP's fix didn't work for me, but this did.

In terminal, type

sudo apt-get install libflashsupport

Restart Firefox, and voila!

Nice, thanks! Worked for me under ubuntu 8.04.1

billybigrigger
October 20th, 2008, 07:00 AM
worked for getting flash sound to work in both firefox and opera

gl

psyke83
October 20th, 2008, 07:45 AM
Just to note: this guide is horribly outdated. Flash 9 does not even support ESD by default anymore.

For Hardy/PulseAudio users, libflashsupport is suboptimal (it works, but causes constant crashes). This is covered in excruciating detail here (http://ubuntuforums.org/showthread.php?t=789578).

In summary: don't use Flash 9 if possible. Upgrade to Flash 10 (which is now at the final release), and ensure PulseAudio is configured properly. See the link above for more information and access to updated packages in my PPA.

P.S. Moderator(s), can we please move this thread to the outdated section? Rationale: the OP's instructions do nothing, and other advice amounts to increasing instability, and spam/duplicates of bug #192888 (https://bugs.launchpad.net/bugs/192888).

everlearner
October 21st, 2008, 03:37 PM
The OP's fix didn't work for me, but this did.

In terminal, type

sudo apt-get install libflashsupport

Restart Firefox, and voila!

It works for me under Ubuntu 8.04. Thanks^^

everlearner

teamsah
November 7th, 2008, 10:28 AM
It works but my default sound (mp3s, videos) doesn't work. How do i reverse this ?

i've same problem..help

RhubarbnCustard
November 8th, 2008, 03:24 PM
worked for me - thanks

Jajo
November 26th, 2008, 01:52 PM
hi, i've just installed intrepid, and no sound, i've installed flashplugin-nonfree and flashplugin-nonfree-extrasound, but i still have no sound on gnome; using intrepid at 64bit i had no sound with gnome and no problems with xfce, how can i solve?

i've intrepid32 on a amd64 3200 with an audigy2 zs and, in Preferences -> Sound, if i set something different from OSS or alsa multichannel playback, i have no sound or bad playing, and, of course, no sound in flash vids

Jajo
November 26th, 2008, 03:09 PM
ps: flash works good even in kde

psyke83
November 27th, 2008, 01:00 AM
To the recent posters and new readers:

Don't follow the OP's instructions, and don't install libflashsupport!

Why?

The OP's instructions are hopelessly outdated - recent Flash releases don't even supports ESD output anymore, so the instructions make no sense.
The libflashsupport library was a necessary evil to get Flash 9 working with PulseAudio, but it causes extreme instability in Firefox. Flash 10 no longer needs this buggy library, so you are advised to upgrade.


You should upgrade to Flash 10 and configure PulseAudio correctly. This is the only way to guarantee that sound mixing will work on your system (and without crashes).

See: http://ubuntuforums.org/showthread.php?t=789578

Jajo
November 27th, 2008, 03:03 AM
i followed your guide, and pulseaudio uses this device Audigy 2 ZS [SB0350]: ADC Capture/Standard PCM Playback. it plays, but just with my front speakers!

the device chooser doesn't even let me choose another device, and i don't know how to set it up..

SimonDay
January 4th, 2009, 05:36 PM
ok, by the looks of itit's a brilliant thing that works, but i'm new with linux and it makes no sence to me at all, any chance someone could go threw it step by step?

forestwalkerjoe
February 14th, 2009, 11:00 PM
i know that not every thing can work for each persons system.. i tried the below solve and .. well, it didnt work for me.
i did however try 3 others.. the last test i did solved it.. and it think it address's the Glitch in this version of ubuntu very nicely.
i am running on IBIX 810.
here is the link to my solve (http://ubuntuforums.org/showthread.php?p=6734814#post6734814).
I am not good with linking and getting every thing to open.. so if you cant see the other links on this post i am setting up.. write back. BUT this really did solve nearly every thing.

Good Luck

FWJ

emrys.r
April 18th, 2009, 08:11 PM
The OP's fix didn't work for me, but this did.

In terminal, type

sudo apt-get install libflashsupport

Restart Firefox, and voila!



AWSOME! nice one. 2 second fix. tried a few others with no luck.

This should be moved to the top of the list!

psyke83
April 21st, 2009, 03:43 AM
AWSOME! nice one. 2 second fix. tried a few others with no luck.

This should be moved to the top of the list!

Please spread the word, libflashsupport causes serious instability in Firefox. Stop using it, and upgrade to Flash 10 instead.

See: https://bugs.launchpad.net/bugs/192888

msetts
April 29th, 2009, 09:48 AM
Thanks so much! This is a perfect fix!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

msetts
April 30th, 2009, 05:05 AM
actually, this did work, until i rebooted my computer again, now having the same problem!

mrbabinga
May 30th, 2009, 04:10 AM
I had sound issues since I upgraded to 9.04. Uninstalled Swfdec and problems disappeared.

mrbabinga

pdadad
July 18th, 2009, 06:51 PM
Deleting libflashsupport then re-installing flash 10 fixed Firefox but not Opera, which is no show stopper for me, in Ubuntu 8.04. Thanks for the post!

BrionS
August 31st, 2009, 12:14 PM
I had sound issues since I upgraded to 9.04. Uninstalled Swfdec and problems disappeared.

I think this is actually the more elegant (and permanent) solution. It works for me and I don't need to create a script to keep re-installing a hack on each boot.

How libswfdec (swfdec-mozilla) got installed I'm not sure, but removing still allows Flash 10 to play but also enables the sound.

I'm running 9.04 and had sound in Flash until a few package-manager updates ago when suddenly it stopped. I think swfdec-mozilla is contending with the real Flash player (nonfree) and the result is lost sound. Removing swfdec-mozilla fixes this problem and I recommend trying that approach first! :guitar:

omrsafetyo
October 3rd, 2009, 02:23 AM
Tried the instructions on the first page..
sudo ln -s /usr/lib/libesd.so.0 /usr/lib/libesd.so.1
sudo mkdir -p /tmp/.esd/
sudo touch /tmp/.esd/socket

no luck..

Went to /usr/lib and did a find for the file that was linked..
/usr/lib$ find /usr/lib* -name "libesd*"
/usr/lib/libesd.so.0

hmm.. my link points to nothing! alsa wasn't even installed yet...

sudo apt-get install libesd-alsa0

Still no luck...

sudo apt-get install flashplugin-nonfree-extrasound

Still no...

Clicked on the sound icon and opened the mixer.. unmuted LFE and turned the volume up - and magically it works!

Just thought I would share my experience in case it helps someone else.

po-90260
October 7th, 2009, 07:34 AM
I think this is actually the more elegant (and permanent) solution. It works for me and I don't need to create a script to keep re-installing a hack on each boot.

How libswfdec (swfdec-mozilla) got installed I'm not sure, but removing still allows Flash 10 to play but also enables the sound.



I'm new to ubuntu but I used unix 20 years ago.
I just installed 9.04 on an old PC. I hear sound in Youtube but there's none in Flash 10.
How do I check if I have this libswfdec? How do I remove it? It's not listed in "Add/remove applications list". I seriously don't know my way around this product. Windows has brain deadened me I guess.

frazerr
October 18th, 2009, 05:02 PM
I'm new to ubuntu but I used unix 20 years ago.
How do I check if I have this libswfdec? How do I remove it? It's not listed in "Add/remove applications list". I seriously don't know my way around this product. Windows has brain deadened me I guess.

Hi. "Add/remove applications" only shows applications. It is the simple interface that hides most packages away from new users.

You want to go to System/Administration/Synaptic Package manager.

this will do everything you need

po-90260
October 30th, 2009, 12:32 AM
Synaptic package manager it lists 9 files begining with libswfdec

jac0117
April 9th, 2010, 08:09 AM
awesome... thanks this worked for me!

ben2talk
April 27th, 2010, 06:13 AM
Yeeee Haaaaaaa! I've read so many posts about this, including all the "can't be fixed, wait for flash 9, yadda yadda". This fix works perfectly for me on dapper. Now I can watch all that pointless, moronic flash content! Thank you.

Amazing - but I'm using Flash 10 and this fix didn't work for me.

williamslewis
April 27th, 2010, 12:58 PM
I was looking for this thing for almost a month and thank God I have finally reached here. Thanks for sharing such an informative tutorial

Rob-e
October 12th, 2010, 08:54 AM
I was having this problem with ubuntu 10.10, I had to go to sound preferences and the output tab and pick my BT headset, for some reason other apps used it but flash used the selected one.

(posting here because its the first search result I got)

lkjoel
August 1st, 2011, 05:30 PM
Thanks a lot for this! It fixed my flash sound!

Fedek86
October 17th, 2011, 10:13 PM
After weeks of searching for a solution, this has finally got sound in flash working for me. :-D

https://launchpad.net/distros/ubuntu/+source/flashplugin-nonfree/+bug/29760


# Flash also looks for /usr/lib/libesd.so.1
sudo ln -s /usr/lib/libesd.so.0 /usr/lib/libesd.so.1

# Flash expects /tmp/.esd/socket to exist.
sudo mkdir -p /tmp/.esd/
sudo touch /tmp/.esd/socket

this still working for me!! thanks!

Ronalddig
November 14th, 2011, 02:21 PM
It worked for me

Thx :)

UNubTu
December 10th, 2011, 04:46 AM
Also worked for me on Oneiric. Although, I had to also start a Youtube movie and then while it was running, open up Sound Settings, Applications, and uncheck the Mute button next to ALSA plug-in [npviewer.bin]. Now that I think about it, I am not sure if creating the link files really solved the problem or if the Mute box being checked was my problem all along. But I don't want to risk deleting the links now that it is working :D

tmnuwan12
December 11th, 2011, 11:17 PM
I had some issues with flash. It was nothing to do with sound but with image cluttering and slow response. But I did a kernal upgrade and it works ok now...I think this would help if someone got any other issue with flash. I think kernal update would help..Thanks