PDA

View Full Version : [ubuntu] Ubuntu not working with ACPI



04blatca
August 10th, 2012, 12:36 PM
I recently purchased a new server for my company and tried installing Ubuntu 12.04 server but have had numerous issues. Basically, the install process starts and the server almost instantly just restarts. The same thing happens with a windows installation which restarts when it starts to load files.

After disabling ACPI on boot, Ubuntu installed correctly. The problem with this however is that without ACPI, there is not hyper threading which I require for the applications I am running on the server. As soon as I enable the acpi=ht flag on grub, the server fails to boot and restarts.

I have tried 2 different motherboards and CPUs, as well as changing the RAM for known working sticks and replacing the PSU and video card. I have also ensured that the motherboards had the latest bios and used a different CD drive.

Server specs are:

3930K @3.2GHz (6 Core/12 Threads)
64GB DDR3 RAM @ 1333MHz
Tried 2 different motherboards (ASRock X79 Extreme6 and ASUS Sabertooth X79)
360GB SSD + 2TB HDD

Any help would be greatly appreciated.

Thanks!

corrosion
August 11th, 2012, 02:13 PM
I have the same problem as you with my motherboard server GA-MA69VM-S2. It is updated to the last BIOS version, but no change, when booting the ubuntu server 1204 (amd64) installer with acpi support it hangs. Without ACPI it install without problems, but the CPU load goes 100% without any apparent reasons...
With Debian, anyway, it works perfect...

Vegan
August 11th, 2012, 02:30 PM
while kernel support is usually excellent, there are lots of boards it cannot figure out

corrosion
August 12th, 2012, 01:00 PM
Looking into the forums I found the solution for my motherboard: Disable HPET from BIOS Power Settings. Now I installed ubuntu server 1204 with ACPI without problems. Try yourself and good luck!