PDA

View Full Version : [SOLVED] Issues with a fresh WP install on a VPS



Lightmaster
August 9th, 2012, 01:26 PM
Hello everyone!I just bought a new VPS, installed Ubuntu 12.04 on it, followed an online tutorial on how to install Wordpress on it and now I'm having problems.

I finished the tutorial step by step, but when I try to access the website, all I get is the default apache page.

What could be the issue?

Cheesemill
August 9th, 2012, 03:34 PM
Which tutorial did you follow?

Lightmaster
August 9th, 2012, 03:38 PM
Ooops, I forgot to post it

http://echotutorials.com/96/ubuntu-complete-wordpress-setup-guide/tutorial/screencast/guide.php#more-96

This is it.

Cheesemill
August 9th, 2012, 03:53 PM
Did you make sure that you enabled your site using the a2ensite command and restarted Apache?

What's the output of:

ls -l /etc/apache2/sites-enabled

Lightmaster
August 9th, 2012, 03:56 PM
root@ubi:~# ls -l /etc/apache2/sites-enabled
total 0
lrwxrwxrwx 1 root root 26 Aug 9 10:59 000-default -> ../sites-available/default
lrwxrwxrwx 1 root root 35 Aug 9 11:12 garajulindie.com -> ../sites-available/garajulindie.com
root@ubi:~#

I see two webites there.That might be the problem.Question is, how do I remove that?

Cheesemill
August 9th, 2012, 04:06 PM
That's how it should be. Can you give me the output of:

cat /etc/apache2/sites-enabled/garajulindie.com

Lightmaster
August 9th, 2012, 04:16 PM
root@ubi:~# cat /etc/apache2/sites-enabled/garajulindie.com
<VirtualHost *:80>
ServerAdmin blocked out
ServerName garajulindie.com
ServerAlias www.garajulindie.com
DocumentRoot /var/www/garajulindie.com/public_html/
ErrorLog /var/www/garajulindie.com/logs/error.log
CustomLog /var/www/garajulindie.com/logs/access.log combined
<Directory /var/www/garajulindie.com/public_html>
Options FollowSymLinks
AllowOverride All
RewriteEngine On
RewriteCond %{HTTP_HOST} ^www.garajulindie.com$ [NC]
RewriteRule ^(.*)$ http://garajulindie.com/$1 [R=301,L]
</Directory>
</VirtualHost>


There you go.Thank you so much for helping me out :)

PS: I blocked out the email adress over there to not show up on the forum.

Cheesemill
August 9th, 2012, 04:33 PM
Hmmm, that all looks good to me.

Usually the problem you are having with the default page appearing happens either when name-based virtual hosting isn't set up properly or if you access the webserver using an address that doesn't match any of the ServerName or ServerAlias directives.

You are trying to access your site by going to either garajulindie.com or www.garajulindie.com and not by its IP address aren't you?

dbrooke
August 9th, 2012, 05:59 PM
Hello everyone!I just bought a new VPS, installed Ubuntu 12.04 on it, followed an online tutorial on how to install Wordpress on it and now I'm having problems.

I finished the tutorial step by step, but when I try to access the website, all I get is the default apache page.

What could be the issue?

Did you enable your virtualhost?

man a2ensite

service apache2 restart

Edit: Sorry, didn't see cheesemill already suggested this!
Donovan

Lightmaster
August 9th, 2012, 07:55 PM
Ah...I was trying to acces the website via de IP adress.I'm such an newbie.I've updated the DNS records and now, instead of the default apache page, I'm getting a "Error establishing a database connection" page.

I don't know what the hell is wrong.The wp-config page is good, same user/pass as with the mysql database I have created.


LE: Nevermind, small typo= a lot of wasted time.Nonetheless, thank you very much!