PDA

View Full Version : [SOLVED] Installation of "Zram" locked up Synaptic



Javelin Dan
August 9th, 2012, 02:31 AM
Running Ubuntu 12.04 on an eMac G-4, 1 Ghz processor, 1 GB Ram, 40 GB hard drive.

I had looked on a site entitled "Modify Ubuntu - Ubuntu 12.04 Tips and Tricks" and decided I would try installing "Zram" to maybe speed things up. It seemed to install normally through the command line, but when I went into Synaptic for something else it told me to run "dpkg". I did, and ran the command:

[sudo dpkg --debug=<octal>] and got the following output:

[ dpkg: error: unknown option -o

Type dpkg --help for help about installing and deinstalling packages
;
Use `dselect' or `aptitude' for user-friendly package management;
Type dpkg -Dhelp for a list of dpkg debug flag values;
Type dpkg --force-help for a list of forcing options;
Type dpkg-deb --help for help about manipulating *.deb files;

Options marked
produce a lot of output - pipe it through `less' or `more' !
daniel@daniel-desktop:~$ sudo dpkg -Dhelp
dpkg debugging option, --debug=<octal> or -D<octal>:

Number Ref. in source Description
1 general Generally helpful progress information
2 scripts Invocation and status of maintainer scripts
10 eachfile Output for each file processed
100 eachfiledetail Lots of output for each file processed
20 conff Output for each configuration file
200 conffdetail Lots of output for each configuration file
40 depcon Dependencies and conflicts
400 depcondetail Lots of dependencies/conflicts output
10000 triggers Trigger activation and processing
20000 triggersdetail Lots of output regarding triggers
40000 triggersstupid Silly amounts of output regarding triggers
1000 veryverbose Lots of drivel about eg the dpkg/info directory
2000 stupidlyverbose Insane amounts of drivel

Debugging options can be mixed using bitwise-or.
Note that the meanings and values are subject to change.
daniel@daniel-desktop:~$ sudo dpkg --debug=<octal>
bash: syntax error near unexpected token `newline'
daniel@daniel-desktop:~$ sudo dpkg --D<octal>
bash: syntax error near unexpected token `newline'
daniel@daniel-desktop:~$]


I'm lost at this point and could use some help.

Javelin Dan
August 10th, 2012, 01:34 AM
I removed "Zram" and got synaptic back. I still don't know why it didn't work, but I guess this is as "Solved" as it's gonna get.