PDA

View Full Version : [SOLVED] Xfce Power Manager



themuCkk
August 2nd, 2012, 11:25 PM
Hey,

I am using an Ubuntu installation with Xfce as desktop environment on my Thinkpad E520. After installing updates (including a reboot) my power manager stopped working and I also get crash reports about the network manager on every start. I tried reinstalling (sudo apt-get remove, then install) xfce4-power-manager, but it didn't help. Here are some screenshots:

https://dl.dropbox.com/u/12769915/power1.png
https://dl.dropbox.com/u/12769915/power2.png
(The text says "Can't establish connection to the power manager for Xfce")

Any ideas how to fix this problem?

muCkk

Toz
August 2nd, 2012, 11:57 PM
Hello themuCkk and welcome to the forums.

Is xfce4-power-manager running? You can check by typing in the following in a terminal window:

ps -ef | grep xfce4-power

There also might be some useful information in the ~/.xsession-errors log file.

themuCkk
August 3rd, 2012, 12:39 AM
Hello,

xfce4-power is running. The only related message in the log was this:

(xfce4-power-manager-settings:3227): xfce4-power-manager-settings-CRITICAL **: Unable to get configuration information from xfce power manager: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

Thanks for your fast reply :).

Toz
August 3rd, 2012, 01:47 AM
Try clearing out your sessions cache. Logout form Xfce, Ctrl+Alt+F1 to go to first tty, login to tty (text-based), clear the cache with:

rm -rf ~/.cache/sessions
...then go back to the GUI (Ctrl+Alt+F7) and log back in.

themuCkk
August 3rd, 2012, 08:53 AM
That solved it, thanks!

Mavashi
November 2nd, 2012, 10:17 PM
Try clearing out your sessions cache. Logout form Xfce, Ctrl+Alt+F1 to go to first tty, login to tty (text-based), clear the cache with:

rm -rf ~/.cache/sessions
...then go back to the GUI (Ctrl+Alt+F7) and log back in.

That helped me also. Thanks, Toz!

vbeggi
August 22nd, 2013, 02:09 PM
That helped me also. Thanks, Toz!

If the problem consists in thunar, right after login, waiting long time before opening home and doing it after error message (unspecified resource/directory not available), it seems solved by a small change in : /etc/nsswitch.conf.

The original line: [hosts: files dns]
when changed to: [hosts: files wins dns]

seems to solve the problem without further interventions.
Even the "Network" link in thunar works out of the box.

kNKGbYy
October 18th, 2013, 08:22 AM
Try clearing out your sessions cache. Logout form Xfce, Ctrl+Alt+F1 to go to first tty, login to tty (text-based), clear the cache with:

rm -rf ~/.cache/sessions
...then go back to the GUI (Ctrl+Alt+F7) and log back in.

Thanks Toz! Helped me out as well! Cheers mate!

fkkroundabout
May 29th, 2014, 04:37 PM
Try clearing out your sessions cache. Logout form Xfce, Ctrl+Alt+F1 to go to first tty, login to tty (text-based), clear the cache with:

rm -rf ~/.cache/sessions
...then go back to the GUI (Ctrl+Alt+F7) and log back in.

worked for me

Toz
May 29th, 2014, 07:53 PM
This fix, although still valid, was necessary for earlier versions of Xfce. The later versions of Xfce (4.10+) including the version in 14.04 has added the ability to clear the sessions cache without the need to go to a text console. Look for it in Settings Manager >> Session and Startup >> Session tab >> "Clear saved sessions". It is much easier now to clear the saved sessions cache.

Closing this thread.