PDA

View Full Version : [ubuntu] Nautilus will not run



Robynsveil
August 1st, 2012, 02:33 PM
I've had a search this evening to see if anyone else has encountered this issue: I can't find any similar instance.

I'm not fond of Unity, so I'm running Gnome Classic in Ubuntu 12.04 LTS. I've recently been getting these internal error notifications, but nothing seemed to be amiss so I only ever looked at the most recent one. It appeared to be about the applets that were causing problems.

I only mention this because I'm not sure it is a related problem. I clicked on the Home Folder icon (next to Applications | Places at the top) but nothing happened. I then tried to run nautilus from the cli and got:


me@my-laptop:~$ nautilus
Could not register the application: Timeout was reached
On another thread, someone recommended using something called gdb... which I ran, and got:

me@my-laptop:~$ gdb nautilus
GNU gdb (Ubuntu/Linaro 7.4-2012.04-0ubuntu2) 7.4-2012.04
Copyright (C) 2012 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law. Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-linux-gnu".
For bug reporting instructions, please see:
<http://bugs.launchpad.net/gdb-linaro/>...
Reading symbols from /usr/bin/nautilus...(no debugging symbols found)...done.
(gdb) run
Starting program: /usr/bin/nautilus
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[New Thread 0x7fffeca11700 (LWP 4400)]
[New Thread 0x7fffe7fff700 (LWP 4401)]
Could not register the application: Timeout was reached
[Thread 0x7fffe7fff700 (LWP 4401) exited]
[Thread 0x7ffff7fc2980 (LWP 4397) exited]
[Inferior 1 (process 4397) exited with code 01]

Any idea what the problem might be and how to fix this? Thanks in advance to any and all who respond.:)

Frogs Hair
August 1st, 2012, 03:48 PM
Try to restart Nautilus with the following command and see if it starts from the icon. Post any errors generated by using the command .
nautilus -q

Robynsveil
August 4th, 2012, 02:38 PM
Thank you for your answer, Frog's Hair. I actually found that if I disconnected my external terrabyte drive, Nautilus came back all of its own. Apparently, there's an issue with my terrabyte drive which caused Nautilus to time out.
Thanks again for replying... I'll try to reconnect the drive and see if the problem reproduces itself... and try your command.