View Full Version : [ubuntu] Video player not working.

July 29th, 2012, 08:55 PM
Hi, i have recently installed OBUNTU 12.04 but i cant play DVD's, when i put a film in the drive, the computer sees it ok and gives a dialogue box saying as below.
An error occured
"Could not read DVD. This maybe because the DVD is encrypted and a decryption library has not been installed"

Could any tell me how to cure this problem? I have also tried VLC and that wont work either. Thanks in advance.

July 29th, 2012, 09:12 PM

sudo apt-get install libdvdcss2 && sudo /usr/share/doc/libdvdread4/./install-css.sh

July 29th, 2012, 09:13 PM
Go to Medibuntu here http://medibuntu.org/repository.php

Copy the code starting "sudo -E wget --outpu.....".

Open a Terminal session by pressing [Ctrl] + [Alt] + T

Paste the code in to Terminal with [Ctrl] + [Shift] + V

Press [Enter] if required and enter your password when asked.

Once finished restart whatever programme you are using to play the DVD and hopefully that will be that.

(This will process will also add extra "non-free" items to the Software Centre)

July 29th, 2012, 10:09 PM
Thanks Laiquendi and cogier, i have tried both your commands and with both i get "command not found"

Any other idea's would be greatly apreciated.

July 29th, 2012, 10:10 PM
For full details and info read https://help.ubuntu.com/community/RestrictedFormats/PlayingDVDs/

July 29th, 2012, 10:19 PM
For full details and info read https://help.ubuntu.com/community/RestrictedFormats/PlayingDVDs/

Thanks aqjgreeny i'll give it a go.

July 29th, 2012, 11:21 PM
I have just had a quick look at the link you gave me ajgreeny and Sheeeeesh, it aint half technical, i am going to have to study this lot and i don't have much confidence in doing that.
So far as i have read, it goes over my head, far too technical for beginners i would have thought. I have been using computers for 8 years or so and ubuntu for a couple of years and the link is very hard going for me, God help the new starters, they aint got a virgin in hells chance.

I read some where that ubuntu team's aim was to simplify it for the ordinary guy in the street, to challenge Windows (spit) in effect. With great deserved respect to the ubuntu team, If that is the case, then the ubuntu team have just taken a dozen or more backward steps. The ordinary guy in the street can not follow the instructions in that link.

I am though a trier if nothing else and i will get struck in to it and hope i get the hang of it. Thanks again for the link, its greatly appreciated.

July 30th, 2012, 02:18 PM
You don't really need to worry about all that being over your head.

Open a terminal with Ctrl+Alt+T and in that type
sudo apt-get install libdvdread4Type your password, which you will not see shown in terminal but it will be there so don't worry.

When that has installed the libdvdread4 package, in the same terminal type
sudo /usr/share/doc/libdvdread4/install-css.shEnter your password again if needed and that should do what you need.