PDA

View Full Version : [ubuntu] Desktop Is Running In 2D Mode



RezPix
July 26th, 2012, 01:26 AM
Hello, I installed Ubuntu 12.04 earlier today. I installed my ATI drivers and they worked perfectly until I just restarted about 6 hours later.. Now it says my Ubuntu is running in 2D mode. I had restarted my computer many of times before. And randomly just went to 2D Mode. I have also logged out and tried to see if there is a option to change to 3D mode, and there isn't. I have no idea why its doing this. Does anyone know? Thanks.

HoCo xXSamXx
July 26th, 2012, 04:43 AM
I had this exact problem last night. I installed the ATI drivers and the next morning I had all sorts of problems. As you said, I could only get into 2D mode. I had additional problems like my Wine Windows Program Launcher crashing.
I uninstalled the drivers, and rebooted a few time and have had no succes.

EDIT- In addition, the Compiz effects are not working

QIII
July 26th, 2012, 04:48 AM
How did you install the ATI driver?

The ATI driver is not necessarily the culprit.

HoCo xXSamXx
July 26th, 2012, 04:52 AM
How did you install the ATI driver?

I am not the OP, but I think I have the same problem. I installed it from the Software Center. I wonder how the OP installed it.

QIII
July 26th, 2012, 05:04 AM
The OP may be otherwise engaged in life right now, but discussing this will leave him a trail to follow up on.

Did you install the "Post Release Update" version?

HoCo xXSamXx
July 26th, 2012, 07:17 AM
The OP may be otherwise engaged in life right now, but discussing this will leave him a trail to follow up on.

Did you install the "Post Release Update" version?

No, the current stable version I think.

viperdvman
July 26th, 2012, 07:20 AM
The way I've always installed the proprietary graphics drivers was to use the "Additional Drivers" app in Ubuntu. I have yet to do it in 12.04 on my netbook (which has an AMD Radeon chip) since I prefer the open source one (I've had problems running flash with it in previous Ubuntu releases), but give the "Additional Drivers" app a shot after installing Ubuntu.

HoCo xXSamXx
July 26th, 2012, 08:20 AM
I solved this for myself. Had uninstalled the driver, but it had installed some add-on that did not uninstall for some reason. I have no idea if any of this will help the OP though.

RezPix
July 26th, 2012, 12:27 PM
Hello, Thanks for all the reply's. I had installed the drivers via the Additional Drivers, and when I rebooted like I said it was in 2d Mode. So I removed the additional drivers and downloaded and installed he Linux drivers from the ATI website for my specific card. When I just rebooted again, now unity is not being displayed. I am greeted with just my desktop background and my ATI driver icon on my desktop. Would it be a good idea to just reinstall ubuntu? Thanks.

HoCo xXSamXx
July 26th, 2012, 01:28 PM
Would it be a good idea to just reinstall ubuntu? Thanks.

If you haven't gone through to much work configuring setting and whatnots, I would re-install if I where you.

RezPix
July 26th, 2012, 01:57 PM
If you haven't gone through to much work configuring setting and whatnots, I would re-install if I where you.

Yeah, I decided to reinstall. I didn't really have a lot installed anyway. Thanks.