PDA

View Full Version : HOWTO: Wireless Security - WPA1, WPA2, LEAP, etc.



Pages : [1] 2 3 4 5 6 7 8

wieman01
June 24th, 2006, 11:40 AM
This guide was tested with:

Jaunty Jackalope (9.04)
Oneiric Ocelot (11.10)
--
Since it appears that very few people take wireless security seriously, I'd like to come up with my first HOWTO and explain how I was able to configure a secure home network using WPA2, the latest encryption & authentication standard. There are also other types of configuration (WPA1, mixed mode, LEAP, PEAP, DHCP, etc.) shown in the appendix. Feedback is much appreciated.

Common stumbling blocks - Make sure that:
1. Ethernet cable is unplugged.
2. No firewall & configuration tool is running (e.g. Firestarter).
3. MAC filtering is disabled.
4. NetworkManager, Wifi-Radar & similar wireless configuration tools are disabled/turned off and not in use.
5. Some cards/drivers (e.g. Madwifi) do not support WPA2 (AES). Try WPA1 (TKIP) if WPA2 secured connections fail.
6. Set router to BG-Only if using ndiswrapper (and perhaps Broadcom 43xx as I don't know about others).

My Requirements:
1. WPA2 / RSN
2. AES / CCMP
3. Hidden ESSID (no broadcast)
4. Static IP (because I use port forwarding & firewall, etc.)
5. Pre-shared key (no EAP)

If you want to know more about WPA / RSN & 802.11i security specification, I recommend this site (http://en.wikipedia.org/wiki/IEEE_802.11i).

Now let's get started (wpa-suplicant is usually installed by default):
0. Install "wpa-supplicant":

sudo apt-get install wpasupplicant
1. Verify that your network device ("wlan0"?) is working & your wireless network is detected:

iwconfig

sudo iwlist scan
Your network device & wireless network should appear here.

2. Open "/etc/network/interfaces":

sudo gedit /etc/network/interfaces
The content should look similar to this:

auto lo
iface lo inet loopback

auto wlan0
iface wlan0 inet dhcp
3. Now replace the last 2 lines with the following using your own network settings (the sequence in which the lines appear is crucial):

auto wlan0
iface wlan0 inet static
address 192.168.168.40
gateway 192.168.168.230
dns-nameservers 192.168.168.230
netmask 255.255.255.0
wpa-driver wext
wpa-ssid <your_essid>
wpa-ap-scan 2
wpa-proto RSN
wpa-pairwise CCMP
wpa-group CCMP
wpa-key-mgmt WPA-PSK
wpa-psk <your_hex_key> [IMPORTANT: See "WPA-PSK key generation"]

auto wlan0:
Your network interface (e.g. wlan0, eth1, rausb0, ra0, etc.).


iface wlan0 inet static:
Self-explanatory... I am using a Static IP instead of DHCP. "iface wlan0" must correspond to your network interface (see above).


address, netmask, [..], dns-nameservers:
Also self-explanatory... Be aware that "broadcast" needs to end with ".255" for negotiation with the router. These lines need to be according to your own (static) network settings. For DHCP see further below.


wpa-driver:
Use "wext" only. All other drivers are outdated no longer used.
[/QUOTE]


wpa-ssid:
Your network's ESSID (no quotes ""). Please avoid blanks/spaces as they will created problems during key generation (see below).


wpa-ap-scan:
"1" = Broadcast of ESSID.
"2" = Hidden broadcast of ESSID.


wpa-proto:
"RSN" = WPA(2)
"WPA" = WPA(1)


wpa-pairwise & wpa-group:
"CCMP" = AES cipher as part of WPA(2) standard.
"TKIP" = TKIP cipher as part of WPA(1) standard.


wpa-key-mgmt:
"WPA-PSK" = Authentication via pre-shared key (see 'key generation' further below).
"WPA-EAP" = Authentication via enterprise authentication server.

VERY IMPORTANT ("WPA PSK Key Generation"):
Now convert your WPA ASCII password using the following command:

wpa_passphrase <your_essid> <your_ascii_key>
Resulting in an output like...

network={
ssid="test"
#psk="12345678"
psk=fe727aa8b64ac9b3f54c72432da14faed933ea511ecab1 5bbc6c52e7522f709a
}
Copy the "hex_key" (next to "psk=...") and replace <your_hex_key> in the "interfaces" files with it. Then save the file and restart your network:

sudo /etc/init.d/networking restart
You should be connecting to your router now... However, I figured that a restart is sometimes necessary so that's what I usually do (I know this sounds a bit clumsy - see post #2 for startup script).


*****************************Revoking read-permission from 'others'*********************************

sudo chmod o=-r /etc/network/interfaces
*****************************Revoking read-permission from 'others'*********************************

*****************************Sample configuration WPA2 & DHCP, ESSID broadcast enabled***************

auto wlan0
iface wlan0 inet dhcp
wpa-driver wext
wpa-ssid <your_essid>
wpa-ap-scan 1
wpa-proto RSN
wpa-pairwise CCMP
wpa-group CCMP
wpa-key-mgmt WPA-PSK
wpa-psk <your_hex_key> [IMPORTANT: See "WPA-PSK key generation"]
*****************************Sample configuration WPA2 & DHCP, ESSID broadcast enabled***************

*****************************Sample configuration WPA1 & DHCP, ESSID broadcast enabled***************

auto wlan0
iface wlan0 inet dhcp
wpa-driver wext
wpa-ssid <your_essid>
wpa-ap-scan 1
wpa-proto WPA
wpa-pairwise TKIP
wpa-group TKIP
wpa-key-mgmt WPA-PSK
wpa-psk <your_hex_key> [IMPORTANT: See "WPA-PSK key generation"]
*****************************Sample configuration WPA1 & DHCP, ESSID broadcast enabled***************

****************************Sample configuration mixed mode (WPA1, WPA2) & DHCP, ESSID broadcast*****

auto wlan0
iface wlan0 inet dhcp
wpa-driver wext
wpa-ssid <your_essid>
wpa-ap-scan 1
wpa-proto WPA RSN
wpa-pairwise TKIP CCMP
wpa-group TKIP CCMP
wpa-key-mgmt WPA-PSK
wpa-psk <your_hex_key> [IMPORTANT: See "WPA-PSK key generation"]
****************************Sample configuration mixed mode (WPA1, WPA2) & DHCP, ESSID broadcast*****

****************************Sample conf. LEAP, WEP, DHCP, ESSID broadcast***************************

auto wlan0
iface wlan0 inet dhcp
wpa-driver wext
wpa-ssid <your_essid>
wpa-ap-scan 1
wpa-eap LEAP
wpa-key-mgmt IEEE8021X
wpa-identity <your_user_name>
wpa-password <your_password>
****************************Sample conf. LEAP, WEP, DHCP, ESSID broadcast***************************

****************************Sample conf. PEAP, AES, DHCP, ESSID broadcast***************************

auto wlan0
iface wlan0 inet dhcp
wpa-driver wext
wpa-ssid <your_essid>
wpa-ap-scan 1
wpa-proto RSN
wpa-pairwise CCMP
wpa-group CCMP
wpa-eap PEAP
wpa-key-mgmt WPA-EAP
wpa-identity <your_identity>
wpa-password <your_password>
****************************Sample conf. PEAP, AES, DHCP, ESSID broadcast***************************

*****************************Sample conf. TTLS, WEP, DHCP, ESSID broadcast**************************

auto wlan0
iface wlan0 inet dhcp
wpa-driver wext
wpa-ssid <your_essid>
wpa-ap-scan 1
wpa-eap TTLS
wpa-key-mgmt IEEE8021X
wpa-anonymous-identity <anonymous_identity>
wpa-identity <your_identity>
wpa-password <your_password>
wpa-phase2 auth=PAP [Also: CHAP, MSCHAP, MSCHAPV2]
*****************************Sample conf. TTLS, WEP, DHCP, ESSID broadcast**************************

*****************************NOT TESTED: Sample conf. EAP-FAST, WPA1/WPA2, DHCP, ESSID broadcast****

auto wlan0
iface wlan0 inet dhcp
wpa-driver wext
wpa-ssid <your_essid>
wpa-ap-scan 1
wpa-proto RSN WPA
wpa-pairwise CCMP TKIP
wpa-group CCMP TKIP
wpa-key-mgmt WPA-EAP
wpa-eap FAST
wpa-identity <your_user_name>
wpa-password <your_password>
wpa-phase1 fast_provisioning=1
wpa-pac-file /path/to/eap-pac-file
*****************************NOT TESTED: Sample conf. EAP-FAST, WPA1/WPA2, DHCP, ESSID broadcast****

*****************************Tested adapters****************************************** *********

1. Linksys WUSB54G V4 (ndiswrapper; wpa-driver = wext)
2. Intel IPW2200 (Linux driver; wpa-driver = wext)
3. Linksys WPC54G (ndiswrapper; wpa-driver = wext)
4. D-Link WNA-2330 (Linux driver; wpa-driver = madwifi)
5. Linksys WMP54G V2 (ndiswrapper; wpa-driver = wext)
6. D-Link WDA-2320 (Linux driver; wpa-driver = madwifi)
7. Netgear WPN311 (Linux driver; wpa-driver = wext)
8. Netgear WG511v2 (ndiswrapper; wpa-driver = wext)
*****************************Tested adapters****************************************** *********

*****************************Post this if you are stumped******************************************

# route
# iwconfig
# sudo iwlist scan
# sudo lshw -C network
# sudo cat /etc/network/interfaces
# sudo ifdown -v <your_interface>
# sudo ifup -v <your_interface>

*****************************Post this if you are stumped******************************************

*****************************Other useful commands****************************************** ***


# Ubuntu version & kernel >> uname -a
# Root file access >> alt F2 then 'gksudo nautilus' in cli
# Get IP Address or Renew >> sudo dhclient wlan0 [or whatever your wl adapter is]
# Get wireless info >> iwconfig
# Get AP info >> iwlist scan
# Get wireless info >> iwlist (lots of options will list)
# Routes if wlan0 working >> route
# DNS resolving via eth1 >> cat /etc/resolv.conf
# List devices/modules >> lspci, lsusb, lshw, lsmod
# Restart network >> sudo /etc/init.d/networking restart
# Boot messages >> dmesg
# Kill NWM >> sudo killall NetworkManager
# Events from your wl >> iwevent
# Restart all daemons >> sudo /etc/init.d/dbus restart
# Restart network >> sudo /etc/init.d/networking restart
*****************************Other useful commands****************************************** ***

CHANGE LOG:
08/11/2006: Added section "Post this if you are stumped" (SquibT).
08/11/2006: Added sample configuration for WPA2 with DHCP & ESSID broadcast (Wieman01).
08/11/2006: Added sample configuration for WPA1 with DHCP & ESSID broadcast (Wieman01).
08/11/2006: Added section "Tested adapters" (Wieman01).
08/11/2006: Added section "Useful commands" (SquibT).
08/11/2006: Added section "Common stumbling blocks" (Wieman01).
08/11/2006: Changed section "wpa-driver" and added new drivers (Wieman01).
08/11/2006: Added section "Revoking read-permission from group 'others'" (Wieman01).
09/11/2006: Minor changes in layout (Wieman01).
09/11/2006: Added sample configuration for mixed mode (WPA1, WPA2) with DHCP & ESSID broadcast (Wieman01).
09/11/2006: Added experimental sample configuration for LEAP with WEP, DHCP & ESSID broadcast (Wieman01).
09/11/2006: Added section "Install wpa-supplicant" (Wieman01).
10/11/2006: Added experimental sample configuration for TTLS with WEP, DHCP & ESSID broadcast (Wieman01).
15/11/2006: Added experimental sample configuration for EAP-FAST with WPA1/WPA2, DHCP & ESSID broadcast (Wieman01).
04/12/2006: Changed "wpa_passphrase" section & added quotes ("") for encryption keys containing special characters (Wieman01).
04/01/2007: Added various security options (Wieman01).
15/01/2007: Added valid script for EAP-LEAP (Wieman01).
31/01/2007: Added valid script for EAP-PEAP (Wieman01).
21/04/2007: Removed "wpa-conf" for Edgy Eft (Wieman01).
22/04/2007: Simplified section concerning static network settings (Wieman01).
02/05/2007: Added note concerning WPA2 support for Atheros cards & drivers (Wieman01).
13/05/2007: Added note on Ralink drivers (Wieman01).
15/04/2008: Tested with HardyHeron (Wieman01).
04/09/2008: Added note on wireless B/G/N (Wieman01).
06/12/2008: Note for Intrepid Ibex users (Wieman01).
07/03/2009: Closed thread (Wieman01).
05/04/2009: Re-opened and enhanced thread (Wieman01).

wieman01
August 8th, 2006, 01:32 AM
Some users reported (including myself) that the network has to be restarted every time after startup... Apparently this is a bug.

Here is a workaround that helps restart the network during boot so that one does not have to do it manually after logging on to the system.

Create startup script:

sudo gedit /etc/init.d/wireless-network
Add this line & save file:

/etc/init.d/networking restart
Change permission (executable):

sudo chmod +x /etc/init.d/wireless-network
Create symbolic link:

sudo ln -s /etc/init.d/wireless-network /etc/rcS.d/S40wireless-network
[Note: You may have to choose a boot sequence other than S40.]

Restart...

sionghua
October 30th, 2006, 01:31 PM
How to adapt this to WPA(1)?

I got everything setup and running ok, except that it is not automated even though I included the wpa_supplicant command in /etc/network/interfaces so everytime I start my computer I need to run wpa_supplicant manually and then dhclient manually as well in order to access to internet. Any idea why automation is not working?

my interfaces file as follow:


auto wlan0
iface wlan0 inet dhcp
wireless-mode Managed
wireless-essid bplus1
pre-up wpa_supplicant -Dwext -iwlan0 -c/etc/wpa_supplicant.conf -Bw
post-down killall -q wpa_supplicant
By the way I notice that I need to completely shut down my computer before I login to ubuntu again to make sure the usb adapter refresh, if I simply restart it will not be detected.

wieman01
October 30th, 2006, 01:50 PM
For WPA1 my example would look like this:

auto wlan0
iface wlan0 inet dhcp
wpa-driver wext
wpa-conf managed
wpa-ssid your_essid
wpa-ap-scan 1
wpa-proto WPA
wpa-pairwise TKIP
wpa-group TKIP
wpa-key-mgmt WPA-PSK
wpa-psk your_wpa_psk
I have never bothered to setup wpa_supplicant outside of "interfaces" because I don't think it is nice. So I cannot give you any advice there. However, I am having a similar issue as you whereby I need to initialize my wireless network at startup, then immediately bring it down & restart it. For some reason the network would remain disconnected if I did not restart it.

So my advice is to follow post #2 and restart the network during the boot process. Not sure if this is a bug but I have not found a solution ever since.

wieman01
October 30th, 2006, 01:56 PM
By the way... This also works for Atheros chipsets ("ath0") as shown in here:http://www.ubuntuforums.org/showthread.php?t=225290

sionghua
October 31st, 2006, 12:18 AM
I followed all the instructions but it won't connect, when issuing iwconfig i get

essid: off/any

sionghua
October 31st, 2006, 12:33 AM
here's my wpa_supplicant.conf


ctrl_interface=/var/run/wpa_supplicant
network={
ssid="bplus1"
psk=xxxxxxx
key_mgmt=WPA-PSK
proto=WPA
pairwise=TKIP
}

sionghua
October 31st, 2006, 12:42 AM
Commands that i use to invoke wpa_supplicant is
sudo wpa_supplicant -Dwext -iwlan0 -c/etc/wpa_supplicant.conf -Bw
and for dhcp
sudo dhclient wlan0

I invoke this commands with

auto wlan0
iface wlan0 inet dhcp
wireless-mode Managed
wireless-essid bplus1
in the interfaces file than it works

squibT
October 31st, 2006, 10:05 AM
@weiman01,

Hi again weiman01...I reinstalled Edgy just to get a fresh start and tried to use this guide to setup my Interfaces file and not use the wpa_supplicant.conf file. If you recall I did have the wpa_supplicant.conf file working and connecting but I wanted to go your route with the Interfaces file.

Good news and bad...My (Linksys wpc54gs)lsbcmnds drivers work fine and report as installed and present, card lights up and flashes connectivity, "iwlist wlan0 scan" reports my AP info correctly (encryption on, correct ESSID ****, etc...) I have a wireless signal meter on the taskbar 100%
This is with the Networking GUI though...and a etc/init.d/network restart reports the key is wrong (obviously..no wpa- in front of any items in the Interfaces file yet.

After setting up your/my Interfaces file (see below):

No internet access, can't get a ping reply from my AP, Iwlist wlan0 scan shows no results .
I have the Interfaces file shown below taken from this HowToo (my IPs are different):

auto wlan0
iface wlan0 inet static
wpa-driver wext (tried ndiswrapper also)
wpa-conf managed
wpa-ssid <my_essid>
wpa-ap-scan 2
wpa-proto RSN
wpa-pairwise CCMP
wpa-group CCMP
wpa-key-mgmt WPA-PSK
wpa-psk <my_64_hex_key>
address 192.168.168.40
netmask 255.255.255.0
network 192.168.168.0
broadcast 192.168.168.255
gateway 192.168.168.230
dns-nameservers 192.168.168.230

I tried enabeling wireless via the GUI. Are you also using the Networking GUI and enabling your wireless there also? When I do and I enter the basic information it writes in to the bottom of your/my Interfaces file this:

My_ip_information....
wireless-essid <my-essid>
wireless-key <my-hex-key>

auto wlan0

Basically adding these lines again...incorrectly.

If I modify the file it does not work...

And "/etc/init.d/network restart" cant read the Interfaces file.

And if I just use your/my config file exactly as you wrote it, "/etc/init.d/network restart" reads the Interfaces file OK but still no connection...like it is not communicating with WPA_Supplicant...or my router....router is setup correctly though.
Iwconfig shows not associated with AP ( of course)
Iwlist wlan0 scan shows no results.

Your file seems to be the closest I have got to getting this going...no errors when I "/etc/init.d/network restart"...just says Reconfiguring then OK which is great.

Using just a basic Interfaces file with no security "iwlist wlan0 scan" reports my AP info correctly (encryption on, correct ESSID ****, etc...) I have a wireless signal meter on the taskbar 100%...

I am missing something...

Any ideas? I dont want to take a lot of your time but if you can think of anything I am missing let me know.

Thanx,

squibt

squibT
October 31st, 2006, 11:28 AM
Success!

I was using my 64 char hex key from my router (WPA-PSK AES) and not using the directions on page 4 of your instructions. I entered my hex key and it would not work in the Network-Applet Hex box or in the Interfaces file. It seems I have to use an Ascii pass-phrase like BillyBob on my router and then in the Network-Applet enter my info and then run wpa_passphrase <my-essid> <BillyBob (my ascii-key)> to generate a psk hex key....this new key is entered into your Interfaces file like you state on page 4.

Let me experiment with this a little and get back to you...gonna try to use my hex key as a ascii key and regenerate it.

BTW...nice HowToo...if you follow it....](*,) :-D

squibt

squibT
October 31st, 2006, 11:58 AM
So it looks like you CAN use your routers 64 hex key to setup your Network-applet and Interfaces file.

I took my 64 char hex key and entered it in both the ascii and hex boxes (different times) and then followed page 4 of your doc and generated a psk for the Interfaces file. Entering both (at different times) worked fine. The only problem is at sudo /etc/init.d/networking restart....

* Reconfiguring network interfaces... Error for wireless request "Set Encode" (8B2A) :
invalid argument "0EGgN94V5rER1EAGNw7KIGOTJbfyBNoT3UQEeblubdYLvMZAPy YRk93CwPgGvdR".
That is my real hex key the Network-applet adds to your/my Interfaces file along with another entry for my ESSID, both at the bottom of the file. Delete them and restart networking and you get just an OK and no error.

AES works fine...same key I always had...no wpa_supplicant.conf file used.

Thanx weiman01...great HowToo....I just needed to understand the process a little better and not rely on what I thought was the correct procedure...read page 4 :-D

squibt

wieman01
October 31st, 2006, 12:53 PM
Hi Squibt,

Reading this makes me smile... You have probably fallen into every single trap I have fallen into myself. So you have my sympathy... :-) Apparently you need no more help, but I'd appreciate if you posted your "interfaces" file just for the fun of it. I am a bit nosy, that's all.

By the way... The Networking Applet won't help you in Dapper as it does not have a WPA option. Does the Edgy one have??

EDIT:
What "page 4" of my documentation are you referring to??? You mean the other thread mentioned?

squibT
October 31st, 2006, 07:59 PM
Hi Squibt,

Reading this makes me smile... You have probably fallen into every single trap I have fallen into myself. So you have my sympathy... :-) Apparently you need no more help, but I'd appreciate if you posted your "interfaces" file just for the fun of it. I am a bit nosy, that's all.

By the way... The Networking Applet won't help you in Dapper as it does not have a WPA option. Does the Edgy one have??

EDIT:
What "page 4" of my documentation are you referring to??? You mean the other thread mentioned?

Hey weiman01,
Lol...traps is right! but this thread and a little research was key to understanding what Edgy needs to get wl going. This "doc" is point number 9 of this thread...sorry I was not clear...when it prints out on paper page 4 is the key to getting your Internet connection working with any type of encryption...
I think it is on the first page of this same thread you will see the below quote...

>>9. address, netmask, network, broadcast, gateway, dns-nameservers:
>> Also self-explanatory... be aware that "broadcast" needs to end with ".255" for negotiation with the router. These lines need to be according to your own network settings.

As for WPA-PSK key generation, type the following command in a terminal:

Quote:
wpa_passphrase <your_essid> <your_ascii_key>
Resulting in an output like...

Quote:
network={
ssid="test"
#psk="12345678"
psk=fe727aa8b64ac9b3f54c72432da14faed933ea511ecab1 5bbc6c52e7522f709a
}
Copy the "hex_key" (next to "psk=...") and replace <your_hex_key> in the "interfaces" files with it. Then save the file and restart your network:

Quote:
sudo /etc/init.d/networking restart
You should be connecting to your router now...<<


Edgy's Networking_applet does not allow for any obvious differences in configuration...they just removed the word WEP and changed it to Network Password....I am thinking you do not need to use it at all to get setup or connected.....just follow your HowToo. Right now my wireless setup in the Networking_applet is now disabled...I enabled it to set it up last night thinking that was how Edgy would know I had a card, ESSID, PSK, etc....but I am thinking now it is not needed. Im guessing you did not use it? If you do use it you get this at the bottom of your Interfaces file:

auto lo
iface lo inet loopback

auto wlan0
iface wlan0 inet static
wpa-driver wext
wpa-conf managed
wpa-ssid Digger
wpa-ap-scan 2
wpa-proto RSA
wpa-pairwise CCMP
wpa-group CCMP
wpa-key-mgmt WPA-PSK
wpa-psk 2e89d446b73d2281c685f087c76742bb2409b17f175774acdd 82b3e438f0580a
address 10.18.81.25
netmask 255.255.255.0
network 10.18.81.0
broadcast 10.18.81.255
gateway 10.18.81.2
dns-nameservers 10.18.81.2
wireless-essid Digger
wireless-key 0EGgN94V5rER1EAGNw7KIGOTJbfyBNoT3UQEeblubdYLvMZAPy YRk93CwPgGvdR


That is my routers hex key entered into the Network_applet....you can simply delete the two lines and your Interface file works fine using /etc/init.d/networking restart....if you don't delete the lines /etc/init.d/networking restart, at cli, will generate errors but still work. Of course you still have to generate a wpa_passphrase like page 4 says "wpa_passphrase <essid> <hex or ascii key>"

and enter it into your Interfaces file. So I am thinking you do not need the Networking_applet at all for this. Just use an Interfaces file with a generated psk.

My config file:

auto lo
iface lo inet loopback

auto wlan0
iface wlan0 inet static
wpa-driver wext
wpa-conf managed
wpa-ssid Digger
wpa-ap-scan 2
wpa-proto RSA
wpa-pairwise CCMP
wpa-group CCMP
wpa-key-mgmt WPA-PSK
wpa-psk 2e89d446b73d2281c685f087c76742bb2409b17f175774acdd 82b3e438f0580a
address 10.18.81.25
netmask 255.255.255.0
network 10.18.81.0
broadcast 10.18.81.255
gateway 10.18.81.2
dns-nameservers 10.18.81.2

You can see the psk is the one generated by Edgy...not the one I have in my router or the one I put in Networking_applet (which is now turned off for all devices...actually it is on but all devices are not enabled....not needed)

Anyway...TKIP, then CCMP worked fine for me also....easy and quick change in testing. I think a lot of people do not understand this procedure and are getting stuck trying to config wl....some are using wpa_supplicant like I was but I believe this is the recommended configuration. It is simple if your drivers show they are working and active before you start configuring the Interfaces file.

Thanx again,

squibt

wieman01
November 1st, 2006, 01:37 AM
The Gnome networking applet does WEP only. That's why it adds those 2 lines at the bottom of the "interfaces" configuration file. That's WEP terminology:

wireless-key 0EGgN94V5rER1EAGNw7KIGOTJbfyBNoT3UQEeblubdYLvMZAPy YRk93CwPgGvdR
So yes, we can forget about the applet if we use WPA.

If you choose to set up WPA encryption/authentication using "interfaces" then wpa_supplicant will configure "/etc/wpa_supplicant.conf" for you. The file is still there & apparently used by the system, it's just the way of controlling it what is different. Check it out on your system.

Ok, I think it makes probably sense to enhance this documentation & include WPA1, WEP, LEAP, EAP, etc. as well as other chipsets. Perhaps there is a chance that we get together soon.

squibT
November 1st, 2006, 02:10 AM
So the Network_applet is misleading...they just renamed the Key box from WEP to Network Password....be nice if it would have the options WEP, WPA1, WPA2, Radius,...whatever and have it really config your Interface file for you. And allow you to enable and disable an interface via this tool so you can switch between wl and wired. Right now if you mess with the wl in it it sometimes deletes all your Interfaces settings. And too it seems a bit odd you can enter your Hex key from your router say....but it is not recognized by Edgy as a valid key....you have to tell Edgy to make a new key for the Interfaces file...from your router key...seems like a needless duplication to me.

Anyway, I will test out WEP, WPA1 (AES/TKIP fall back), WPA2 going by the HowToo step by step to make sure all works like it should.

I will keep in touch....

squibt

wieman01
November 1st, 2006, 05:21 AM
Yes, I think the default network applet is kind of flawed. That's why most people prefer NetworkManager over the applet, however, NetworkManager has certain drawbacks (e.g. no support for static IP or hidden ESSID, etc.) that make it impossible for me to use.

BTW: AES (CCMP) is part of the WPA2 specification as opposed to TKIP (WPA1). You'll find all the technical details on the Wikipedia website.

EDIT:
Or more precisely, this guide covers what most people refer to as WPA2: AES with PSK (pre-shared key) rather than EAP (Extensible Authentication Protocol). The latter requires a authentication server which is costly & complex and therefore not suitable for home use. I have never tried out the full implementation of 802.11i (= WPA2) including an EAP server, simply because I don't happen to have one back home. My company has implemented it of course, but you can do nothing in a Windows based environment.

squibT
November 1st, 2006, 06:05 AM
I guess Ubuntu/Edgy still needs some wl app-driver connectivity work...we will have to be patient till the devs get around to it and the IT community and companys dealing in wl products in general come more on onboard with Linux...and stop holding their proprietary drivers so close to their vests.

The reason why I included AES/TKIP is that I am using DD-WRT on my routers and have the options TKIP, AES, TKIP+AES which is supposed to give the client the option to fall back to TKIP if they cannot do AES....dunno if it works but I will test this also.

Later...

wieman01
November 1st, 2006, 06:18 AM
This does work also... You can simply add options:

auto wlan0
iface wlan0 inet static
wpa-driver wext
wpa-conf managed
wpa-ssid <your_essid>
wpa-ap-scan 2
wpa-proto WPA RSN
wpa-pairwise TKIP CCMP
wpa-group TKIP CCMP
wpa-key-mgmt WPA-PSK
wpa-psk <your_hex_key>
address 192.168.168.40
netmask 255.255.255.0
network 192.168.168.0
broadcast 192.168.168.255
gateway 192.168.168.230
dns-nameservers 192.168.168.230
RSN stands for WPA2 actually; CCMP "kind of" for AES.

mahy
November 2nd, 2006, 08:13 PM
Hi,

what about moving around with a laptop? Will have to edit /etc/network/interfaces everytime i come across a new network? (Pretty clumsy, eh?) I hope not so. Can you explain it to me?

wieman01
November 3rd, 2006, 01:11 AM
Hi,

what about moving around with a laptop? Will have to edit /etc/network/interfaces everytime i come across a new network? (Pretty clumsy, eh?) I hope not so. Can you explain it to me?
In that case you have 2 options I am aware of:

1. gnome-network-manager (GUI), network-manager (daemon)
2. wifi-radar

Hope this helps.

tedrogers
November 7th, 2006, 09:42 PM
Can you please explain (and sorry for being a dumbass) what the typical equivalents of these are:

address 192.168.168.40
netmask 255.255.255.0
network 192.168.168.0
broadcast 192.168.168.255
gateway 192.168.168.230
dns-nameservers 192.168.168.230

I'm just a bit confused between address and network, broadcast and dns-nameservers.

Netmask and gateway are easy.

Another thing....if I set all this up by DHCP (i.e. replace STATIC with DHCP in the interfaces file) - do I even need to bother setting any of the IP addresses for the router?

Thanks.

wieman01
November 8th, 2006, 12:43 PM
DHCP is - of course - possible. See post #4 (WPA1). In that case you would not have to worry about address, netmask, etc. Still want to know what address and network, broadcast and dns-nameservers stand for?

tedrogers
November 8th, 2006, 12:53 PM
Thanks...and yes...what are the equivalents of these. Ubuntu seems to call things by different names...e.g. why would AES be CCMP?? I'd never guess this.

Not had much luck with WPA so far, tried for 6 hours last night...will keep at it though. Have posted in lost of places, some of them were yours.

Also, is there any reason why I can't use a 63 character PSK?

And...why don't I have a wpa_supplicant.conf file in /etc? Should I have one of these?

Finally (for now) - could you replace the line 'wext' for 'ndiswrapper'?

Thanks.

wieman01
November 8th, 2006, 01:10 PM
I have replied to you in the other thread.

1. You have probably skipped the part where I mention the PSK key generation (passphrase).
2. "wext" is the right driver for "ndiswrapper". The latter is obsolete.
3. The relationship between CCMP & AES is explained in the Wiki (link also given). They explain it in a much more accurate manner than I could possibly do.
4. "/etc/wpa_supplicant.conf" was part of the previous versions of "ndiswrapper". The latest once don't seem to have it by default.
5. I send you a link on networking later on.

apis
November 9th, 2006, 04:18 AM
Wow! I just did it! I was desperate before I encountered this thread! You did really good job guys! Thanks for that! :D

I used "Sample configuration WPA1 & DHCP, ESSID broadcast enabled" and it worked perfectly for my hardware.

Linksys WMP54G rev2 (Broadcom 4306) PCI network card and router Linksys WRT54G.

wieman01
November 9th, 2006, 06:04 AM
Wow! I just did it! I was desperate before I encountered this thread! You did really good job guys! Thanks for that! :D

I used "Sample configuration WPA1 & DHCP, ESSID broadcast enabled" and it worked perfectly for my hardware.

Linksys WMP54G rev2 (Broadcom 4306) PCI network card and router Linksys WRT54G.
Using "ndiswrapper"? And what "wpa-driver" are you using (I assume "wext")? Just for the record...

Dr. Cox
November 9th, 2006, 12:41 PM
hi there,

i've tried your instructions for wpa1,etc. only problem for me is that my essid is hidden and not being broadcasted.
iwlist scan notices the signal being present as well as the channel.

i tried your sample for wpa1, dhcp and tried both, wpa-ap-scan 1 as well as 2. it wouldn't work.

sometimes it just didn't work without any error message.
sometimes it gave me error 9 or error 10, i think, saying that ifup and ifdown couldn't read or open /etc/network/interfaces

any idea? i'm sorry i couldn't provide the usual output you asked for, but i've i-net only at work right now. any help is appreciated.

cheers

wieman01
November 9th, 2006, 12:56 PM
That's a tough question... "wpa-ap-scan 2" is certainly the right setting if the broadcast of ESSID is disabled. It would certainly help if you posted your "interfaces" config-file and told us a bit more about your card/chipset. I am sure we can resolve this.

As for the read-permission... Please check if "interfaces" has the right permission settings:

ls -l /etc/network/
If not that's how you change the permissions:

sudo chmod ug=+rw /etc/network/interfaces

Dr. Cox
November 9th, 2006, 02:19 PM
it's a intel centrino ipw2100 wireless chipset.
read and write permission are granted.
i also tried running it as root.
didn't change anything. try to post config files tonight

cheers

wieman01
November 9th, 2006, 02:46 PM
it's a intel centrino ipw2100 wireless chipset.
read and write permission are granted.
i also tried running it as root.
didn't change anything. try to post config files tonight

cheers
That'd be best... Post the error message you encounter at the same time.

apis
November 11th, 2006, 04:57 AM
Using "ndiswrapper"? And what "wpa-driver" are you using (I assume "wext")? Just for the record...

I am using ndiswrapper and wext, it looks like wpa_supplicator doesn't work with standard bcm43xx driver, although if you don't need WPA bcm43xx works reasonably well. Few more details I am on edgy and ndiswrapper and wpa_supplicant are from standard edgy repositories as well. And I also have issue with network restart.

DavidTangye
November 12th, 2006, 04:02 PM
This thread resulted in my getting a Broadcom 4318 wireless installed and running with WPA(1) under Edgy. I am basically using your example '*Sample configuration WPA1 & DHCP, ESSID broadcast enabled*' from your message #1. Thanks very much.:D

A slight improvement on this is that actually, to get wireless up at bootup, all you need is to do this as root:

echo 'ifdown wlan0' >/etc/init.d/WlanDown
chmod +x /etc/init.d/WlanDown
ln -s ../init.d/WlanDown /etc/rcS.d/S40WlanDown
This runs S40WlanDown just before S40networking, so tidies up something in the wlan setup. Then S40networking runs ../init.d/networking which runs 'ifup -a' which successfully starts wlan0 and all other interfaces.

The source problem is a bug whereby at shutdown 'ifdown -a' does not seem to run (successfully) :not effectively doing an 'ifdown wlan0'.

Now I just gotta find again (for the record) where is the other forum message that told me where to get a tarball, that had the driver, and a script to do a lot of the work for me.

wieman01
November 13th, 2006, 10:22 AM
This thread resulted in my getting a Broadcom 4318 wireless installed and running with WPA(1) under Edgy. I am basically using your example '*Sample configuration WPA1 & DHCP, ESSID broadcast enabled*' from your message #1. Thanks very much.:D

A slight improvement on this is that actually, to get wireless up at bootup, all you need is

This runs S40WlanDown just before S40networking, so tidies up something in the wlan setup. Then S40networking runs ../init.d/networking which runs 'ifup -a' which successfully starts wlan0 and all other interfaces.
Great. Thank you as well for the script. I will try it out sometime this week & update the guide.

Would you mind sharing your configuration with us? So the I can take a glance at the "wpa-driver", etc. Just curious, and it it perhaps helpful for others with Broadcom chipsets as well.

tedrogers
November 13th, 2006, 12:52 PM
This thread resulted in my getting a Broadcom 4318 wireless installed and running with WPA(1) under Edgy. I am basically using your example '*Sample configuration WPA1 & DHCP, ESSID broadcast enabled*' from your message #1. Thanks very much.:D

A slight improvement on this is that actually, to get wireless up at bootup, all you need is

This runs S40WlanDown just before S40networking, so tidies up something in the wlan setup. Then S40networking runs ../init.d/networking which runs 'ifup -a' which successfully starts wlan0 and all other interfaces.

The source problem is a bug whereby at shutdown 'ifdown -a' does not seem to run (successfully) :not effectively doing an 'ifdown wlan0'.

Now I just gotta find again (for the record) where is the other forum message that told me where to get a tarball, that had the driver, and a script to do a lot of the work for me.

Hi,

I assume by 'bootup' you mean outside of X windows in a plain old terminal? Before X is loaded, perhaps in Recovery Mode?

I can see why this would be useful.

Thanks.

wieman01
November 13th, 2006, 03:02 PM
Hi,

I assume by 'bootup' you mean outside of X windows in a plain old terminal? Before X is loaded, perhaps in Recovery Mode?

I can see why this would be useful.
Yes, this kind of operation can only be run as "root" process. Once X is up & running you are sort confined as to what process you can run. That's to do with Linux' architecture (without going into detail). Found this link which may be interesting in that respect:

https://wiki.ubuntu.com/StreamlinedBoot?highlight=%28rcs%29

tedrogers
November 13th, 2006, 07:58 PM
When I run this in X windows...


echo 'ifdown wlan0' >/etc/init.d/WlanDown
ln -s ../init.d/WlanDown /etc/rcS.d/S40WlanDown

...I get permission denied...even with sudo appended to the front.

Do I need to run this in a root terminal, or by CTRL + ALT + F1 and logging in?

Also have you tried this yet Wieman?

Thanks.

wieman01
November 14th, 2006, 01:23 AM
Deleted...

tedrogers
November 14th, 2006, 10:12 AM
Even if I run these using sudo...


sudo echo 'ifdown wlan0' >/etc/init.d/WlanDown
sudo ln -s ../init.d/WlanDown /etc/rcS.d/S40WlanDown

...I get permission denied.

Could this be because of the chmod command we ran before to change permissions on the wlan config files?

tedrogers
November 14th, 2006, 08:48 PM
Sorry for the double post here, but the solution is listed at this post:

http://ubuntuforums.org/showthread.php?t=299651

Basically, these commands need to run at a root terminal. To get access through a normal terminal, type the following:


sudo -i

Then issue these commands without the 'sudo' prefix (as mentioned by me previously).


echo 'ifdown wlan0' >/etc/init.d/WlanDown
ln -s ../init.d/WlanDown /etc/rcS.d/S40WlanDown

Alternatively, you should be able to run the root terminal from the Application > System Tools menu...as long as you have enabled this option within the Preferences > Menu Layout configuration.

Hope this helps.

DavidTangye
November 16th, 2006, 06:18 AM
sudo echo 'ifdown wlan0' >/etc/init.d/WlanDown

Yes this line is incorrect because >/etc/init.d/WlanDown is checked in the shell that presents that line, ie your current shell. At that point 'you' are the command presenter not root, so 'you' get the erro message that 'you' do not have the necessary permissions, and the sudo command is not even attempted.

This works:

sudo bash -c 'echo "ifdown wlan0" >/etc/init.d/WlanDown'

because here the access to /etc/init.d/WlanDown is not attempted until a bash shell is run by the user root.

The command "echo 'ifdown wlan0' >/etc/init.d/WlanDown" must be run by root, from a bash shell started by, eg

"sudo -i" (login fully and run your default shell, probably bash), or
"sudo bash" (just run a bash shall)
"sudo bash -c ... " (just run a single command in a bash shell as per above)

giruzz
November 20th, 2006, 04:07 AM
Success!

Thansk to SquibT and wieman01 for your guide. I just switched from WinXp and everything worked without problems.

FYI, I first followed another guide (the one that you can find in the wiki section) and didn't work. Following your instructions solved all my problems in 30sec :D

Great job!

giruzz

wieman01
November 21st, 2006, 01:13 AM
Since it's a pretty common & popular wireless card, I am including a sample configuration for IPW2200, DHCP, WPA1 (TKIP), broadcast of ESSID enabled.

auto lo
iface lo inet loopback

auto eth1
iface eth1 inet dhcp
wpa-driver wext
wpa-conf managed
wpa-ssid your_essid
wpa-ap-scan 1
wpa-proto WPA
wpa-pairwise TKIP
wpa-group TKIP
wpa-key-mgmt WPA-PSK
wpa-psk MY_GENERATED_PSK_THINGIE
Thanks to user "Karmapolice" for it. Perhaps this helps others.

giruzz
November 21st, 2006, 11:12 AM
Just one little problem...

now when the system is re-booting it takes ages to start...

this because the system is re-starting my lan card and because there isn't a cable connected the system waits..and waits...and finally goes on timeout...

just wondering..there is any way to re-restart only the wifi card?

thanks

giruzz

wieman01
November 21st, 2006, 12:39 PM
Just one little problem...

now when the system is re-booting it takes ages to start...

this because the system is re-starting my lan card and because there isn't a cable connected the system waits..and waits...and finally goes on timeout...

just wondering..there is any way to re-restart only the wifi card?
Can you try post #32 / #40 instead of my script? Would that help? If not, we go for plan B.

giruzz
November 22nd, 2006, 11:19 AM
Sorry,

not sure I understood what I should change the current

networking script with the script of post #32?

thanks

giruzz

cantormath
November 22nd, 2006, 11:25 AM
Nice tutorial.

wieman01
November 22nd, 2006, 01:32 PM
Sorry,

not sure I understood what I should change the current

networking script with the script of post #32?
Yes, please delete my stuff & try the other script. That's all.

tedrogers
November 22nd, 2006, 02:20 PM
Wieman01 means that all of the posts on this forum are numbered on the right hand side...he is just asking you to use the script listed in post number 32 instead .

giruzz
November 23rd, 2006, 11:50 AM
Sorry..but I cannot get it work....

I'm really sorry..but I couldn't understand where to replace what... (ok..I know I have to change/delete the old script)

(I'm a n00b)

byeee

g.

tedrogers
November 23rd, 2006, 02:40 PM
I think this is right. First get to a Root Terminal (not the regular terminal). You get to a Root Terminal by running this code in a normal terminal:


sudo su

Now enter your password and you are now a root (super)user.

Right, here is the code from post number 32:


echo 'ifdown wlan0' >/etc/init.d/WlanDown
ln -s ../init.d/WlanDown /etc/rcS.d/S40WlanDown

Try running this in the Root Terminal. Make sure you copy and paste each line seperately...do not copy and paste both lines as this will not work. Do each line at a time.

Then make it executable (so it can be run at startup) using this command:


chmod +x /etc/init.d/WlanDown

Once you have done this, try rebooting and see if your wireless wlan works on reboot.

If it doesn't work try using the code from post number 40, which you can run in a normal terminal I believe (but if it doesn't work try as a root terminal just like above):


sudo bash -c 'echo "ifdown wlan0" >/etc/init.d/WlanDown'

Don't forget to make it executable (so it can be run at startup) using this command:


chmod +x /etc/init.d/WlanDown

Then restart again and see if that has fixed it for you.

wieman01
November 23rd, 2006, 02:52 PM
Obsolete...

giruzz
November 24th, 2006, 08:06 AM
Thanks for your help.
I couldn't make it work.

I opened a new thread here (http://ubuntuforums.org/showthread.php?p=1799852#post1799852),

I hope that somebody can help me!

thanks

g.

tebibyte
November 25th, 2006, 12:34 AM
You have to go through all this just to get WPA to work? This is absolutly rediculous. Users shouldn't even have to go to the command propmt to use something that is used this widely.

tedrogers
November 25th, 2006, 12:41 AM
There really is only about 4 -5 steps to get it working.

Yes...it should work out of the box...but with some wireless pcmcia (inc. broadcom chips) it doesn't...so this is the fix.

This ain't win-blows - but it's free (!!) and just as good once you are up and running.

Don't get me wrong...this is one of the more problematic areas - most stuff works straight out of the box.

Don't get disheartened...the community is here to help you.

wieman01
November 25th, 2006, 04:33 AM
You have to go through all this just to get WPA to work? This is absolutly rediculous. Users shouldn't even have to go to the command propmt to use something that is used this widely.
There are options: NetworkManager or Wifi-Radar... However, all of these tools have certain drawbacks. Nonetheless, see for yourself what's the best solution. Wireless support in Linux is not yet perfect, in particular when it comes to EAP.

aysiu
November 25th, 2006, 05:28 AM
You have to go through all this just to get WPA to work? This is absolutly rediculous. Users shouldn't even have to go to the command propmt to use something that is used this widely.
Good thing the Ubuntu developers are working on improving this.

tedrogers
November 25th, 2006, 08:34 PM
This is good to hear.

Do ya think they'll include (by default) build-essential, w32codec and the rest of the stuff we all use in the next release?

Fingers crossed.

aysiu
November 25th, 2006, 08:41 PM
This is good to hear.

Do ya think they'll include (by default) build-essential, w32codec and the rest of the stuff we all use in the next release?

Fingers crossed.
No, they won't.

w32codecs are owned by Microsoft, and they've decided for "security reasons" that build-essential won't be installed by default (I happen to disagree, but that's their decision).

tedrogers
November 26th, 2006, 12:58 AM
I suspected that thye might think that build-essential might be a bit dangerous for new users...but I have to agree with you that I don't quite see how.

usererror
November 28th, 2006, 07:02 PM
Kudos to those have have contributed to this thread and the original poster! this is great. Using the WPA1 sample and my Intel 3945 wifi card it worked perfect on the 2nd try! (first try was user error :D )

I am now trying to test the EAP-FAST environment. At work we are in a domain environment, which requries EAP-FAST using DOMAIN\username format with domain password, the certificate and WEP...

If anyone has any ideas off the bat i'm open to them. I'm working from the EAP-FAST sample on page 1 of this thread. :)

wieman01
November 29th, 2006, 01:09 AM
I am now trying to test the EAP-FAST environment. At work we are in a domain environment, which requries EAP-FAST using DOMAIN\username format with domain password, the certificate and WEP...
Excellent. I was actually looking for users that could test EAP scripts for me. Back home I don't happen to have an authentication server... Please don't hesitate to ask for help. I really want to sort this out & update the thread. Thank you!

tedrogers
December 2nd, 2006, 03:55 PM
Hi,

I just went back from Edgy to Dapper...and the weird thing for me is that all instances of wlan0 in the /etc/network/interfaces file had to be changed to eth1 for it to work.

So in order to get it to work I had to change this:


auto wlan0
iface wlan0 inet dhcp
etc...

...to this:


auto eth1
iface eth1 inet dhcp
etc...

Does anyone know why this is?

Is there a way I can change this so that my wireless is called wlan0 and not eth1.

Forgive me for being picky, but I like it to be called what it actually is! It's less confusing that way.

Thanks.

wieman01
December 2nd, 2006, 05:46 PM
Hi Ted,

Let's discuss this on another thread in detail. Hard to tell what the problem is but "wlan0" usually refers to "ndiswrapper" which I don't think is installed in a fresh system. I reckon your wireless card has been recognized out of the box, hence the system refers to your interface as "eth1".

That said, let's discuss that in another (more appropriate) thread.

roachk71
December 9th, 2006, 07:29 AM
Many thanks indeed!

Before these hints were available I kept trying (unsuccessfully each time) to configure wpasupplicant using the advanced method; this procedure has changed to the simpler /etc/network/interfaces approach since Hoary.

An extremely helpful set of instructions! 8)

By the way: My card's a Netgear WG511v2 (Made in China, Libertas chipset); if anybody else has this card, you don't really have to compile a custom kernel to make it work (unless your computer has a high-end AMD,) but you need the server kernel and headers, along with build-essential and the latest NDISwrapper from source.

Once you've installed the necessary packages (and you're running the newly-downloaded kernel,) unpack the NDISwrapper tarball and follow the instructions in the INSTALL document, then use this configuration for the card.

Another thing: Some computers won't keep the link up (this is a bug, which is easy to remedy.)

From the terminal, type:

sudo gedit /etc/init.d/wireless-network.sh
and add this line:

/etc/init.d/networking restart

Save this file and exit your text editor. Then, create a symlink:

sudo ln -s /etc/init.d/wireless-network.sh /etc/rcS.d/S42wireless-network

Now, make this change executable (nearly forgot):

sudo chmod +x /etc/init.d/wireless-network.sh

and restart. Your card should be up and running after the reboot. Enjoy!

jinhr
December 12th, 2006, 06:37 AM
I am using WPA2 +AES with hidden ESSID.
Router = Linksys WRT 54GC
Laptop = IBM Thinkpad R52 with iwp2200.

Here are my successful codes.

===start===
auto eth1
iface eth1 inet dhcp
wpa-driver wext
wpa-conf managed
wpa-ssid skywalker
wpa-ap-scan 2
wpa-proto RSN
wpa-pairwise CCMP
wpa-group CCMP
wpa-key-mgmt WPA-PSK
wpa-psk 3c00852a3d2ab654d7290a98534d8574d1aca3061621d6cd47 9e1275c145802a
===end===

The only problem:
I can not run "/etc/init.d/networking restart" without sudo.

jinhr@Ubuntu:~$ /etc/init.d/networking restart
open: Permission denied
* Reconfiguring network interfaces... ifdown: failed to open statefile /var/run/network/ifstate: Permission denied
ifup: failed to open statefile /var/run/network/ifstate: Permission denied
open: Permission denied
[fail]

I checked "ls -ln /var/run/network/ifstate" which says:
-rwxr-xr-x 1 0 0 26 2006-12-12 00:22 /var/run/network/ifstate

I think I can not run the sh file at start up due to no-right for "/var/run/network/ifstate"

Can wieman01 help me on this?

Currently I have to type manually "sudo /etc/init.d/networking restart" after ubuntu starts up.

wieman01
December 12th, 2006, 07:02 AM
Hello Jinhr,

Post #2 definitely works... Just follow the steps given & restart the computer. All init-script are run by the system with root privileges, so you don't have to worry about "sudo" at all. Simply add the mentioned script & reboot. That's it.

I have a IPW2200 as well & therefore I can confirm that this works.

sefs
December 12th, 2006, 06:49 PM
This is the best wpa tutorial ever!

Finally i am able to move from wep to wpa and did not even have to fiddle with networkmanager or wpasupplicant or any of that nonsense.

Thanks to the creator of this great tutorial!

I'm using a cnet usb key (Ralink - RT73) with ndiswrapper and the windows drivers for this card that came on the CD

Floor19
December 13th, 2006, 03:29 PM
Thanks for this great HOWTO, finally i can use WPA encryption with the WPA2 only conf file and a Linksys WPC54G PMCIA card.

I only have one problem.

With the PMCIA plugged in i can't get past the login screen. Everything loads fine but after entering my login and password i get a black screen with only my mouse symbol visible (no lockup)

Without my card plugged in I can login as normal and when i plug in the card ndiswrapper loads my conf file i am up and running.

It works but does someone knows the problem for the black screen?!

Thanks and again for the HOWTO.

Floor

EDIT

added the folowing lines in etc/network/interfaces and no more problems with startup.

auto lo
iface lo inet loopback

Cheers!

compwiz18
December 17th, 2006, 11:01 PM
Great tutorial.

You are right, it is far easier then using the wpa_supplicant.conf file. Just pop the settings in, restart networking, and you're connected :D

Now to make connection-manager do this automatically.

And I'm gonna need some to test LEAP, like we discussed.

compwiz18
December 17th, 2006, 11:33 PM
Question: It would appear that the dns-nameservers line doesn't do anything, and I can't find anything about it in the man interfaces manual page...

any ideas?

thanks again for your help and this tutorial

wieman01
December 18th, 2006, 04:07 AM
Please let us know once your "network-manager" is ready. I will post a link to your site in my tutorial because I am really convinced it could make "life" considerably easier.

As for "dns-nameserver", it does serve a purpose. As the name suggests this refers to the IP address of the server that resolves domain names & lets you browse the Internet using words rather than IP addresses. :-) Since routers normally act as gateways & communicate with DNS servers provided by your ISP, all you have to do is state your gateway's IP address here. Using STATIC IP rather than DHCP requires you to set the DNS server manually as well. Does that more or less answer the question?

compwiz18
December 18th, 2006, 04:13 AM
Right. But it doesn't update resolv.conf with the new addresses...which is what is confusing me. Am I correct in thinking that /etc/resolv.conf should be updated with those addresses when I sudo /etc/init.d/networking restart?

wieman01
December 18th, 2006, 04:21 AM
I would think that "/etc/resolv.conf" updates itself... Usually there is no need to update it yourself, it takes whatever information is available through "/etc/networking/interfaces".

compwiz18
December 18th, 2006, 04:27 AM
I would think that "/etc/resolv.conf" updates itself... Usually there is no need to update it yourself, it takes whatever information is available through "/etc/networking/interfaces".
Well, it doesn't seem to be updating automatically. Oh well, not a giant problem, I'll just have the program update it. I'm just wondering why it doesn't do it by itself.

Thanks for you help, and thanks for the great tutorial.

uber_nerd11
December 18th, 2006, 05:28 PM
I know that some people are working on different EAP situations, so I have a question concerning that. The university I am attending is using WPA or WPA2 Enterprise with PEAP and a security certificate. For Windows machines the network fails if they do not have the right certificate selected for use. When I signed on to the wireless for the first time it asks for my username and password for the school as it should. From there everything works fine even though I don't have a certificate set. My first question is where can I go to get the security certificates? My second is am I still securely using the network even though I don't have a security certificate tied to the connection?

wieman01
December 19th, 2006, 12:33 AM
My first question is where can I go to get the security certificates?
You network administrator should provide it. So the first thing you should do is get in touch the staff there.

My second is am I still securely using the network even though I don't have a security certificate tied to the connection?
Well, you probably won't be able to authenticate and hence connect to the university network. That's the whole point of a certificate: authentication.

That said, I would use NetworkManager for EAP-PEAP. Of course I appreciate if you tested the scripts given, but it's probably wasting your time so I recommend that you take a look at this thread (http://www.ubuntuforums.org/showthread.php?t=316582&page=2&highlight=PEAP). The guy also attached a screenshot of NetworkManager which is a tool that actually supports PEAP out of the box. No need to mess around with text files as it seems.

compwiz18
December 19th, 2006, 03:41 AM
Which in the first post would be used for PEAP?

Again, thanks for your help.

wieman01
December 19th, 2006, 03:49 AM
Which in the first post would be used for PEAP?

Again, thanks for your help.

I have not published anything with regard to PEAP... But let's try to work it out together:

EAP-PEAP (MSCHAPV2):

auto eth1
iface eth1 inet dhcp
wpa-driver wext
wpa-conf managed
wpa-ssid your_essid
wpa-ap-scan 1
wpa-eap PEAP
wpa-key-mgmt WPA-EAP
wpa-identity your_identity
wpa-password your_password
wpa-ca-cert /etc/cert/ca.pem
wpa-phase1 peaplabel=1
wpa-phase2 auth=MSCHAPV2
wpa-priority 10
But we need someone who has got access to a RADIUS server and can test this for us... Settings are:

>> EAP-PEAP
>> ESSID broadcast enabled
>> DHCP
>> Network interfaces = eth1

compwiz18
December 19th, 2006, 03:53 AM
Thanks :D

Is it possible to run a RADIUS server in Ubuntu? (Never mind, I searched the Repos, it is) My router is capable of using a RADIUS server, so maybe I'll see if I can get that to fly. Chances are I won't though, so if someone else out there has access to an already setup RADIUS server, that would be helpful.

edit: i gave up on the setting-up-a-RADIUS-server idea, so if someone could test it, thanks :D

uber_nerd11
December 19th, 2006, 05:24 PM
The security certificate is one of the one's that come with WINXP. Its the Equifax Secure Certificate Authority one. I didn't know if there was a way to import this and other default certificates or if there were Linux versions of them out there. I have been able to connect to the wireless here on campus, so thats why I was curious about my security. I am currently using Network Manager. It was suggested to me when I first installed Ubuntu. Thanks.

wieman01
December 20th, 2006, 01:12 AM
Thanks :D

Is it possible to run a RADIUS server in Ubuntu? (Never mind, I searched the Repos, it is) My router is capable of using a RADIUS server, so maybe I'll see if I can get that to fly. Chances are I won't though, so if someone else out there has access to an already setup RADIUS server, that would be helpful.

edit: i gave up on the setting-up-a-RADIUS-server idea, so if someone could test it, thanks :D
You router certainly has a RADUIS setting, however, you need to set up a RADUIS to support it. The RADIUS function only allows you to connect to a dedicated RADIUS server. I am sure you would be able to set it up using Ubuntu. I would do it, unfortunately I will be on the road in the next couple of weeks.

EDIT:
I asked other users to help me with testing a while ago... Perhaps we can make use of this thread (http://www.ubuntuforums.org/showthread.php?t=304706). Feel free to join in. Really like to see this go ahead.

compwiz18
December 20th, 2006, 01:29 AM
I just finished incorporating all the info into connection-manager on the first page of this thread, and it works like a charm :D at least for wpa2 and hidden essid and static ips, and normal unsecured visible dhcp.

And I'll put a note on my thread asking for users to test. maybe between us we can get a couple.

thanks again.

wieman01
December 20th, 2006, 01:35 AM
I just finished incorporating all the info into connection-manager on the first page of this thread, and it works like a charm :D at least for wpa2 and hidden essid and static ips, and normal unsecured visible dhcp.

And I'll put a note on my thread asking for users to test. maybe between us we can get a couple.

thanks again.
Man, that's great. I will give it a go soon & post a link to your site/package after testing it myself. Good job, buddy.

compwiz18
December 20th, 2006, 01:36 AM
I need to finish the GUI, I'll do that tomorrow. But the hard part (the part that does the work) is finished. I hope to release it by December 25. But I'll PM it to you first (as soon as it is done) so you can have a look and make sure it works.

usererror
December 21st, 2006, 04:42 AM
I am having a heck of a time getting this to work in my network environment:

We use the following:

EAP-FAST (using our active directory username and password)
Dynamic WEP
802.1x Authentication
Open Authentication.

I tried using the EAP-FAST (untested one in the howto) and it does not connect me. Does anyone else have this type of network environment? ](*,)

wieman01
December 21st, 2006, 10:04 AM
Have you tried this?

auto wlan0
iface wlan0 inet dhcp
wpa-driver wext
wpa-conf managed
wpa-ssid <your_essid>
wpa-ap-scan 1
wpa-group WEP104 WEP40
wpa-key-mgmt IEEE8021X
wpa-eap FAST
wpa-identity <your_user_name>
wpa-password <your_password>
wpa-phase1 fast_provisioning=1
wpa-pac-file /path/to/eap-pac-file
You also need the stuff in 'green'.

usererror
December 21st, 2006, 03:04 PM
Wieman01,

I think I had the green code, but the WEP part you have posted I did not have. I'll try this today and post back, thank you for your assistance!

wieman01
December 21st, 2006, 03:31 PM
No worries, I am glad you help us out as well. Would love to see this work as well because this would help a lot of other users as you can image (including me of course).

iceman1234
December 23rd, 2006, 05:42 PM
VERY good HOWTO. It worked the first time, after reading the very important rule about WPA-PSK :-)

Again, many thx.
cheers

Lysi
January 2nd, 2007, 09:07 PM
finally, I got it working as well. Thx 4 the HOWTO.

One thing bothers me still, because I haven't totally understood the process yet.

is /etc/wpa_supplicant/wpa_supplicant.conf necessary? it is used in other threads herein the forum. because everything is configured /etc/network/interfaces and it works without it.
and one more thing to add here. maybe it helps someone else.

if you have a password including bash special characters, e.g.
234$42er24r
then, a backslash in front of $ is necessary to remove its bash interpretation,

wpa_passphrase "NET1" "234\$42er24r"
network={
ssid="NET1"
#psk="234$42er24r"
psk=d95df02d0eece531d1d266ea4aa8c61691be8cc66ebde7 e2810df676b1439d97
}


it took me some time to realize that I always got the wrong network psk ](*,) ](*,)

wieman01
January 2nd, 2007, 09:58 PM
"/etc/wpa_supplicant/wpa_supplicant.conf" is not necessary if you make use of this approach.

As for the generation of the network key (PSK), it's a bit tricky if you use special characters, etc. Thanks for your post. I will update this thread in a short while and be a bit more specific in that respect. Thanks again.

nakko
January 4th, 2007, 03:16 AM
Great howto, I got my wifi up in pretty much no time. I am not exaggerating when I say it probably took me about five minutes.

I do have a problem, however! Not merely when the machine boots, but seemingly every time a DHCP lease expires, it won't renew automatically. So, every forty-thousand seconds or so (10-12 hours, usually), I have to do a

sudo /etc/init.d/networking restart
All over again. So I cannot leave the computer running, leave the house and expect to necessarily be able to SSH back into it later, among other things. =/

Something I am missing, doing wrong? Any tips?

Edit: Here's my /etc/network/interfaces file, names have been changed to protect the innocent.

# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

auto eth0
iface eth0 inet dhcp

auto ath0
iface ath0 inet dhcp
wpa-driver madwifi
wpa-conf managed
wpa-ssid {*}
wpa-ap-scan 2
wpa-proto WPA
wpa-pairwise TKIP
wpa-group TKIP
wpa-key-mgmt WPA-PSK
wpa-psk {*}
wireless-essid {*}
wireless-key {*}

wieman01
January 4th, 2007, 07:23 PM
Great howto, I got my wifi up in pretty much no time. I am not exaggerating when I say it probably took me about five minutes.

I do have a problem, however! Not merely when the machine boots, but seemingly every time a DHCP lease expires, it won't renew automatically. So, every forty-thousand seconds or so (10-12 hours, usually), I have to do a

sudo /etc/init.d/networking restart
All over again. So I cannot leave the computer running, leave the house and expect to necessarily be able to SSH back into it later, among other things. =/

Something I am missing, doing wrong? Any tips?
I suspect this has rather to do with the settings of your physical network. Usually the router allows you to change certain settings such as the beacon interval, etc. I used to have a similar problem and cautiously changing some of the settings eventually did the trick for me (e.g. reducing beacon interval default value).

nakko
January 4th, 2007, 08:36 PM
I suspect this has rather to do with the settings of your physical network. Usually the router allows you to change certain settings such as the beacon interval, etc. I used to have a similar problem and cautiously changing some of the settings eventually did the trick for me (e.g. reducing beacon interval default value).

I'm going to have to (politely!) disagree with you on that one, since the other desktops in the house & my laptop don't have this problem. And, since the router isn't mine, I cannot tinker with it.

wieman01
January 4th, 2007, 08:45 PM
I'm going to have to (politely!) disagree with you on that one, since the other desktops in the house & my laptop don't have this problem. And, since the router isn't mine, I cannot tinker with it.
I experienced the problem only after installing Ubuntu. Windows used to be no problem at all. That's all I can say... Have you got "firestarter" or something like that by chance? Perhaps that's the issue. But if you do not have access to the router, then there is not much you can do I guess. I did some thorough stability testing and the only (but ugly) option that yielded good results was to mess around with the mentioned settings.

EDIT:
What card have you got?

nakko
January 4th, 2007, 10:56 PM
What card have you got?

I'm using a D-Link DWL-G510, which comes in two revisions, but I happen to be using the one with the Atheros chipset, so I am using the madwifi drivers, and they do function perfectly (albeit only for however long). I haven't even looked into ndiswrapper.

bleearg
January 6th, 2007, 07:33 PM
I personally am about ready to throw my Ubuntu laptop out the window. I have been utterly unsuccessful in keeping my wireless connection working. ](*,)

First of all, this guide is definitely helpful - it assisted me in getting my wireless working...initially. However, after a reboot, the wireless simply won't work. It won't associate with my AP. I'm using WPA2/CCMP, which is not at all complicated. My SSID is hidden, and I do have the 'wpa-ap-scan' set to '2'.

Output from the 'wpa_cli' simply states:


<2>Authentication with 00:00:00:00:00:00 timed out.
<2>Trying to associate with SSID 'blah'

Here is my 'interfaces' file:


auto eth1
iface eth1 inet dhcp
wpa-driver wext
wpa-conf managed
wpa-ssid <ssid>
wpa-ap-scan 2
wpa-proto RSN
wpa-pairwise CCMP
wpa-group CCMP
wpa-key-mgmt WPA-PSK
wpa-psk <secret_key>

Here is the output of 'iwconfig' and 'iwlist scan':


lo no wireless extensions.

eth0 no wireless extensions.

irda0 no wireless extensions.

eth1 IEEE 802.11g ESSID:"myssid"
Mode:Managed Frequency:2.412 GHz Access Point: 00:12:17:AA:7A:CC
Bit Rate:54 Mb/s Tx-Power=20 dBm Sensitivity=8/0
Retry limit:7 RTS thr:off Fragment thr:off
Power Management:off
Link Quality=86/100 Signal level=-44 dBm Noise level=-90 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:11 Missed beacon:0

sit0 no wireless extensions.

user@host:~$ iwlist scan
lo Interface doesn't support scanning.

eth0 Interface doesn't support scanning.

irda0 Interface doesn't support scanning.

eth1 Scan completed :
Cell 01 - Address: 00:12:17:AA:7A:CC
ESSID:"<hidden>"
Protocol:IEEE 802.11bg
Mode:Master
Channel:1
Encryption key:on
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 6 Mb/s; 9 Mb/s
11 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
48 Mb/s; 54 Mb/s
Quality=91/100 Signal level=-37 dBm
IE: IEEE 802.11i/WPA2 Version 1
Group Cipher : CCMP
Pairwise Ciphers (1) : CCMP
Authentication Suites (1) : PSK
Extra: Last beacon: 268ms ago

sit0 Interface doesn't support scanning.

I'm on an IBM T43 laptop with an Intel 2200BG wireless adapter. What's the deal?

EDIT:
No less than two minutes after posting this, but after having done absolutely nothing to change anything, I did an 'ifdown eth1' and 'ifup eth1' and my wireless was suddenly associated. What would cause this behavior?

wieman01
January 6th, 2007, 10:20 PM
Take a look at the second post (#2) of this thread. I am having the exact same problem with the Intel IPW2200. I have to restart the network during startup in order to get connected while the computer is booting. Try post #2 and see if it does the job for you. I am sure it will.

EDIT:
This is a bug by the way...

bleearg
January 11th, 2007, 01:17 PM
Thanks for the response, weiman01, but that didn't work. At first, I thought it had something to do with whether or not 'eth0' was enabled in the /etc/network/interfaces file. However, last night, it stopped working altogether. When my 'iwlist scan' is run, it never sees my SSID.

lo900
January 11th, 2007, 05:37 PM
My hat off to you, many thanks for this how to

it worked perfect for me (WPA2-psk)

on Toshiba-Tecra and on HP-dv5000

Thanks gain

Lo900

squibT
January 12th, 2007, 12:44 AM
Thanks for the response, weiman01, but that didn't work. At first, I thought it had something to do with whether or not 'eth0' was enabled in the /etc/network/interfaces file. However, last night, it stopped working altogether. When my 'iwlist scan' is run, it never sees my SSID.

...... Extra: Last beacon: 268ms ago

This beacon interval should probably read 100 or 50 if modified because your are having connectivity problems. Not that your beacon interval is set at 268....it is just odd you lost your connection for a while..Let me ask this...

Is it you dont wish to mess with the router your ISP gave you or is it a shared router that a neighbor manages?

giosetti
January 15th, 2007, 01:15 AM
I proceeded the way described in "Sample configuration mixed mode (WPA1, WPA2) & DHCP, ESSID broadcast" with this result:

giosetti@ubuntu:~$ sudo /etc/init.d/networking restart
* Reconfiguring network interfaces... Internet Systems Consortium DHCP Client V3.0.3
Copyright 2004-2005 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/products/DHCP

Listening on LPF/eth0/00:80:5a:24:c1:35
Sending on LPF/eth0/00:80:5a:24:c1:35
Sending on Socket/fallback
DHCPRELEASE on eth0 to 192.168.2.1 port 67
ioctl[SIOCSIWAUTH]: Operation not supported
WEXT auth param 7 value 0x1 - ioctl[SIOCSIWENCODEEXT]: Operation not supported
ioctl[SIOCSIWENCODEEXT]: Operation not supported
ioctl[SIOCSIWENCODEEXT]: Operation not supported
ioctl[SIOCSIWENCODEEXT]: Operation not supported
ioctl[SIOCSIWAUTH]: Operation not supported
WEXT auth param 4 value 0x0 - ioctl[SIOCSIWAUTH]: Operation not supported
WEXT auth param 5 value 0x1 - Internet Systems Consortium DHCP Client V3.0.3
Copyright 2004-2005 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/products/DHCP

Listening on LPF/rausb0/00:13:d4:09:29:9c
Sending on LPF/rausb0/00:13:d4:09:29:9c
Sending on Socket/fallback
DHCPDISCOVER on rausb0 to 255.255.255.255 port 67 interval 7
DHCPDISCOVER on rausb0 to 255.255.255.255 port 67 interval 9
DHCPDISCOVER on rausb0 to 255.255.255.255 port 67 interval 21
DHCPDISCOVER on rausb0 to 255.255.255.255 port 67 interval 12
DHCPDISCOVER on rausb0 to 255.255.255.255 port 67 interval 12
No DHCPOFFERS received.
No working leases in persistent database - sleeping.
Internet Systems Consortium DHCP Client V3.0.3
Copyright 2004-2005 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/products/DHCP

Listening on LPF/eth0/00:80:5a:24:c1:35
Sending on LPF/eth0/00:80:5a:24:c1:35
Sending on Socket/fallback
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 4
DHCPOFFER from 192.168.2.1
DHCPREQUEST on eth0 to 255.255.255.255 port 67
DHCPACK from 192.168.2.1
bound to 192.168.2.102 -- renewal in 133651 seconds.
[ ok ]
giosetti@ubuntu:~$

Complementary data:

giosetti@ubuntu:~$ iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

sit0 no wireless extensions.

rausb0 RT2500USB WLAN ESSID:""
Mode:Managed Frequency=2.412 GHz Bit Rate=11 Mb/s
RTS thr:off Fragment thr:off
Link Quality=0/70 Signal level:-120 dBm Noise level:-216 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

giosetti@ubuntu:~$

giosetti@ubuntu:~$ iwlist scan
lo Interface doesn't support scanning.

eth0 Interface doesn't support scanning.

sit0 Interface doesn't support scanning.

rausb0 Scan completed :
Cell 01 - Address: 00:12:BF:9B:B1:A7
Mode:Managed
ESSID:"mywlanessid"
Encryption key:on
Channel:1





Any idea what my problem might be? Thanx.

bleearg
January 15th, 2007, 01:39 AM
...... Extra: Last beacon: 268ms ago
Is it you dont wish to mess with the router your ISP gave you or is it a shared router that a neighbor manages?

I have no qualms about editing the AP config myself, as it is mine. If you are saying I should edit the beacon interval, I'll go ahead and try that.

EDIT: I just realized that I think you are confusing my issue with another user, who didn't want to mess with his router's settings. However, I will check the beacon interval in the AP and see what it's set to.

wieman01
January 15th, 2007, 07:22 AM
ioctl[SIOCSIWENCODEEXT]: Operation not supported
That's no good sign. I suspect that you are using the Linux driver for your Linksys card (Ralink), is that correct? I don't think Serialmonkey's driver for Ralink chipsets support WPA like other cards do. At least that's what the error message is about. You either try to install "ndiswrapper" and get your card working by using the native Windows driver, or you check on their website for support:

http://rt2x00.serialmonkey.com/wiki/index.php?title=Main_Page

I have a Linksys card myself (WUSB54G) and never got it to work with WPA, only after removing the Linux driver and installing "ndiswrapper"...

EDIT:
What wireless adapter are you using? Besides please try WPA1 (only) first and let me know if the error message keeps occurring...

Gladier
January 15th, 2007, 10:05 AM
gladier@gladier-desktop:~$ uname -a
Linux gladier-desktop 2.6.17-10-generic #2 SMP Tue Dec 5 22:28:26 UTC 2006 i686 GNU/Linux
gladier@gladier-desktop:~$ ifconfig -a
eth0 Link encap:Ethernet HWaddr 00:16:17:E8:70:4D
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
Base address:0xbf00 Memory:fd8e0000-fd900000

eth1 Link encap:Ethernet HWaddr 00:16:17:E8:70:4E
inet addr:192.168.15.135 Bcast:192.168.15.255 Mask:255.255.255.0
inet6 addr: fe80::216:17ff:fee8:704e/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:1735 errors:0 dropped:0 overruns:0 frame:0
TX packets:1670 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:100
RX bytes:1300445 (1.2 MiB) TX bytes:260569 (254.4 KiB)
Base address:0xaf00 Memory:fdee0000-fdf00000

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:2 errors:0 dropped:0 overruns:0 frame:0
TX packets:2 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:100 (100.0 b) TX bytes:100 (100.0 b)

sit0 Link encap:IPv6-in-IPv4
NOARP MTU:1480 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

wlan0 Link encap:Ethernet HWaddr 00:16:E3:21:D0:CF
inet6 addr: fe80::216:e3ff:fe21:d0cf/64 Scope:Link
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:21 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:5082 (4.9 KiB)

gladier@gladier-desktop:~$ route -n
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
192.168.15.0 0.0.0.0 255.255.255.0 U 0 0 0 eth1
0.0.0.0 192.168.15.1 0.0.0.0 UG 0 0 0 eth1
gladier@gladier-desktop:~$ iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

eth1 no wireless extensions.

wlan0 IEEE 802.11g ESSID:off/any
Mode:Managed Frequency:2.412 GHz Access Point: Not-Associated
Bit Rate:54 Mb/s Tx-Power:25 dBm
RTS thr:2347 B Fragment thr:2346 B
Power Management:off
Link Quality:100/100 Signal level:-10 dBm Noise level:-96 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

sit0 no wireless extensions.

gladier@gladier-desktop:~$ ifconfig
eth0 Link encap:Ethernet HWaddr 00:16:17:E8:70:4D
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
Base address:0xbf00 Memory:fd8e0000-fd900000

eth1 Link encap:Ethernet HWaddr 00:16:17:E8:70:4E
inet addr:192.168.15.135 Bcast:192.168.15.255 Mask:255.255.255.0
inet6 addr: fe80::216:17ff:fee8:704e/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:1747 errors:0 dropped:0 overruns:0 frame:0
TX packets:1670 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:100
RX bytes:1301924 (1.2 MiB) TX bytes:260569 (254.4 KiB)
Base address:0xaf00 Memory:fdee0000-fdf00000

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:2 errors:0 dropped:0 overruns:0 frame:0
TX packets:2 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:100 (100.0 b) TX bytes:100 (100.0 b)

wlan0 Link encap:Ethernet HWaddr 00:16:E3:21:D0:CF
inet6 addr: fe80::216:e3ff:fe21:d0cf/64 Scope:Link
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:23 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:5766 (5.6 KiB)

gladier@gladier-desktop:~$ iwlist scan
lo Interface doesn't support scanning.

eth0 Interface doesn't support scanning.

eth1 Interface doesn't support scanning.

wlan0 Scan completed :
Cell 01 - Address: 00:0F:B5:3E:46:4A
ESSID:"VANHOUTEN"
Protocol:IEEE 802.11g
Mode:Managed
Frequency:2.462 GHz (Channel 11)
Quality:35/100 Signal level:-73 dBm Noise level:-96 dBm
Encryption key:off
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
24 Mb/s; 36 Mb/s; 54 Mb/s; 6 Mb/s; 9 Mb/s
12 Mb/s; 48 Mb/s
Extra:bcn_int=100
Extra:atim=0
Cell 02 - Address: 00:14:BF:EC:D0:E0
ESSID:"MuWaPa"
Protocol:IEEE 802.11g
Mode:Managed
Frequency:2.457 GHz (Channel 10)
Quality:46/100 Signal level:-66 dBm Noise level:-96 dBm
Encryption key:on
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
48 Mb/s; 54 Mb/s
Extra:bcn_int=100
Extra:atim=0
IE: WPA Version 1
Group Cipher : TKIP
Pairwise Ciphers (1) : TKIP
Authentication Suites (1) : PSK

sit0 Interface doesn't support scanning.

gladier@gladier-desktop:~$ cat /etc/network/interfaces
auto lo
iface lo inet loopback


iface eth0 inet dhcp

auto eth1
iface eth1 inet dhcp

auto eth2
iface eth2 inet dhcp

auto ath0
iface ath0 inet dhcp

auto wlan0
iface wlan0 inet dhcp
wpa-driver wext
wpa-conf managed
wpa-ssid MuWaPa
wpa-ap-scan 2
wpa-proto RSN
wpa-pairwise CCMP
wpa-group CCMP
wpa-key-mgmt WPA-PSK
wpa-psk 8271c094cb6412345asfg97bfb0d45054asdfa231175d8 [changed for posting]

auto eth0
gladier@gladier-desktop:~$ cat /etc/modprobe.d/ndiswrapper
install usb:v0B05p1717d*dc*dsc*dp*ic*isc*ip* /sbin/modprobe ndiswrapper
gladier@gladier-desktop:~$ cat /etc/resolv.conf
search ctrl-esc.local
nameserver 192.168.15.254
nameserver 192.168.15.1


hopefully thats enough...

i can see my network(MuWaPa) - however i cant connect to it. running hidden SSID WPA no mac filtering etc.

and i know my local connection is still plugged in - but that shouldnt make a difference.

Regards,
Gladier

wieman01
January 15th, 2007, 10:21 AM
If your Ethernet cable is plugged in, you won't be able to connect to your wireless network. It does make a difference.

Second, "iwlist scan" says that your network is using TKIP which happens to be WPA1 (ESSID:"MuWaPa"):

IE: WPA Version 1
Group Cipher : TKIP
Pairwise Ciphers (1) : TKIP
Authentication Suites (1) : PSK
Either change to WPA2 or use the sample script for WPA1 instead:

auto wlan0
iface wlan0 inet dhcp
wpa-driver wext
wpa-conf managed
wpa-ssid MuWaPa
wpa-ap-scan 2
wpa-proto WPA
wpa-pairwise TKIP
wpa-group TKIP
wpa-key-mgmt WPA-PSK
wpa-psk 8271c094cb6412345asfg97bfb0d45054asdfa231175d8 [changed for posting]

t_anjan
January 15th, 2007, 01:31 PM
I've followed the HOW-TO exactly.
I've got a Netgear WG111v2 USB dongle that I have installed using NDISWRAPPER.

'iwlist scan' shows me the available network:


anjan@supernal:~$ iwlist wlan0 scan
wlan0 Scan completed :
Cell 01 - Address: 00:14:6C:F0:03:06
ESSID:"AnjanWireless"
Protocol:IEEE 802.11bg
Mode:Master
Channel:11
Encryption key:on
Bit Rates:54 Mb/s
Extra: Rates (Mb/s): 1 2 5.5 6 9 11 12 18 22 24 36 48 54
Quality:17 Signal level:0 Noise level:2
Extra: Last beacon: 0ms ago

Output of 'iwconfig'

anjan@supernal:~$ iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

wlan0 802.11b/g link.. ESSID:"AnjanWireless"
Mode:Managed Channel=11 Access Point: Not-Associated
Bit Rate=11 Mb/s
Retry:on Fragment thr:off
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

sit0 no wireless extensions.

Contents of my 'interfaces' file:


auto lo
iface lo inet loopback

auto eth0
iface eth0 inet dhcp

auto eth1
iface eth1 inet dhcp

auto eth2
iface eth2 inet dhcp

auto ath0
iface ath0 inet dhcp

auto wlan0
iface wlan0 inet dhcp
wireless-essid AnjanWireless
wpa-driver wext
wpa-conf master
wpa-ssid AnjanWireless
wpa-ap-scan 1
wpa-proto WPA
wpa-pairwise TKIP
wpa-group TKIP
wpa-key-mgmt WPA-PSK
wpa-psk <hidden>


First, before reading this How-To, I had my 'interfaces' file without all the wpa config commands. Instead I had these two lines:


pre-up wpa_supplicant -Bw -Dwext -ieth0 -c/etc/wpa_supplicant.conf
post-down killall -q wpa_supplicant

Contents of my 'wpa_supplicant.conf' file:


# Minimal /etc/wpa_supplicant.conf to associate with open
# access points. Please see
# /usr/share/doc/wpasupplicant/wpa_supplicant.conf.gz for more complete
# configuration parameters.

ctrl_interface=/var/run/wpa_supplicant
ctrl_interface_group=0

eapol_version=1
ap_scan=2
fast_reauth=1

network={
ssid="AnjanWireless"
scan_ssid=1
key_mgmt=WPA-PSK
proto=WPA
#pairwise=CCMP TKIP
#group=CCMP TKIP
#psk="<hidden>"
psk=<hidden>
}

Everything seems OK to me. But I just cannot hook up to my wireless router, even after disabling my wired connection (eth0) and disconnecting my ethernet cable.

Please, I've spent three days on this now and Ubuntu is really starting to frustrate me. Someone help!

wieman01
January 15th, 2007, 02:27 PM
t_anjan:

What are your router's security settings? It looks to me as if it is set to WEP. Could you check? If it is set to WPA, is it WPA with TKIP (WPA1) or AES (WPA2)? Is broadcasting of ESSID enabled or hidden?

t_anjan
January 15th, 2007, 02:36 PM
t_anjan:

What are your router's security settings? It looks to me as if it is set to WEP. Could you check? If it is set to WPA, is it WPA with TKIP (WPA1) or AES (WPA2)? Is broadcasting of ESSID enabled or hidden?

No, my router is set to WPA-PSK, with TKIP. I know this is correct, because I connect to the same router from my windows laptop. SSID broadcasting is ON.

wieman01
January 15th, 2007, 02:52 PM
No, my router is set to WPA-PSK, with TKIP. I know this is correct, because I connect to the same router from my windows laptop. SSID broadcasting is ON.
Have you got Firestarter, NetworkManager, or Wifi-Radar running? If so, uninstall them for the time being... Please also post the output when you restart the network:


sudo ifdown -v wlan0

sudo ifup -v wlan0

t_anjan
January 15th, 2007, 08:46 PM
I don't have any of Firestarter, Network Manager or WiFi-Radar installed.

The output of sudo ifdown -v wlan0


Configuring interface wlan0=wlan0 (inet)
run-parts --verbose /etc/network/if-down.d
run-parts: executing /etc/network/if-down.d/wpasupplicant
dhclient3 -r -pf /var/run/dhclient.wlan0.pid -lf /var/lib/dhcp3/dhclient.wlan0.leases wlan0
There is already a pid file /var/run/dhclient.wlan0.pid with pid 5068
killed old client process, removed PID file
Internet Systems Consortium DHCP Client V3.0.4
Copyright 2004-2006 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

Listening on LPF/wlan0/00:18:4d:08:c7:0e
Sending on LPF/wlan0/00:18:4d:08:c7:0e
Sending on Socket/fallback
ifconfig wlan0 down
run-parts --verbose /etc/network/if-post-down.d
run-parts: executing /etc/network/if-post-down.d/wireless-tools
run-parts: executing /etc/network/if-post-down.d/wpasupplicant
wpa_supplicant: terminating wpa_supplicant daemon via pidfile /var/run/wpa_supplicant.wlan0.pid
Stopped /sbin/wpa_supplicant (pid 3738).

The output of sudo ifup -v wlan0


Configuring interface wlan0=wlan0 (inet)
run-parts --verbose /etc/network/if-pre-up.d
run-parts: executing /etc/network/if-pre-up.d/wireless-tools
run-parts: executing /etc/network/if-pre-up.d/wpasupplicant
wpa_supplicant: wpa-driver wext
wpa_supplicant: /sbin/wpa_supplicant -B -P /var/run/wpa_supplicant.wlan0.pid -i wlan0 -D wext -C /var/run/wpa_supplicant
Starting /sbin/wpa_supplicant...


ioctl[SIOCSIWAUTH]: Operation not supported
WEXT auth param 7 value 0x1 - ioctl[SIOCSIWENCODEEXT]: Operation not supported
ioctl[SIOCSIWENCODEEXT]: Operation not supported
ioctl[SIOCSIWENCODEEXT]: Operation not supported
ioctl[SIOCSIWENCODEEXT]: Operation not supported
ioctl[SIOCSIWAUTH]: Operation not supported
WEXT auth param 4 value 0x0 - ioctl[SIOCSIWAUTH]: Operation not supported
WEXT auth param 5 value 0x1 - wpa_supplicant: ctrl_interface socket located at /var/run/wpa_supplicant/wlan0
wpa_supplicant: wpa-ap-scan 1 -- OK
wpa_supplicant: configuring network block -- 0
wpa_supplicant: wpa-ssid "AnjanWireless" -- OK
wpa_supplicant: wpa-psk ***** -- OK
wpa_supplicant: wpa-pairwise TKIP -- OK
wpa_supplicant: wpa-group TKIP -- OK
wpa_supplicant: wpa-key-mgmt WPA-PSK -- OK
wpa_supplicant: wpa-proto WPA -- OK
wpa_supplicant: enabling network block 0 -- OK

dhclient3 -pf /var/run/dhclient.wlan0.pid -lf /var/lib/dhcp3/dhclient.wlan0.leases wlan0
There is already a pid file /var/run/dhclient.wlan0.pid with pid 5798864
Internet Systems Consortium DHCP Client V3.0.4
Copyright 2004-2006 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

Listening on LPF/wlan0/00:18:4d:08:c7:0e
Sending on LPF/wlan0/00:18:4d:08:c7:0e
Sending on Socket/fallback
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 4
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 4
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 4
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 8
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 8
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 11
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 10
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 10
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 2
No DHCPOFFERS received.
No working leases in persistent database - sleeping.
run-parts --verbose /etc/network/if-up.d
run-parts: executing /etc/network/if-up.d/mountnfs
run-parts: executing /etc/network/if-up.d/ntp-server
run-parts: executing /etc/network/if-up.d/ntpdate
Synchronizing clock to ntp.ubuntu.com...

Thanks for taking the time to help out.

giosetti
January 15th, 2007, 09:46 PM
That's no good sign. I suspect that you are using the Linux driver for your Linksys card (Ralink), is that correct?

Yes, it is the driver that comes out of the box.


What wireless adapter are you using?

It is the ASUS WL-167g.


I don't think Serialmonkey's driver for Ralink chipsets support WPA like other cards do.

But that's what they say - for WPA2 at least: http://rt2x00.serialmonkey.com/phpBB2/viewtopic.php?t=1822&highlight=wpa2


Besides please try WPA1 (only) first and let me know if the error message keeps occurring...

It does:


giosetti@ubuntu:/etc/network$ sudo /etc/init.d/networking restart
Listening on LPF/eth0/00:80:5a:24:c1:35
Sending on LPF/eth0/00:80:5a:24:c1:35
Sending on Socket/fallback
DHCPRELEASE on eth0 to 192.168.2.1 port 67
ioctl[SIOCSIWPMKSA]: Network is down
ioctl[SIOCSIWAUTH]: Operation not supported
WEXT auth param 7 value 0x1 - ioctl[SIOCSIWENCODEEXT]: Operation not supported
ioctl[SIOCSIWENCODEEXT]: Operation not supported
ioctl[SIOCSIWENCODEEXT]: Operation not supported
ioctl[SIOCSIWENCODEEXT]: Operation not supported
ioctl[SIOCSIWAUTH]: Operation not supported
WEXT auth param 4 value 0x0 - ioctl[SIOCSIWAUTH]: Operation not supported
WEXT auth param 5 value 0x1 - Internet Systems Consortium DHCP Client V3.0.3
Copyright 2004-2005 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/products/DHCP

Listening on LPF/rausb0/00:13:d4:09:29:9c
Sending on LPF/rausb0/00:13:d4:09:29:9c
Sending on Socket/fallback
DHCPDISCOVER on rausb0 to 255.255.255.255 port 67 interval 8
DHCPDISCOVER on rausb0 to 255.255.255.255 port 67 interval 7
DHCPDISCOVER on rausb0 to 255.255.255.255 port 67 interval 14
DHCPDISCOVER on rausb0 to 255.255.255.255 port 67 interval 15
DHCPDISCOVER on rausb0 to 255.255.255.255 port 67 interval 17
No DHCPOFFERS received.



Here the /etc/network/interfaces:


# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface

auto rausb0
iface rausb0 inet dhcp
wpa-driver wext
wpa-conf managed
wpa-ssid WLAN-9BB139
wpa-ap-scan 1
wpa-proto WPA
wpa-pairwise TKIP
wpa-group TKIP
wpa-key-mgmt WPA-PSK
wpa-psk SP-3091A7330


iface eth0 inet dhcp


Should I try any other WPA driver such as hostap? Or should I try to run ndiswrapper straight away? I need to see how that works. Do I need a certain windows driver in that case? And how do eliminate the linux driver? There are how-tos I guess, I'll look around. Is there BTW any conflict with the applications|system|networking menue?

Thx.

giosetti
January 15th, 2007, 10:38 PM
You either try to install "ndiswrapper"

I was just reading the avialable ndiswrapper howtos, went to the Asus site to retrieve a suitable driver, when I realized that they indicated "USB2.0 adapter".

But AFAIK the Dell Latitude CPi operates USB1.0:



giosetti@ubuntu:~$ lspci
0000:00:00.0 Host bridge: Intel Corporation 440BX/ZX/DX - 82443BX/ZX/DX Host bridge (rev 03)
0000:00:01.0 PCI bridge: Intel Corporation 440BX/ZX/DX - 82443BX/ZX/DX AGP bridge (rev 03)
0000:00:03.0 CardBus bridge: Texas Instruments PCI1225 (rev 01)
0000:00:03.1 CardBus bridge: Texas Instruments PCI1225 (rev 01)
0000:00:07.0 Bridge: Intel Corporation 82371AB/EB/MB PIIX4 ISA (rev 02)
0000:00:07.1 IDE interface: Intel Corporation 82371AB/EB/MB PIIX4 IDE (rev 01)
0000:00:07.2 USB Controller: Intel Corporation 82371AB/EB/MB PIIX4 USB (rev 01)
0000:00:07.3 Bridge: Intel Corporation 82371AB/EB/MB PIIX4 ACPI (rev 02)
0000:01:00.0 VGA compatible controller: Neomagic Corporation NM2200 [MagicGraph 256AV] (rev 12)
0000:01:00.1 Multimedia audio controller: Neomagic Corporation NM2200 [MagicMedia 256AV Audio] (rev 12)
0000:02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)

However iwconfig gives the RA2500:


giosetti@ubuntu:~$ iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

sit0 no wireless extensions.

rausb0 RT2500USB WLAN ESSID:""
Mode:Managed Frequency=2.412 GHz Bit Rate=11 Mb/s
RTS thr:off Fragment thr:off
Link Quality=0/70 Signal level:-120 dBm Noise level:-202 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

Now - is this a/the problem? And what could be done? Better buy a PCMCIA card (which would be more useful anyway, because I need the (only) USB slot for saving files (the notebook has no CDWR). And which one could that be?

wieman01
January 15th, 2007, 11:05 PM
First of all, the error message suggests that the driver does not support WPA the way we are trying to set it up. That's definitely a no-go. I suggest that you either check out their website for suitable support or give "ndiswrapper" a go. This is a good start:

https://help.ubuntu.com/community/WifiDocs/Driver/Ndiswrapper

Before you do so, you could also try other wpa-drivers, however, I believe "wext" is the right one.

t_anjan
January 15th, 2007, 11:22 PM
First of all, the error message suggests that the driver does not support WPA the way we are trying to set it up. That's definitely a no-go. I suggest that you either check out their website for suitable support or give "ndiswrapper" a go. This is a good start:

https://help.ubuntu.com/community/WifiDocs/Driver/Ndiswrapper

Before you do so, you could also try other wpa-drivers, however, I believe "wext" is the right one.

If this message was directed at me, I'm already using ndiswrapper. Any other suggestions?

giosetti
January 16th, 2007, 12:10 AM
First of all, the error message suggests that the driver does not support WPA the way we are trying to set it up. That's definitely a no-go. I suggest that you either check out their website for suitable support or give "ndiswrapper" a go. This is a good start:

https://help.ubuntu.com/community/WifiDocs/Driver/Ndiswrapper



Does my Dell notebook supporting USB1.0 where the Asus WL-167G is based on USB2.0 affect the whole process substantially?

As I wrote previously lspci doesn't identify the USB dongle. On the other hand iwconfig comes up with indication "RT2005".

So does it makes sense to go this way?

wieman01
January 16th, 2007, 08:34 AM
If this message was directed at me, I'm already using ndiswrapper. Any other suggestions?
So you can connect to unsecured networks? Have you tried the latest version of the driver for your card? Perhaps the current one does not support WPA. wpa-driver "wext" is definitely the right one if you are using "ndiswrapper".

EDIT:
Hang on, there is a problem with your script:

auto wlan0
iface wlan0 inet dhcp
wpa-ssid AnjanWireless
wpa-driver wext
wpa-conf master
wpa-ssid AnjanWireless
wpa-ap-scan 1
wpa-proto WPA
wpa-pairwise TKIP
wpa-group TKIP
wpa-key-mgmt WPA-PSK
wpa-psk <hidden>
Your script says "wireless-essid" which is incorrect if you use WPA.

wieman01
January 16th, 2007, 08:40 AM
Does my Dell notebook supporting USB1.0 where the Asus WL-167G is based on USB2.0 affect the whole process substantially?

As I wrote previously lspci doesn't identify the USB dongle. On the other hand iwconfig comes up with indication "RT2005".

So does it makes sense to go this way?
Let's put the question this way: Can you or can you not connect to unsecured networks using your dongle?

t_anjan
January 16th, 2007, 01:00 PM
So you can connect to unsecured networks? Have you tried the latest version of the driver for your card? Perhaps the current one does not support WPA. wpa-driver "wext" is definitely the right one if you are using "ndiswrapper".

I'm using AMD64 version of Edgy and have used the 64 bit RT8187 driver (available on the Realtek Site) in ndiswrapper. I'm using the same driver on Win x64 where WPA works. So the driver definitely supports WPA. But WPA is not the problem here. I can't connect to even unsecure networks.



EDIT:
Hang on, there is a problem with your script:

Your script says "wireless-essid" which is incorrect if you use WPA.

I actually have the "wpa-ssid" command 3 lines below. The "wireless-essid" command is added by the "System->Administration->Networking" automatically. I removed the line manually. But it doesn't make a difference.

Catsworth
January 16th, 2007, 02:09 PM
I don't know what to say other than:

"Thank You So Very Much!"

I followed your steps through one at a time, restarted the network and held my breath. Everything connected first time and I'm now wireless with WPA enabled.

I really cannot thank you enough for posting this.

t_anjan
January 16th, 2007, 02:12 PM
So you can connect to unsecured networks?

To heck with WPA. I've temporarily disabled all security on my router. I want Edgy to connect to my unsecured router.

My "interfaces" file:

auto lo
iface lo inet loopback

#auto eth0
#iface eth0 inet dhcp

#auto eth1
#iface eth1 inet dhcp

#auto eth2
#iface eth2 inet dhcp

#auto ath0
#iface ath0 inet dhcp

auto wlan0
iface wlan0 inet dhcp
wireless-essid AnjanWireless
wireless-channel 2
wireless-mode managed

Output of sudo /etc/init.d/networking restart


anjan@supernal:~$ sudo /etc/init.d/networking restart
* Reconfiguring network interfaces... There is already a pid file /var/run/dhclient.wlan0.pid with pid 8963
killed old client process, removed PID file
Internet Systems Consortium DHCP Client V3.0.4
Copyright 2004-2006 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

Listening on LPF/wlan0/00:18:4d:08:c7:0e
Sending on LPF/wlan0/00:18:4d:08:c7:0e
Sending on Socket/fallback
Error for wireless request "Set Frequency" (8B04) :
SET failed on device wlan0 ; Operation not supported.
There is already a pid file /var/run/dhclient.wlan0.pid with pid 5798864
Internet Systems Consortium DHCP Client V3.0.4
Copyright 2004-2006 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

Listening on LPF/wlan0/00:18:4d:08:c7:0e
Sending on LPF/wlan0/00:18:4d:08:c7:0e
Sending on Socket/fallback
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 4
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 11
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 13
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 9
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 10
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 14
No DHCPOFFERS received.
No working leases in persistent database - sleeping.

I think these two lines are the most important:

Error for wireless request "Set Frequency" (8B04) :
SET failed on device wlan0 ; Operation not supported.

I have no idea why SET is not working. Any ideas? I can't even connect to an unsecured network!!!

wieman01
January 16th, 2007, 02:49 PM
I think these two lines are the most important:

Error for wireless request "Set Frequency" (8B04) :
SET failed on device wlan0 ; Operation not supported.

I have no idea why SET is not working. Any ideas? I can't even connect to an unsecured network!!!
I cannot tell for sure what's going on but perhaps open another thread for your problem as it seems to relate to your driver rather than WPA security.

Just a last thought: Check that both router and wireless adapter are running on either wireless B or G. Put them in sync.

Catsworth
January 16th, 2007, 05:50 PM
I don't know what to say other than:

"Thank You So Very Much!"

I followed your steps through one at a time, restarted the network and held my breath. Everything connected first time and I'm now wireless with WPA enabled.

I really cannot thank you enough for posting this.

With just one minor problem.....

I have to open a terminal and type:


/etc/init.d/networking restart

every time I start Ubuntu, otherwise my wireless connection doesn't work. Anybody got any ideas why this might be?

Thanks.

wieman01
January 16th, 2007, 05:51 PM
With just one minor problem.....

I have to open a terminal and type:


/etc/init.d/networking restart

every time I start Ubuntu, otherwise my wireless connection doesn't work. Anybody got any ideas why this might be?

Thanks.
I was expecting that. :-) Please read post #2 of this thread. It's a bug so you have to restart the network while the computer is booting.

Catsworth
January 16th, 2007, 06:31 PM
I was expecting that. :-) Please read post #2 of this thread. It's a bug so you have to restart the network while the computer is booting.

Tee Hee :)

That'll teach me to read a bit further next time even if I think everything's working fine :)

Thanks, I'll reboot now and see how it goes.....

Catsworth
January 16th, 2007, 07:09 PM
Ok, that didn't work - I still had to restart the network after I'd logged in.

Any ideas why that might be?

There was a note in post 2 regarding possibly having to change the S40 value.....could that be it?

I've seen that other people are having this problem but the solutions posted didn't make any sense, and I'm having a brain-hurting time as it is without making matters worse. Could you let me know which of the many posts concerning this has the right instructions to follow?

Thanks.

wieman01
January 16th, 2007, 07:16 PM
Ok, that didn't work - I still had to restart the network after I'd logged in.

Any ideas why that might be?

There was a note in post 2 regarding possibly having to change the S40 value.....could that be it?

I've seen that other people are having this problem but the solutions posted didn't make any sense, and I'm having a brain-hurting time as it is without making matters worse. Could you let me know which of the many posts concerning this has the right instructions to follow?
I am afraid I don't know any other solution... Changing the S40 value may be worth a try but I doubt this will solve your problem. Sorry I cannot be of any help here. But a solution would be appreciate if you came across one.

palomuuri
January 16th, 2007, 07:32 PM
Maybe my eyes are blurring, but the instructions on how to use wpa_passphrase show an example where the hexadecimal output appears to be two strings. I get a single string:

$ wpa_passphrase '<my ESSID>' '<my passphrase>'
network={
ssid="my ESSID"
#psk="my password"
psk=47965933a8937a4a9443bb0ff6e04d7b06ad10731d361c ddbf9f92bf97e30e21
}

The example at the beginning of this thread shows
psk=fe727aa8b64ac9b3f54c72432da14faed933ea511ecab1 5bbc6c52e7522f709a

Which is correct? I tend to believe the output of wpa_passphrase.

Best regards,

Catsworth
January 16th, 2007, 07:50 PM
Sorry I cannot be of any help here. But a solution would be appreciate if you came across one.

I think it's something to do with getting the network to restart automatically at boot, which your post #2 was trying to do, for some reason it just doesn't work on my machine and I have to do it manually:(

Catsworth
January 16th, 2007, 07:55 PM
Ok, in your post #2 you wrote:


sudo ln -s /etc/init.d/wireless-network.sh /etc/rcS.d/S40wireless-network

I think I *might* have put rc5 instead of rcS (a five instead of the required 'S'". Is there anyway that I can check this, or better still just delete the symbolic link so that I can redo it?

Thanks.

Pollywoggy
January 16th, 2007, 08:32 PM
I used the info in this thread to set up my router for WPA, which I had already done, but now I have a static IP address. My router software, DD-WRT, can only use TKIP and AES and I have a question.

Are all WPA2 variants capable of ESSID; of hiding the SSID?


Until I read the info here, I had not set up my router to map MAC addresses to static IP addresses, I had to play with this since I had not done it before, but it works now.
My router does WPA2 but only with AES and/or TKIP.

Pollywoggy
January 16th, 2007, 08:35 PM
Initially I had voted that this thread was "somewhat helpful" but if I could change my vote I would say that it has been very helpful.

wieman01
January 16th, 2007, 09:39 PM
Ok, in your post #2 you wrote:


sudo ln -s /etc/init.d/wireless-network.sh /etc/rcS.d/S40wireless-network

I think I *might* have put rc5 instead of rcS (a five instead of the required 'S'". Is there anyway that I can check this, or better still just delete the symbolic link so that I can redo it?

Thanks.
Yes, you can check by typing this:

ls -l /etc/rc5.d/S40wireless-network
If this command returns your link, then you have previously created it. Nonetheless, it does not harm redoing it & creating the right symblink.

wieman01
January 16th, 2007, 09:42 PM
Are all WPA2 variants capable of ESSID; of hiding the SSID?
Basically yes. "wpa-ap-scan" controls this part of your security settings. Check it out if you have not done so already.

katu
January 17th, 2007, 09:42 PM
ok. I made a large post here:
problems with WPa... (http://http://ubuntuforums.org/showthread.php?t=340552)

but was directed here. Now my interfaces looks like this:

auto lo
iface lo inet loopback
address 127.0.0.1
netmask 255.0.0.0

#auto eth0
#iface eth0 inet static
#address 172.16.11.87
#netmask 255.255.0.0
#gateway 172.16.1.1

auto eth1
iface eth1 inet dhcp

wpa-driver wext
wpa-conf managed
wpa-ssid WAiRPort
wpa-ap-scan 2
wpa-proto RSN
wpa-pairwise CCMP
wpa-group CCMP
wpa-key-mgmt WPA-PSK
wpa-psk 256db0e3d42e7d5e879d933bcc91cee41c275be013c47dc75a aaacac287f36c3



and I tried running /etc/init.d networking restart
and the firs time I actually got an IP, but the net didn't go through. So I tried to shut down eth0 (which I had not yet done at the time), made a mistake and shutdown eth1 instead :(.
Any subsequent attempts to try run it didn't work. I also tried restarting the comp, with the above interfaces file. The result is:

* Deconfiguring network interfaces... Internet Systems Consortium DHCP Client V3.0.4
Copyright 2004-2006 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

Listening on LPF/eth1/00:90:4b:9a:0e:d6
Sending on LPF/eth1/00:90:4b:9a:0e:d6
Sending on Socket/fallback
DHCPRELEASE on eth1 to 10.0.1.1 port 67
send_packet: Network is unreachable
send_packet: please consult README file regarding broadcast address.
[ ok ]
root@warpik:/home/andrzej# /etc/init.d/networking start
* Configuring network interfaces... There is already a pid file /var/run/dhclient.eth1.pid with pid 5798864
Internet Systems Consortium DHCP Client V3.0.4
Copyright 2004-2006 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

Listening on LPF/eth1/00:90:4b:9a:0e:d6
Sending on LPF/eth1/00:90:4b:9a:0e:d6
Sending on Socket/fallback
DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 4
DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 8
DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 8
DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 11
DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 21
DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 7
DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 2
No DHCPOFFERS received.
No working leases in persistent database - sleeping.



the highlight is mine. The address it sees is right. Of what I know the router gives adresses like 10.0.1.1 .
I think the send_packet thing may be a problem, but I don't know. I also tried moving the file mentioned
/var/run/dhclient.eth1.pid to a different location - no difference and I think the number stays the same as well... ;/

wieman01
January 17th, 2007, 09:55 PM
wpa-ap-scan 2
Is the ESSID hidden? If not, this line needs to be:

wpa-ap-scan 1
Can you connect to unsecured networks? Please do a...

iwlist scan
... while you are near the network in questions & post the results.

Please try this script as well:

auto eth1
iface eth1 inet dhcp
wpa-driver wext
wpa-conf managed
wpa-ssid WAiRPort
wpa-ap-scan 1
wpa-proto RSN WPA
wpa-pairwise CCMP TKIP
wpa-group CCMP TKIP
wpa-key-mgmt WPA-PSK
wpa-psk 256db0e3d42e7d5e879d933bcc91cee41c275be013c47dc75a aaacac287f36c3
That should do!

giosetti
January 17th, 2007, 10:50 PM
Let's put the question this way: Can you or can you not connect to unsecured networks using your dongle?

It seems I cannot. I have deactivated encryption, booted the notebook, checked system|networking where the interface rausb0 is identified. When I try to activate it, the computer freezes.

So I quit system|networking and sudo /etc/init.d/networking restart and again the computer freezes at:



*Reconfiguring network interfaces...

Listening on LPF/rausb0/00:13:d4:09:29:9c
Sending on LPF/rausb0/00:13:d4:09:29:9c
Sending on Socket/Fallback
DHCPRELEASE on rausb to 192.168.2.1 port 67
Internet Systems Consortium Client V3.0.3

Listening on LPF/rausb0/00:13:d4:09:29:9c
Sending on LPF/rausb0/00:13:d4:09:29:9c
Sending on Socket/Fallback


What bothers me is that I don't know if it is ok that system|networking is running. I thought I've read it should not be running, but I may have messed that with Network-manager, which is not installed on that computer.

The other thing that I find strange is that the computer often freezes while booting. At some point I booted with the options "acpi=off" with no problems, at another point "noapm" did the trick. Now it seems that the computer freezes while booting when the dongle is attached while the machine boots correctly when the dongle is not attached. I'm not sure if I can nail things down like this because I lack the time to reboot systematically to exactly find the problem, but the dongle seems to cause the trouble. A memory stick BTW causes no problems.

So I'd rather think there is a hardware problem at hand.

katu
January 18th, 2007, 10:38 AM
Is the ESSID hidden? If not, this line needs to be:

Can you connect to unsecured networks? Please do a...

... while you are near the network in questions & post the results.

Please try this script as well:

That should do!

I hate to say this, but it didn't work ;/.

I used ap-scan 2, because the admin hid the essid again. I tried also with wpa-ap-scan 1, but the result is pretty much the same:


* Reconfiguring network interfaces...
There is already a pid file /var/run/dhclient.eth1.pid with pid 4966
killed old client process, removed PID file
Internet Systems Consortium DHCP Client V3.0.4
Copyright 2004-2006 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

Listening on LPF/eth1/00:90:4b:9a:0e:d6
Sending on LPF/eth1/00:90:4b:9a:0e:d6
Sending on Socket/fallback
DHCPRELEASE on eth1 to 10.0.1.1 port 67
There is already a pid file /var/run/dhclient.eth1.pid with pid 5798864
Internet Systems Consortium DHCP Client V3.0.4
Copyright 2004-2006 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

Listening on LPF/eth1/00:90:4b:9a:0e:d6
Sending on LPF/eth1/00:90:4b:9a:0e:d6
Sending on Socket/fallback
DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 5
DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 8
DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 17
DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 19
DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 9
DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 3
No DHCPOFFERS received.
No working leases in persistent database - sleeping.


I hihglihted the 2 pid lines again. the firs one seem right, as far as the number. the second one is crazy though. And the same as yesterday...

also iwlist scan gives:



lo Interface doesn't support scanning.

eth1 No scan results
eth0 Interface doesn't support scanning.

sit0 Interface doesn't support scanning.




But as I mentioned earlier, I was able to connect to unsecured networkss with this card. So I think it's either something wrong with what I'm doing here with the WPA or something weird with the wireless hub (apple).

Cheers and I really appreciate the help,

wieman01
January 18th, 2007, 11:01 AM
But as I mentioned earlier, I was able to connect to unsecured networkss with this card. So I think it's either something wrong with what I'm doing here with the WPA or something weird with the wireless hub (apple).

Cheers and I really appreciate the help,
Question: Have you got any other wireless tool e.g. network-manager, wifi-radar installed? It looks to me as if something is interfering. If so, please uninstall them.

PLUS: Make sure the Ethernet cable is pulled while you are trying to connect through wireless.

katu
January 18th, 2007, 11:41 AM
I don't have wi-fi radar and I shut down knetworkmanager as specified in the howto. a couple of searches with ps aux revelaed that there was indeed a NetworkManager and NetworkManagerDispatcher running. I killed those and apparently the connection is still not there, but the error messages are different:


* Reconfiguring network interfaces... Ignoring unknown interface eth0=eth0.
wpa_supplicant: unknown or stale ctrl_interface socket located at /var/run/wpa_supplicant/eth1...aborting!
run-parts: /etc/network/if-pre-up.d/wpasupplicant exited with return code 1
There is already a pid file /var/run/dhclient.eth1.pid with pid 5798864
Internet Systems Consortium DHCP Client V3.0.4
Copyright 2004-2006 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

Listening on LPF/eth1/00:90:4b:9a:0e:d6
Sending on LPF/eth1/00:90:4b:9a:0e:d6
Sending on Socket/fallback
DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 8
DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 13
DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 15
DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 12
DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 13
No DHCPOFFERS received.
No working leases in persistent database - sleeping.


maybe the highilighted part will shed some light on the subject?
Once again thanks a lot for all your time.

wieman01
January 18th, 2007, 01:10 PM
Katu:

Could you post your entire "/etc/network/interfaces" once again, please, and also do a "iwlist scan" and post the results?

Uninstalling "network-manager" would be best... And is DHCP enabled?

Mujaheiden
January 18th, 2007, 01:27 PM
Hi, concerning your 2nd post - anyway, thanks for this extremely useful post :KS - now if I startup, It gives some lines saying

DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 2
but before it already stated that it obtained a lease or smt for a lot of seconds. So then I just press CTRL-C. Should I wait a bit more, or is something stil misconfigured?

And another question, how abour roaming? If this laptop is going to go places, is it only able to work with the current setup, or, well, how does it go, if I cant use eg. wifi radar?

wieman01
January 18th, 2007, 01:45 PM
Hi, concerning your 2nd post - anyway, thanks for this extremely useful post :KS - now if I startup, It gives some lines saying

but before it already stated that it obtained a lease or smt for a lot of seconds. So then I just press CTRL-C. Should I wait a bit more, or is something stil misconfigured?

And another question, how abour roaming? If this laptop is going to go places, is it only able to work with the current setup, or, well, how does it go, if I cant use eg. wifi radar?
Perhaps you don't require the solution described in post #2. Please try without it. If your computer is online after rebooting, you don't need to do a restart at all. Simply ignore post #2 in that case.

As for roaming, no, that's not possible. You would have to use tools like wifi-radar or network-manager instead. Unless you want to mess around with text files/command line all the time (which I prefer).

katu
January 18th, 2007, 02:17 PM
Katu:

Could you post your entire "/etc/network/interfaces" once again, please, and also do a "iwlist scan" and post the results?

Uninstalling "network-manager" would be best... And is DHCP enabled?

Yeah, dhcp is enabled. Or at least the client is there, that is what's trying to get the lease, if I understood your question right.

ok. interfaces in all it's glory:


auto lo
iface lo inet loopback
address 127.0.0.1
netmask 255.0.0.0

#auto eth0
#iface eth0 inet static
#address 172.16.11.87
#netmask 255.255.0.0
#gateway 172.16.1.1

auto eth1
iface eth1 inet dhcp

wpa-driver wext
wpa-conf managed
wpa-ssid WAiRPort
wpa-ap-scan 1
wpa-proto RSN WPA
wpa-pairwise CCMP TKIP
wpa-group CCMP TKIP
wpa-key-mgmt WPA-PSK
wpa-psk 256db0e3d42e7d5e879d933bcc91cee41c275be013c47dc75a aaacac287f36c3

iwlist scan is a bit funny. firs when I tried it it gave:


lo Interface doesn't support scanning.

eth0 Interface doesn't support scanning.

eth1 No scan results
sit0 Interface doesn't support scanning.

I got the admin to broadcast the essid and then I got:



eth1 Scan completed :
Cell 01 - Address: 00:0D:88:8C:89:62
ESSID:"daqborex"
Protocol:IEEE 802.11bg
Mode:Master
Channel:6
Encryption key:off
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 6 Mb/s; 9 Mb/s
11 Mb/s; 12 Mb/s; 18 Mb/s; 22 Mb/s; 24 Mb/s
36 Mb/s; 48 Mb/s; 54 Mb/s
Quality=100/100 Signal level=-74 dBm
Extra: Last beacon: 344ms ago
Cell 02 - Address: 00:0A:95:F5:69:37
ESSID:"WAiRPort"
Protocol:IEEE 802.11bg
Mode:Master
Channel:13
Encryption key:on
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 6 Mb/s; 9 Mb/s
11 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
48 Mb/s; 54 Mb/s
Quality=100/100 Signal level=-46 dBm
IE: WPA Version 1
Group Cipher : TKIP
Pairwise Ciphers (1) : TKIP
Authentication Suites (1) : PSK
IE: IEEE 802.11i/WPA2 Version 1
Group Cipher : TKIP
Pairwise Ciphers (2) : CCMP TKIP
Authentication Suites (1) : PSK
Extra: Last beacon: 52ms ago



the crazy part is that the first network daqborex is not ours, but didn;t show up before... Anyway I tried reconnecting (changed wpa-ap-scan to 1) and it still didn;t connect, but the end of dmesg is pretty interesting:



10232.731916] ADDRCONF(NETDEV_UP): eth1: link is not ready
[10413.238194] SoftMAC: Open Authentication completed with 00:0a:95:f5:69:37
[10413.248929] ADDRCONF(NETDEV_CHANGE): eth1: link becomes ready
[10423.362897] eth1: no IPv6 routers present
[10435.638362] SoftMAC: Open Authentication completed with 00:0a:95:f5:69:37
[10459.030061] SoftMAC: Open Authentication completed with 00:0a:95:f5:69:37
[10482.419793] SoftMAC: Open Authentication completed with 00:0a:95:f5:69:37
[10498.024806] SoftMAC: Received deauthentication packet from 00:13:02:3f:74:d8, but that network is unknown.
[10498.025934] SoftMAC: Received deauthentication packet from 00:13:02:3f:74:d8, but that network is unknown.
[10498.026780] SoftMAC: Received deauthentication packet from 00:13:02:3f:74:d8, but that network is unknown.
[10498.028430] SoftMAC: Received deauthentication packet from 00:13:02:3f:74:d8, but that network is unknown.
[10498.032557] SoftMAC: Received deauthentication packet from 00:13:02:3f:74:d8, but that network is unknown.
[10498.046790] SoftMAC: Received deauthentication packet from 00:13:02:3f:74:d8, but that network is unknown.
[10498.051162] SoftMAC: Received deauthentication packet from 00:13:02:3f:74:d8, but that network is unknown.
[10498.071699] SoftMAC: Received deauthentication packet from 00:13:02:3f:74:d8, but that network is unknown.
[10498.083476] SoftMAC: Received deauthentication packet from 00:13:02:3f:74:d8, but that network is unknown.
[10498.088160] SoftMAC: Received deauthentication packet from 00:13:02:3f:74:d8, but that network is unknown.
[10748.381445] ADDRCONF(NETDEV_UP): eth1: link is not ready



the other MAC is from the laptop of another guy in the room...
(oh yeah - I deinstalled network-manager. knetworkmanager went as well. I also threw out wlassitant for good measure.)
Thanks,

katu
January 18th, 2007, 07:16 PM
Another thing I noticed. When I execute iwconfig the result is:


eth1 IEEE 802.11b/g ESSID:"WAiRPort" Nickname:"Broadcom 4306"
Mode:Managed Frequency=2.472 GHz Access Point: 00:0A:95:F5:69:37
Bit Rate=1 Mb/s Tx-Power=15 dBm
RTS thr:off Fragment thr:off
Encryption key:off
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0


My question is. should the encryption key be off? Maybe I'm making a mistake there?

wieman01
January 18th, 2007, 09:00 PM
My question is. should the encryption key be off? Maybe I'm making a mistake there?
"iwconfig" is irrelevant at this stage... Another question: Can you connect to unsecured networks for sure? We should start from there... If you can't, we need to fix your card first.

lukemack
January 20th, 2007, 12:20 PM
Hi,

I'm having trouble getting WPA set up with my broadcom 4306 card. I'm running 6.10-server on i386 (dell dimension 4500)

i'm trying to connect to a netgear DG834GT. I can connect fine without the encryption and am using bcmwl5.inf with ndiswrapper.

i've attached the output from wpa_supplicant, iwlist scan and the contents of my wpa_supplicant.conf file.

can anyone help?

many thanks,

lukemack.

wieman01
January 20th, 2007, 12:50 PM
Hi,

I'm having trouble getting WPA set up with my broadcom 4306 card. I'm running 6.10-server on i386 (dell dimension 4500)

i'm trying to connect to a netgear DG834GT. I can connect fine without the encryption and am using bcmwl5.inf with ndiswrapper.

i've attached the output from wpa_supplicant, iwlist scan and the contents of my wpa_supplicant.conf file.

can anyone help?
Hi Luke,

This thread uses a different approach to wireless security. Please read the HOWTO first. I won't be able to help you with this one...

lukemack
January 20th, 2007, 01:45 PM
thanks. i;ve switched to using the interfaces file but get an error when trying to restart the network:

* Reconfiguring network interfaces... /etc/network/interfaces:14: option with empty value
ifdown: couldn't read interfaces file "/etc/network/interfaces"
/etc/network/interfaces:14: option with empty value
ifup: couldn't read interfaces file "/etc/network/interfaces"

any idea what might be causing this?

contents of /etc/interfaces:


# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

iface eth0 inet dhcp

auto eth1
iface eth1 inet dhcp
wpa-driver wext
wpa-conf managed
wpa-ssid="OLDSCHOOLHOUSE"
wpa-ap-scan 1
wpa-proto WPA
wpa-pairwise TKIP
wpa-group TKIP
wpa-key-mgmt WPA-PSK
psk=696251dd95c4238af640bb6b3a78e615372d0771e31axx xxxxxxxxxxxxxxxxx

i think its complaining about line 14 which is the ssid - i;ve tried this with and without quotes

wieman01
January 20th, 2007, 02:04 PM
Try this instead (simply copy and paste):

auto lo
iface lo inet loopback

auto eth1
iface eth1 inet dhcp
wpa-driver wext
wpa-conf managed
wpa-ssid OLDSCHOOLHOUSE
wpa-ap-scan 1
wpa-proto WPA
wpa-pairwise TKIP
wpa-group TKIP
wpa-key-mgmt WPA-PSK
wpa-psk 696251dd95c4238af640bb6b3a78e615372d0771e31axxxxxx xxxxxxxxxxxxx
Have you generated the key as suggested in the first post?

lukemack
January 20th, 2007, 02:43 PM
thanks - i get a bit further with that (the network tries to restart) but get the attached output (i dont receive a DHCP lease). The subnet mask looks wrong to me. anything I can do about that?

Also, do i still need to make changes in the networking gui to get this working?

thanks,

lukemack.

wieman01
January 20th, 2007, 02:50 PM
Looks much better now... Have you got network-manager or wifi-radar installed? Please remove it before you go ahead.

This error message does not look right:

/var/run/dhclient.eth1.pid with pid 134993416
Perhaps restart the computer after uninstalling the mentioned tools.

lukemack
January 20th, 2007, 03:04 PM
i dont have those installed no. i did want to install network manager but add/remove programs says it is not supported on i386?

a reboot hasnt helped unfortunately. would you expect these lines?

DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 7
DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 7
DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 18

when eth0 is connected (ethernet cable), ifconfig shows:

eth0 Link encap:Ethernet HWaddr 00:07:E9:00:7C:F2
inet addr:192.168.0.5 Bcast:192.168.0.255 Mask:255.255.255.0
inet6 addr: fe80::207:e9ff:fe00:7cf2/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:3699 errors:0 dropped:0 overruns:0 frame:0
TX packets:3415 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:3585950 (3.4 MiB) TX bytes:547529 (534.6 KiB)

so isnt it trying to discover something at the wrong address?

wieman01
January 20th, 2007, 03:37 PM
Pull the Ethernet cable while you are trying to connect through wireless. You cannot run both in Linux... Please try again with the cable unplugged.

lukemack
January 20th, 2007, 03:52 PM
i tried that - same thing. the ethernet cable is always unplugged when i am trying to connect via the wireless card. i also tried disabling the wired interface in administration->networking, various reboots and nothing works. i still get:

DHCPRELEASE on eth1 to 192.168.0.1 port 67
send_packet: Network is unreachable
send_packet: please consult README file regarding broadcast address.
There is already a pid file /var/run/dhclient.eth1.pid with pid 134993416

i have tried deleting the file it is complaining about but it just gets recreated when i run networking restart.

wieman01
January 20th, 2007, 03:58 PM
i tried that - same thing. the ethernet cable is always unplugged when i am trying to connect via the wireless card. i also tried disabling the wired interface in administration->networking, various reboots and nothing works. i still get:

DHCPRELEASE on eth1 to 192.168.0.1 port 67
send_packet: Network is unreachable
send_packet: please consult README file regarding broadcast address.
There is already a pid file /var/run/dhclient.eth1.pid with pid 134993416

i have tried deleting the file it is complaining about but it just gets recreated when i run networking restart.
But you can connect to unsecured / WEP secured networks no problem, right?

lukemack
January 20th, 2007, 03:59 PM
yes

wieman01
January 20th, 2007, 04:22 PM
yes
I am afraid I cannot help you there then. I have seen this problem before but not sure what the solution is. But perhaps try using other "wpa-drivers" as explained in the HOWTO. Sorry I cannot advice more.

flatfish
January 21st, 2007, 02:27 AM
Thank you for this incredibly useful HOWTO. I am a complete novice, but I've been able to connect to my network (with WPA !!) by following your instructions. One problem: I cannot get the network to restart during boot (Post #2). In order to connect, I must use the following after I log in:

sudo wpa_supplicant -D madwifi -i ath0 -c /etc/wpa_supplicant.conf -w -dd
sudo dhclient ath0


Here are the relevant files (I think)
/etc/wpa_supplicant.conf

ctrl_interface=/var/run/wpa_supplicant
network={
ssid="Planet Express"
scan_ssid=1
proto=WPA
pairwise=TKIP
key_mgmt=WPA-PSK
psk=*key*
}


/etc/network/interfaces

auto lo
iface lo inet loopback

auto ath0
iface ath0 inet dhcp
wpa-driver madwifi
wpa-conf managed
wpa-ssid Planet Express
wpa-ap-scan 1
wpa-proto WPA
wpa-pairwise TKIP
wpa-group TKIP
wpa-key-mgmt WPA-PSK
wpa-psk *key*
}

I'm using Edgy, there are no other network applications installed (network manager, wifi radar, etc.), and there is no ethernet cable plugged in. Any Idea what I'm doing wrong?

wieman01
January 21st, 2007, 11:17 AM
Flatfish:

First off, please make sure your "/etc/network/interfaces" file has no "}", that will confuse wpa_supplicant.

Second, you don't need "sudo wpa_supplicant -D madwifi -i ath0 -c /etc/wpa_supplicant.conf -w -dd" if your script is fine... So I suspect you have misconfigured something. Please consider the following:

1. Your router's ESSID is not hidden as suggested by this line:

wpa-ap-scan 1
2. You follow the steps outlined in the HOWTO when generating your WPA key, that's crucial:

wpa-psk
3. After updating the script, please restart the network & post the output if you cannot connect (yet):

sudo /etc/init.d/networking restart

Catsworth
January 21st, 2007, 03:38 PM
Yes, you can check by typing this:

If this command returns your link, then you have previously created it. Nonetheless, it does not harm redoing it & creating the right symblink.

Ok, I tried typing the above and got an error that says there is no such file or directory, so I redid the link and then retried and I'm still getting an error. This seems to suggest that the command to set up the symblink isn't working.

Catsworth
January 21st, 2007, 03:50 PM
Ok, sorted. I re-did the link and it seems to have taken this time. The network came up straight away after a reboot (which is nice :) ).

Looks like it's all working ok now, all I need to do now is find a better way of changing/storing the configurations. When I go to help my mates with their crappy Windoze installs, and then try to show off Ubuntu, I don't wat to spend half an hour trying to get the wireless to work each time if I can help it :)

wieman01
January 21st, 2007, 04:10 PM
Ok, sorted. I re-did the link and it seems to have taken this time. The network came up straight away after a reboot (which is nice :) ).

Looks like it's all working ok now, all I need to do now is find a better way of changing/storing the configurations. When I go to help my mates with their crappy Windoze installs, and then try to show off Ubuntu, I don't wat to spend half an hour trying to get the wireless to work each time if I can help it :)
Yes, good point. You might want to try graphical tools instead... Give Wifi-Radar, Network-Manager, or this one (http://ubuntuforums.org/showthread.php?t=299462) a try.

flatfish
January 21st, 2007, 04:34 PM
I removed the '}' from etc/network/interfaces, and yes the router's ESSID is not hidden. I re-generated the hex key and it is identical to the one I have in the script-I think it must be correct, since I am able to connect to the router.

sudo /etc/init.d/networking restart


* Reconfiguring network interfaces... Internet Systems Consortium DHCP Client V3.0.4
Copyright 2004-2006 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

wifi0: unknown hardware address type 801
wifi0: unknown hardware address type 801
Listening on LPF/ath0/00:15:e9:88:c7:45
Sending on LPF/ath0/00:15:e9:88:c7:45
Sending on Socket/fallback
DHCPDISCOVER on ath0 to 255.255.255.255 port 67 interval 8
DHCPDISCOVER on ath0 to 255.255.255.255 port 67 interval 20
DHCPOFFER from 192.168.1.254
DHCPREQUEST on ath0 to 255.255.255.255 port 67
DHCPACK from 192.168.1.254
bound to 192.168.1.70 -- renewal in 42010 seconds.


It is definitely connected now, since I am able to browse. I'll now reboot and see what happens.

wieman01
January 21st, 2007, 04:41 PM
It is definitely connected now, since I am able to browse. I'll now reboot and see what happens.
Looks ok now. If you have to restart the network after rebooting, please refer to post #2 of this thread. There is a solution posted.

May I ask what card have you got?

flatfish
January 21st, 2007, 04:43 PM
That did It! It connected automatically on reboot. Thanks a ton! The card is a DLink WDA 2320.

lukemack
January 21st, 2007, 04:58 PM
I got mine working in the end. wpa-supplicant.conf worked for me instead of using the interfaces file. i used the driver suggested here:

http://ubuntuguide.org/ see the section on ndiswrapper for broadcom chipsets and follow the instructions.

wieman01
January 21st, 2007, 05:22 PM
I got mine working in the end. wpa-supplicant.conf worked for me instead of using the interfaces file. i used the driver suggested here:

http://ubuntuguide.org/ see the section on ndiswrapper for broadcom chipsets and follow the instructions.
For some reason, Broadcom chips are a bit of a trouble here. Will have to mention that in my guide. Strange thing.

katu
January 21st, 2007, 10:52 PM
"iwconfig" is irrelevant at this stage... Another question: Can you connect to unsecured networks for sure? We should start from there... If you can't, we need to fix your card first.

Sorry, had to leave for a few days. So I couldn't do anything with this net. I did try with a wep encrypted network at a firend's house. And it didn't connect either. And used to be able to connect to that one, when I was still o dapper and using ndiswrapper ;/. Now it sees the network, but never gets the dhcp lease. I don't have access to an unsecure network. The earliest I'll be able to try will be Thursday (the one I was bale to connect, before this fun with trying WPA). darn.

Maybe Ill try to install ndiswrapper tomorrow and see how that goes.

wieman01
January 21st, 2007, 10:56 PM
Sorry, had to leave for a few days. So I couldn't do anything with this net. I did try with a wep encrypted network at a firend's house. And it didn't connect either. And used to be able to connect to that one, when I was still o dapper and using ndiswrapper ;/. Now it sees the network, but never gets the dhcp lease. I don't have access to an unsecure network. The earliest I'll be able to try will be Thursday (the one I was bale to connect, before this fun with trying WPA). darn.

Maybe Ill try to install ndiswrapper tomorrow and see how that goes.
That's bad news... Try to connect to unsecured networks first, that'll be a lot easier. When you do so, please make sure that you definitely remove programs like Wifi-Radar, Network-Manager, and Firestarter. Those can create a nightmare for you.

Once you can connect to unsecured networks, I am sure WPA will be an easy one.

compwiz18
January 23rd, 2007, 10:43 AM
Hi wieman01, I'm back with another weird question: How do I use iwconfig to connect to a hidden wireless network? I _think_ it is possible, but I'm not sure. I thought I had done it before by using the command iwconfig wlan0 essid "someonesessid", but that appears not to work today.

Thanks again for all your help.

wieman01
January 23rd, 2007, 11:17 AM
Hi wieman01, I'm back with another weird question: How do I use iwconfig to connect to a hidden wireless network? I _think_ it is possible, but I'm not sure. I thought I had done it before by using the command iwconfig wlan0 essid "someonesessid", but that appears not to work today.
All you need to do is set the ESSID in the used manner as you have pointed out... Hiding the ESSID merely entails that scanning yields no results. That's it. Only if you configure WPA using my approach do you have to specify whether the ID is broadcast or not.

compwiz18
January 23rd, 2007, 11:23 AM
Darn. Well, exams now, program later.

I'll get back to you if it still doesn't work.

Thanks for your help :D

Megabuntu
January 23rd, 2007, 06:01 PM
Hi!
I'm a new convert to the linux OS. I'm using Xubuntu 6.10 on a Dell Inspiron 2100. I have been trying for days to use my wireless. I have a Dell Truemobile 1150. I tried to go about connecting to the internet via wpa_supplicant.conf. I was able to connect when the encryption was off, but once it was turned on, i couldn't connect. The encryption is WPA1 and I set up the network/interfaces with Dhcp as you described.

I noticed that you told several people that they should remove the Network Manager program. I wasn't sure if I should because during the day I connect via wired ethernet, but at home I'd like to use wireless, and I thought it would be nice to have a GUI to do the switching with.

Here's what happens when I try to restart the network:
sudo /etc/init.d/networking restart
* Reconfiguring network interfaces... There is already a pid file /var/run/dhclient.eth1.pid with pid 5119
killed old client process, removed PID file
Internet Systems Consortium DHCP Client V3.0.4
Copyright 2004-2006 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

Listening on LPF/eth1/00:02:2d:8b:53:1b
Sending on LPF/eth1/00:02:2d:8b:53:1b
Sending on Socket/fallback
DHCPRELEASE on eth1 to 192.168.12.1 port 67
send_packet: Network is unreachable
send_packet: please consult README file regarding broadcast address.
ioctl[SIOCSIWAUTH]: Operation not supported
WEXT auth param 7 value 0x1 - ioctl[SIOCSIWENCODEEXT]: Operation not supported
ioctl[SIOCSIWENCODEEXT]: Operation not supported
ioctl[SIOCSIWENCODE]: Invalid argument
ioctl[SIOCSIWENCODEEXT]: Operation not supported
ioctl[SIOCSIWENCODE]: Invalid argument
ioctl[SIOCSIWENCODEEXT]: Operation not supported
ioctl[SIOCSIWENCODE]: Invalid argument
ioctl[SIOCSIWAUTH]: Operation not supported
WEXT auth param 4 value 0x0 - ioctl[SIOCSIWAUTH]: Operation not supported
WEXT auth param 5 value 0x1 - There is already a pid file /var/run/dhclient.eth1.pid with pid 134993416
Internet Systems Consortium DHCP Client V3.0.4
Copyright 2004-2006 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

Listening on LPF/eth1/00:02:2d:8b:53:1b
Sending on LPF/eth1/00:02:2d:8b:53:1b
Sending on Socket/fallback
DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 5
DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 7
DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 9
DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 15
DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 21
DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 4
No DHCPOFFERS received.
No working leases in persistent database - sleeping.

Here's my network/interfaces:
cat /etc/network/interfaces
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

iface eth0 inet dhcp

auto eth1
iface eth1 inet dhcp
wpa-driver wext
wpa-conf managed
wpa-ssid ****
wpa-ap-scan 1
wpa-proto WPA
wpa-pairwise TKIP
wpa-group TKIP
wpa-key-mgmt WPA-PSK
wpa-psk 455edbd8f697***.....

I'm sorry to be so verbose and take up space but I am at wit's end.
](*,)

wieman01
January 23rd, 2007, 06:08 PM
What wireless card have you got? Broadcom by chance? And what driver are you using.

This information is crucial because the wpa-driver "wext" complains that there is an issue with compatibility. Moreover it's necessary to remove Network-Manager as it will interfer with this approach. Does Network-Manager work for you in general? If so, I'd go for it instead.

EDIT:
This might be interesting for you as well: http://www.ubuntuforums.org/showthread.php?t=304217&highlight=Lucent+IEEE

Megabuntu
January 23rd, 2007, 10:08 PM
It's a Dell TrueMobile 1150 and it's supposed to use (?) an orinoco driver. I read about wext and what I understood was that it could work for a lot of cards. Should my network/interfaces list orinoco as the driver?

Network Manager works only for the wired connection. I can't get it to work for the wireless. I just didn't know that if I took networtk manager off then basically i'd have to go through terminal (which isn't a big problem, but slightly less convenient than the gui) to connect through the wired ethernet.

the link you sent looks like it deals with a similar problem as mine, but I know so little, I am not sure what applies and what doesn't.

Megabuntu
January 23rd, 2007, 11:56 PM
the link you posted (http://www.ubuntuforums.org/showthread.php?t=304217&highlight=Lucent+IEEE) mentions options of network manager that I don't have. Maybe it's a difference between xubuntu and ubuntu????

wieman01
January 24th, 2007, 07:01 AM
the link you posted (http://www.ubuntuforums.org/showthread.php?t=304217&highlight=Lucent+IEEE) mentions options of network manager that I don't have. Maybe it's a difference between xubuntu and ubuntu????
I am not entirely sure to be honest. Orinoco could be a problem, but check out other threads before you give up. You may also deploy your card's Windows driver instead using "ndiswrapper"... Is that an option? Normally "ndiswrapper" yields better results as it relies on the native Windows driver for your card.

Sorry I cannot advise more.

compwiz18
January 24th, 2007, 08:23 AM
Darn. Well, exams now, program later.

I'll get back to you if it still doesn't work.

Thanks for your help :D
Well, it seems to be working this morning...weird. I even rebooted yesterday.

ryu kun
January 30th, 2007, 10:00 PM
How can I make it search only a specific interval?

wieman01
January 31st, 2007, 08:14 AM
How can I make it search only a specific interval?
You need to help me there... Are you referring to DHCP intervals? That's nothing I can help you with since this has nothing to do with wireless security. Have you got trouble connecting?

ryu kun
January 31st, 2007, 01:27 PM
You need to help me there... Are you referring to DHCP intervals? That's nothing I can help you with since this has nothing to do with wireless security. Have you got trouble connecting?

Thanks for quick reply. Yes, I have a problem. I added a script called "S95wireless-network" to /etc/rcS.d but sometimes Ubuntu starts without a connection and in this case I have to restart networking manually with this command: sudo /etc/init.d/networking restart.

Sometimes it can't find any DHCP offer and can't connect when booting. So I thought that if I can set a static interval maybe I could solve this problem and speed up the DHCP offer/receive process, but today I realised that I was wrong, it doesn't use the same interval each time...

So, I wonder how can I make it regularly establish my connection when booting.

wieman01
January 31st, 2007, 02:00 PM
Thanks for quick reply. Yes, I have a problem. I added a script called "S95wireless-network" to /etc/rcS.d but sometimes Ubuntu starts without a connection and in this case I have to restart networking manually with this command: sudo /etc/init.d/networking restart.

Sometimes it can't find any DHCP offer and can't connect when booting. So I thought that if I can set a static interval maybe I could solve this problem and speed up the DHCP offer/receive process, but today I realised that I was wrong, it doesn't use the same interval each time...

So, I wonder how can I make it regularly establish my connection when booting.
Have you tried the solution as posted in post #2 of this thread? Please let me know if this does the job for you.

In addition, you might want to try static IP configuration instead. There could be a problem with DHCP. If all this does not help, drop me a note.

EDIT:
What card/adapter have you got again?

frick
February 1st, 2007, 01:18 AM
I am still a real new guy to Unbuntu edgy....

Many of the steps in this wep fix are not working or necessary in Edgy. The only problem is that I am to new to figure out the steps necessary in Edgy to make this wep fix to work.

Right now, I am running with no WIFI security... and that makes me a bit twitchy.

In 6.10 my card and drivers come up out of the box. The native Network Connection manager does little to make things work.

Wifi-radar worked to get me up on the net, but it does not help with WEP or WPA at all.

Any EDGY EFT fix?

Frick

Peacepunk
February 1st, 2007, 04:39 AM
*****************************Revoking read-permission from 'others'*********************************

sudo chmod o=-r /etc/network/interfaces
*****************************Revoking read-permission from 'others'*********************************

A bit more info on this part maybe ?

Cheers - congrats

I still have to restart my network after login in ubuntu 6.06, but it does work.
[ See my post on sniffing right here & you'll understand THIS howto was crucial. Bandwith is very expensive in Cambodia.]

wpa_gui returns the right info BTW, and allow me to disconnect-connect when needed.

Heading to the "startup Script" phase now...

Jean-Philippe

wieman01
February 1st, 2007, 09:09 AM
I am still a real new guy to Unbuntu edgy....

Many of the steps in this wep fix are not working or necessary in Edgy. The only problem is that I am to new to figure out the steps necessary in Edgy to make this wep fix to work.

Right now, I am running with no WIFI security... and that makes me a bit twitchy.

In 6.10 my card and drivers come up out of the box. The native Network Connection manager does little to make things work.

Wifi-radar worked to get me up on the net, but it does not help with WEP or WPA at all.

Any EDGY EFT fix?

Frick
Wifi-Radar should be fine with WPA and WEP as well.

wieman01
February 1st, 2007, 09:13 AM
A bit more info on this part maybe ?
This ensures that no unprivileged users can read the contents of "/etc/network/interfaces" and thus gain access to secret network keys. It a simple security measure and you might as well ignore it. But I'll update the thread one of these days and highlight the purpose of this section.

gamerteck
February 9th, 2007, 09:36 PM
I can confirm this worked on my laptop, connecting though LEAP authentication.

HP/Compaq NC6230

The only hitch was that on this model, which comes with integrated wireless, you have to input the config in the eth1 field. Config as follows.



auto lo
iface lo inet loopback

auto eth0
iface eth0 inet dhcp

auto eth1
iface eth1 inet dhcp
wpa-driver wext
wpa-conf managed
wpa-ssid <your_essid>
wpa-eap LEAP
wpa-key-mgmt IEEE8021X
wpa-identity <your_user_name>
wpa-password <your_password>


Big-up to you wieman01 for posting this howto!!=D>

Thank you very much!!

cara_cooper
February 11th, 2007, 07:46 PM
Hey,

I followed the directions to set up a wpa tkip psk and it's not working. it keeps finding errors. and why is it that when i go to get the wpa-psk key it is different everytime? should i just type in the key that we use for the other computers?

cara_cooper
February 11th, 2007, 08:05 PM
I keep getting the error while getting interface flags: no such device

and what driver interface am i supposed to use there's madwifi and wext and some others but they aren't working i have a belkin/atheros wireless card. i thought that i was supposed to use madwifi with that idk.
it seems like i don't have the right driver interface or something. was there something else i am supposed to do besides type one of the interface names (like wext or madwifi etc...)


thanks for the help

yael

p.s i'm new at this i'm trying to learn though :D

javapinoy
February 11th, 2007, 09:20 PM
well i just found this website today, and i followed the instructions provided and it worked out for me. but i originally followed the directions of a separate website to setup my wireless usb device and ndiswrapper and such and only this website to setup wpa.

i had a similar problem when i rebooted my computer and i got a lot of device not found sort of errors because my device wasn't turning on (the leds were off so i assumed it was off) but i just went through and did some commands like:

sudo depmod -a
sudo modprobe ndiswrapper

and it turned back on and i was then able to use the instructions provided above

sudo /etc/init.d/networking restart

to get it up and running again

maybe some of these commands are useful to you too
here are the websites i followed before getting to here

http://www.linuxquestions.org/questions/showthread.php?t=406333&highlight=mn710
http://ndiswrapper.sourceforge.net/mediawiki/index.php/Installation

hopefully some of those pages are relevant to you

noel

wieman01
February 12th, 2007, 08:23 AM
I keep getting the error while getting interface flags: no such device
I suppose that your network adapter / Linux driver does not support WPA. What adapter have you got & what driver do you use?

Plus it would be important to know if you can connect to unsecured networks. Please also post your script.

EDIT:
As pointed out by Javapinoy, "ndiswrapper" could an option for you. Check it out.

d3dtn01
February 14th, 2007, 06:01 PM
I followed the excellent HowTo, but have had no success. I setup my network with WPA2 and DHCP, so my interfaces files reads like this:



auto lo
iface lo inet loopback

# The primary network interface
iface eth0 inet dhcp

# The wireless network interface
auto wlan0
iface wlan0 inet dhcp
wpa-driver ndiswrapper
wpa-conf managed
wpa-ssid habibi
wpa-ap-scan 1
wpa-proto RSN
wpa-pairwise CCMP
wpa-group CCMP
wpa-key-mgmt WPA-PSK
wpa-psk c1cc29f9151cedb15d292d1607e4aba74e8680cda61986f122 5702668b818873


I saved the file, then restart my network with the command:


sudo /etc/init.d/networking restart

This is the output that I got:


daren@DellB120:~$ sudo /etc/init.d/networking restart
Password:
* Reconfiguring network interfaces... There is already a pid file /var/run/dhclient.eth0.pid with pid 134993416
Internet Systems Consortium DHCP Client V3.0.4
Copyright 2004-2006 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

Listening on LPF/eth0/00:14:22:9a:89:92
Sending on LPF/eth0/00:14:22:9a:89:92
Sending on Socket/fallback
DHCPRELEASE on eth0 to 192.168.1.1 port 67
send_packet: Network is unreachable
send_packet: please consult README file regarding broadcast address.
Internet Systems Consortium DHCP Client V3.0.4
Copyright 2004-2006 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

Listening on LPF/wlan0/00:14:a5:4f:36:1a
Sending on LPF/wlan0/00:14:a5:4f:36:1a
Sending on Socket/fallback
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 8
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 13
No DHCPOFFERS received.
No working leases in persistent database - sleeping.
There is already a pid file /var/run/dhclient.eth0.pid with pid 134993416
Internet Systems Consortium DHCP Client V3.0.4
Copyright 2004-2006 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

Listening on LPF/eth0/00:14:22:9a:89:92
Sending on LPF/eth0/00:14:22:9a:89:92
Sending on Socket/fallback
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 8
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 13
No DHCPOFFERS received.
No working leases in persistent database - sleeping.


Did I make any obvious mistakes? Any suggestions?

wieman01
February 14th, 2007, 08:26 PM
Assuming that you use "ndiswrapper" (either "wlan0" or "eth1") in connection with a WPA2-capable(!) Windows driver, your file should read like this (I am commenting the eth0 interface for testing):

auto lo
iface lo inet loopback

# The primary network interface
#iface eth0 inet dhcp

# The wireless network interface
auto wlan0
iface wlan0 inet dhcp
wpa-driver wext
wpa-conf managed
wpa-ssid habibi
wpa-ap-scan 1
wpa-proto RSN
wpa-pairwise CCMP
wpa-group CCMP
wpa-key-mgmt WPA-PSK
wpa-psk c1cc29f9151cedb15d292d1607e4aba74e8680cda61986f122 5702668b818873
The correct wpa-driver for "ndiswrapper" is "wext". You are not hiding your ESSID, are you? Can you connect to unsecured networks?

d3dtn01
February 14th, 2007, 08:45 PM
Yipee! I'm connected. Thanks for your help. I changed my driver to wext. I also realized that my router broadcast was disabled. After enabling it and modifying the driver in the interfaces file I was able to connect. Let's hope it lasts. Many, many thanks for resolving this annoying problem.

wieman01
February 14th, 2007, 10:29 PM
Yipee! I'm connected. Thanks for your help. I changed my driver to wext. I also realized that my router broadcast was disabled. After enabling it and modifying the driver in the interfaces file I was able to connect. Let's hope it lasts. Many, many thanks for resolving this annoying problem.
No problem. Change "wpa-ap-scan" if you want to disable broadcast nonetheless:

wpa-ap-scan 2

heyo
February 14th, 2007, 11:19 PM
good post thats very useful for alot of pppl.. wireless is very widespread and unfortunatelty many of them are unsecured

FrancoNero
February 15th, 2007, 04:05 AM
all this should work out-of-the-box without anyone having to edit anything or run any command lines.... seriously, an ubuntu user should just have to click on his/her network manager icon, select the wireless lan he wants to connect to and select the sorts of options like wpa, aes etc and enter the passphrase.... we're in 2007, people do things by clicking and selecting, not by typing commands and editing text files. is it linux for human beings or not?

Peacepunk
February 15th, 2007, 04:30 AM
It Works! I sure feel the same, but if dumb people like me & my wife can do it, the point-and-click option isn't _that_ important.
Check this (http://www.ubuntuforums.org/showthread.php?t=349980).

To keep this discussion technical, why don't you try wpa_gui, so to make the thread progress on the point'N'click options?

Currently, I have to command-line the start of it, then I can use the wpa GUI thingy to disconnect/reconnect when needed.


As stated by frodon, the actual discussion happens here (http://www.ubuntuforums.org/showthread.php?t=202834).



They should lock this one with a Top-Page notice on the open discussion thread.

Cheers

Jean-Philippe.

wieman01
February 15th, 2007, 08:28 AM
all this should work out-of-the-box without anyone having to edit anything or run any command lines.... seriously, an ubuntu user should just have to click on his/her network manager icon, select the wireless lan he wants to connect to and select the sorts of options like wpa, aes etc and enter the passphrase.... we're in 2007, people do things by clicking and selecting, not by typing commands and editing text files. is it linux for human beings or not?
You do have a point, I wasn't happy when I found out either. Unfortunately all existing graphical tools don't deliver (yet) what I was in need of in the first place, i.e. WPA2 with static IP (DHCP disabled) and hidden broadcast of the ESSID. There are standard tools such as Network Manager, Wifi-Radar, etc. but all of them have certain drawbacks and insufficiencies.

Give this (http://ubuntuforums.org/showthread.php?t=299462) program a go, I have heard it works for a lot people.

Let's hope this thread will become moot by the time the next stable release of Ubuntu comes out. Look forward to it.

brodiepearce
February 17th, 2007, 10:23 AM
I followed the guide step for step, unfortunately I'm still having issues. Previously Ubuntu was idling on "Configuring Network Interfaces" on boot, Ctrl-C would skip it, but then a blank screen would occur after login.

After doing this guide, it gets through the interface configuration, however I still get a blank screen. I'm using a Minitar MN54GPC-RC pci wifi NIC, I'm guessing that the rest of the issue is due to the card? Should I install some drivers for it or are there still some settings that could be changed to fix the issue?

wieman01
February 17th, 2007, 04:30 PM
I followed the guide step for step, unfortunately I'm still having issues. Previously Ubuntu was idling on "Configuring Network Interfaces" on boot, Ctrl-C would skip it, but then a blank screen would occur after login.

After doing this guide, it gets through the interface configuration, however I still get a blank screen. I'm using a Minitar MN54GPC-RC pci wifi NIC, I'm guessing that the rest of the issue is due to the card? Should I install some drivers for it or are there still some settings that could be changed to fix the issue?
Can you connect to unsecured networks? Second, please try WPA1 before you go ahead with WPA2 which some cards don't seem to support.

brodiepearce
February 18th, 2007, 04:30 AM
Can you connect to unsecured networks? Second, please try WPA1 before you go ahead with WPA2 which some cards don't seem to support.

Tried again just now on a fresh install of Dapper, the same problem still occurs on WPA1. I'll try it again with just SSID enabled.

*edit* Doesn't work with just SSID without encryption either. I'm using a Minitar MN54GPC pci card, "unco" has published a pretty comprehensive guide (http://www.ubuntuforums.org/showthread.php?t=259355&highlight=minitar) on getting this card to work with Dapper, I was hoping that it wouldn't be necessary but it appears it is. Currently I'm just using the wext driver as defined in the example code, should I try using the Minitar driver instead? Dapper comes with the Ralink RT2500 driver by default though...

wieman01
February 18th, 2007, 10:24 AM
Tried again just now on a fresh install of Dapper, the same problem still occurs on WPA1. I'll try it again with just SSID enabled.

*edit* Doesn't work with just SSID without encryption either. I'm using a Minitar MN54GPC pci card, "unco" has published a pretty comprehensive guide (http://www.ubuntuforums.org/showthread.php?t=259355&highlight=minitar) on getting this card to work with Dapper, I was hoping that it wouldn't be necessary but it appears it is. Currently I'm just using the wext driver as defined in the example code, should I try using the Minitar driver instead? Dapper comes with the Ralink RT2500 driver by default though...
The RT2500 driver is fairly BETA as far as I remember (Serialmonkey). I us "ndiswrapper" and the native Windows driver instead (also a Ralink chipset). Please try to connect to unsecured networks first of all, this thread won't be much of help otherwise.

scoggy
February 19th, 2007, 03:03 PM
Just a quicky to say thanks to all for this thread. I'm a linx n00b, and have recently installed Ubuntu on my Dell Inspiron 6000 to dual boot with XP. I was getting a bit frustrated with Ubuntu which I'd heard was great for n00bs. I was getting frustrated trying to solve my wireless issues without internet access. I saved the first page of this thread to my hard drive and it solved my problems (after a bit of user error).

I'm getting long boot times as others are, so I'll look into that next, but it should be easier now I have web access and don't have to go into XP all the time.

I have to say, until this sort of thing is easier Linux is always going to be not-for-the-masses, but helpful people on forums like this go a long way to making it possible for reasonably technical (but not hugely technical) people like me.

Thanks again!

wieman01
February 19th, 2007, 06:25 PM
Just a quicky to say thanks to all for this thread. I'm a linx n00b, and have recently installed Ubuntu on my Dell Inspiron 6000 to dual boot with XP. I was getting a bit frustrated with Ubuntu which I'd heard was great for n00bs. I was getting frustrated trying to solve my wireless issues without internet access. I saved the first page of this thread to my hard drive and it solved my problems (after a bit of user error).

I'm getting long boot times as others are, so I'll look into that next, but it should be easier now I have web access and don't have to go into XP all the time.

I have to say, until this sort of thing is easier Linux is always going to be not-for-the-masses, but helpful people on forums like this go a long way to making it possible for reasonably technical (but not hugely technical) people like me.

Thanks again!
Thanks for posting your note. To shorten boot times, try Static IP instead of DHCP. I use Static IP and there is virtually no delay during startup. Give it a go!

shaftoe
February 19th, 2007, 08:32 PM
First of all, thanks to all of those who have maintained this thread; it has contributed greatly to my sanity.

Recently I installed Ubuntu 5.10 on an old P3 I am attempting to rehabilitate and subsequently upgraded (via the editing sources.list route) to 6.06 LTS. I am a Linux n00b but I have been excited to give it a try, Wired internet works great, but WPA wireless has been a 2+ day headache so far.

I am using a D-link DWL-G520 PCI card and trying to connect to a D-Link router with WPA authentication. If I disable authentication on the router, I can connect to it and browse normally.

Here are the outputs from my system:


foos@waterhouse:~$ uname -a
Linux waterhouse 2.6.15-28-386 #1 PREEMPT Thu Feb 1 15:51:56 UTC 2007 i686 GNU/Linux

foos@waterhouse:~$ ifconfig -a
ath0 Link encap:Ethernet HWaddr 00:0D:88:C8:7D:CF
inet addr:192.168.0.103 Bcast:192.168.0.255 Mask:255.255.255.0
inet6 addr: fe80::20d:88ff:fec8:7dcf/64 Scope:Link
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:4 errors:0 dropped:0 overruns:0 frame:0
TX packets:13 errors:13 dropped:13 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:452 (452.0 b) TX bytes:830 (830.0 b)

eth0 Link encap:Ethernet HWaddr 00:01:02:76:97:DF
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:5388 errors:0 dropped:0 overruns:46 frame:0
TX packets:1637 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:2481836 (2.3 MiB) TX bytes:246976 (241.1 KiB)
Interrupt:9 Base address:0x8000

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:48905 errors:0 dropped:0 overruns:0 frame:0
TX packets:48905 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:3983636 (3.7 MiB) TX bytes:3983636 (3.7 MiB)

sit0 Link encap:IPv6-in-IPv4
NOARP MTU:1480 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

wifi0 Link encap:UNSPEC HWaddr 00-0D-88-C8-7D-CF-61-74-00-00-00-00-00-00-00-00
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:5251 errors:0 dropped:0 overruns:0 frame:1894386
TX packets:4427 errors:0 dropped:13 overruns:0 carrier:0
collisions:0 txqueuelen:199
RX bytes:704790 (688.2 KiB) TX bytes:240881 (235.2 KiB)
Interrupt:9

Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
192.168.0.0 0.0.0.0 255.255.255.0 U 0 0 0 ath0
0.0.0.0 192.168.0.1 0.0.0.0 UG 0 0 0 ath0

foos@waterhouse:~$ iwconfig
lo no wireless extensions.

wifi0 no wireless extensions.

ath0 IEEE 802.11g ESSID:"seaview"
Mode:Managed Frequency:2.447 GHz Access Point: Not-Associated
Bit Rate:54 Mb/s Tx-Power:31 dBm Sensitivity=0/3
Retry:off RTS thr:off Fragment thr:off
Power Management:off
Link Quality=34/94 Signal level=-51 dBm Noise level=-85 dBm
Rx invalid nwid:3428 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

eth0 no wireless extensions.

sit0 no wireless extensions.

foos@waterhouse:~$ lsmod | grep ath
ath_rate_sample 13568 1
ath_pci 97440 0
wlan 210756 4 wlan_scan_sta,ath_rate_sample,ath_pci
ath_hal 191824 3 ath_rate_sample,ath_pci

foos@waterhouse:~$ iwlist scan
lo Interface doesn't support scanning.

wifi0 Interface doesn't support scanning.

ath0 Scan completed :
Cell 01 - Address: 00:0F:3D:4F:26:76
ESSID:"seaview"
Mode:Master
Frequency:2.412 GHz (Channel 1)
Quality=36/94 Signal level=-59 dBm Noise level=-95 dBm
Encryption key:on
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
12 Mb/s; 24 Mb/s; 36 Mb/s; 9 Mb/s; 18 Mb/s
48 Mb/s; 54 Mb/s
Extra:bcn_int=100
IE: WPA Version 1
Group Cipher : TKIP
Pairwise Ciphers (1) : TKIP
Authentication Suites (1) : PSK
Extra:ath_ie=dd0900037f01010006ff7f

eth0 Interface doesn't support scanning.

sit0 Interface doesn't support scanning.

foos@waterhouse:~$ cat /etc/network/interfaces
auto lo
iface lo inet loopback


auto ath0
iface ath0 inet static
address 192.168.0.103
netmask 255.255.255.0
network 192.168.0.1
broadcast 192.168.0.255
gateway 192.168.0.1
dns-nameservers 192.168.0.1
wpa-driver madwifi
wpa-conf managed
wpa-ssid seaview
wpa-ap-scan 1
wpa-proto WPA
wpa-pairwise TKIP
wpa-group TKIP
wpa-key-mgmt WPA-PSK
wpa-psk HEX-PASSWORD-FROM-WPA_PASSPHRASE

foos@waterhouse:~$ cat /etc/resolv.conf
nameserver 192.168.0.1


I'd appreciate any help that anyone can offer.

Cheers.

wieman01
February 19th, 2007, 09:28 PM
"wifi0" suggests that you have Wifi-Radar installed. Please uninstall it in order for this thread to work for you.

Second there is a minor error as far as the (static) network settings are concerned:

auto ath0
iface ath0 inet static
address 192.168.0.103
netmask 255.255.255.0
network 192.168.0.0
broadcast 192.168.0.255
gateway 192.168.0.1
dns-nameservers 192.168.0.1
wpa-driver madwifi
wpa-conf managed
wpa-ssid seaview
wpa-ap-scan 1
wpa-proto WPA
wpa-pairwise TKIP
wpa-group TKIP
wpa-key-mgmt WPA-PSK
wpa-psk HEX-PASSWORD-FROM-WPA_PASSPHRASE
The rest should be fine actually. Please try again and post the results here.

shaftoe
February 19th, 2007, 09:57 PM
Thanks for the quick reply. I changed /etc/network/interfaces per your suggestion. Synaptic shows that the wifi radar package is not installed.

Unfortunately, my problems have persisted. Any further help is appreciated. Thanks.

ubuntu_demon
February 19th, 2007, 09:59 PM
shaftoe :

From https://help.ubuntu.com/community/HardwareSupportComponentsWirelessNetworkCardsDlink :


DAPPER: Nearly works out-of-the-box, but had to add "wireless-rate 11M" to /etc/network/interfaces + reboot or two.


So you may want to experiment with this wireless-rate setting but I hope you won't need to set it to a lower speed.

I'm interested in your result with wpa and especially wpa2 because I'm considering buying the same pci card see :
http://www.ubuntuforums.org/showthread.php?t=363633

ubuntu_demon
February 19th, 2007, 10:09 PM
Thanks for the quick reply. I changed /etc/network/interfaces per your suggestion. Synaptic shows that the wifi radar package is not installed.

Unfortunately, my problems have persisted. Any further help is appreciated. Thanks.
Do you have restricted modules installed ? To install them :

If you are running 686 kernel (works for p3) then :
$sudo aptitude install linux-686

If you are running 386 kernel (default and you are running 386) then :
$sudo aptitude install linux-386

After you have installed them you should do a reboot.

wieman01
February 19th, 2007, 10:12 PM
Thanks for the quick reply. I changed /etc/network/interfaces per your suggestion. Synaptic shows that the wifi radar package is not installed.

Unfortunately, my problems have persisted. Any further help is appreciated. Thanks.
Could you do a:

ifdown ath0
...and a:

ifup -v ath0
Just to see what's really going on. Please post the output.

wieman01
February 19th, 2007, 10:15 PM
Do you have restricted modules installed ? To install them :

If you are running 686 kernel (works for p3) then :
$sudo aptitude install linux-686

If you are running 386 kernel (default and you are running 386) then :
$sudo aptitude install linux-386

After you have installed them you should do a reboot.
Good point...

@shaftoe:

Can you connect to unsecured wireless networks at this stage? Have you tried and are you positive it works?

shaftoe
February 19th, 2007, 11:03 PM
Ok. I have the necessary restricted modules, as
sudo aptitude install linux-386 does not install anything.

I must have been mistaken earlier, because disabling the security on my router does not allow me to connect.

outputs:

foos@waterhouse:~$ sudo ifup -v ath0
Configuring interface ath0=ath0 (inet)
run-parts --verbose /etc/network/if-pre-up.d
run-parts: executing /etc/network/if-pre-up.d/wireless-tools
run-parts: executing /etc/network/if-pre-up.d/wpasupplicant
wpa_supplicant: ctrl_interface=/var/run/wpa_supplicant
wpa_supplicant: /sbin/wpa_supplicant -B -P /var/run/wpa_supplicant.ath0.pid -i ath0 -C /var/run/wpa_supplicant -D madwifi
Starting /sbin/wpa_supplicant...
wpa_supplicant: ctrl_interface socket located at /var/run/wpa_supplicant/ath0
wpa_supplicant: wpa-ap-scan : OK
wpa_supplicant: configuring new network block "0"wpa_supplicant: wpa-ssid : OK
wpa_supplicant: wpa-psk : OK
wpa_supplicant: wpa-pairwise : OK
wpa_supplicant: wpa-group : OK
wpa_supplicant: wpa-key-mgmt : OK
wpa_supplicant: wpa-proto : OK
wpa_supplicant: enabling network 0 : OK

ifconfig ath0 192.168.0.103 netmask 255.255.255.0 broadcast 192.168.0.255 up
route add default gw 192.168.0.1 ath0
run-parts --verbose /etc/network/if-up.d
run-parts: executing /etc/network/if-up.d/mountnfs
run-parts: executing /etc/network/if-up.d/ntpdate
Synchronizing clock to ntp.ubuntu.com...
Error : Temporary failure in name resolution



foos@waterhouse:~$ sudo ifdown -v ath0
Configuring interface ath0=ath0 (inet)
run-parts --verbose /etc/network/if-down.d
run-parts: executing /etc/network/if-down.d/wpasupplicant
wpa_supplicant: ctrl_interface=/var/run/wpa_supplicant
route del default gw 192.168.0.1 ath0
ifconfig ath0 down
run-parts --verbose /etc/network/if-post-down.d
run-parts: executing /etc/network/if-post-down.d/wireless-tools
run-parts: executing /etc/network/if-post-down.d/wpasupplicant
wpa_supplicant: ctrl_interface=/var/run/wpa_supplicant
wpa_supplicant: terminating wpa_supplicant daemon
Stopped wpa_supplicant (pid 5447).


Thanks for the help.

ubuntu_demon
February 19th, 2007, 11:51 PM
shaftoe :
If you want to connect unsecured make sure the "ath0" part of your /etc/network/interfaces looks like this and nothing else for static (assuming these parameters are correct ):



auto ath0
iface ath0 inet static
address 192.168.0.103
netmask 255.255.255.0
network 192.168.0.0
broadcast 192.168.0.255
gateway 192.168.0.1
dns-nameservers 192.168.0.1


and for dhcp:



auto ath0
iface ath0 inet dhcp


In other words remove the "wpa-" lines when trying to connect unsecured

shaftoe
February 20th, 2007, 12:15 AM
ubuntu_demon:

I made the modification to interfaces but it was fruitless. The output (with dhcp; static did not work either).


foos@waterhouse:~$ sudo /etc/init.d/networking restart
* Reconfiguring network interfaces... Internet Systems Consortium DHCP Client V3.0.3
Copyright 2004-2005 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/products/DHCP

wifi0: unknown hardware address type 801
wifi0: unknown hardware address type 801
Listening on LPF/ath0/00:0d:88:c8:7d:cf
Sending on LPF/ath0/00:0d:88:c8:7d:cf
Sending on Socket/fallback
DHCPRELEASE on ath0 to 192.168.0.1 port 67
send_packet: Network is unreachable
send_packet: please consult README file regarding broadcast address.
Internet Systems Consortium DHCP Client V3.0.3
Copyright 2004-2005 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/products/DHCP

wifi0: unknown hardware address type 801
wifi0: unknown hardware address type 801
Listening on LPF/ath0/00:0d:88:c8:7d:cf
Sending on LPF/ath0/00:0d:88:c8:7d:cf
Sending on Socket/fallback
DHCPDISCOVER on ath0 to 255.255.255.255 port 67 interval 8
DHCPDISCOVER on ath0 to 255.255.255.255 port 67 interval 13
DHCPDISCOVER on ath0 to 255.255.255.255 port 67 interval 9
DHCPDISCOVER on ath0 to 255.255.255.255 port 67 interval 10
DHCPDISCOVER on ath0 to 255.255.255.255 port 67 interval 14
DHCPDISCOVER on ath0 to 255.255.255.255 port 67 interval 7
No DHCPOFFERS received.
No working leases in persistent database - sleeping.
[ ok ]


I am well and truly stumped.

wieman01
February 20th, 2007, 08:08 AM
Just a thought... Do you want to use the interface "wifi0" instead of "ath0"? Would that make a difference? If it doesn't then you best open a new thread as this rather relates to getting your wireless adapter to work.

shaftoe
February 21st, 2007, 12:44 AM
wieman01:

My wireless card works properly on an unsecured network with the following /etc/network/interfaces:


foos@waterhouse:~$ cat /etc/network/interfaces
auto lo
iface lo inet loopback

iface ath0 inet dhcp
wireless-essid seaview

auto ath0

Here is the output when I bring the connection up:



foos@waterhouse:~$ sudo ifup -v ath0
Configuring interface ath0=ath0 (inet)
run-parts --verbose /etc/network/if-pre-up.d
run-parts: executing /etc/network/if-pre-up.d/wireless-tools
run-parts: executing /etc/network/if-pre-up.d/wpasupplicant

dhclient3 -pf /var/run/dhclient.ath0.pid -lf /var/lib/dhcp3/dhclient.ath0.leases ath0
Internet Systems Consortium DHCP Client V3.0.3
Copyright 2004-2005 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/products/DHCP

wifi0: unknown hardware address type 801
wifi0: unknown hardware address type 801
Listening on LPF/ath0/00:0d:88:c8:7d:cf
Sending on LPF/ath0/00:0d:88:c8:7d:cf
Sending on Socket/fallback
DHCPDISCOVER on ath0 to 255.255.255.255 port 67 interval 6
DHCPOFFER from 192.168.0.1
DHCPREQUEST on ath0 to 255.255.255.255 port 67
DHCPACK from 192.168.0.1
bound to 192.168.0.100 -- renewal in 292317 seconds.
run-parts --verbose /etc/network/if-up.d
run-parts: executing /etc/network/if- up.d/mountnfs
run-parts: executing /etc/network/if-up.d/ntpdate
Synchronizing clock to ntp.ubuntu.com...

WPA, unfortunately, still does not work. If anyone has any ideas I am all ears. Thanks much.

ubuntu_demon
February 21st, 2007, 02:57 AM
to shaftoe :

Did you try WPA(2) without hidden essid ?

Did you try both wext and madwifi ?

Did you try connecting in this way ? (more d's means more debug information. try both wext and madwifi) :
$ sudo wpa_supplicant -c/etc/wpa_supplicant/wpa_supplicant.conf -i ath0 -D wext
$ sudo wpa_supplicant -c/etc/wpa_supplicant/wpa_supplicant.conf -i ath0 -D wext -d
$ sudo wpa_supplicant -c/etc/wpa_supplicant/wpa_supplicant.conf -i ath0 -D wext -dd

Now you can puzzle around and see what goes wrong and change that specific setting. That's how I was able to "reverse engineer" the wireless network settings of my university.

wieman01
February 21st, 2007, 08:03 AM
wieman01:

WPA, unfortunately, still does not work. If anyone has any ideas I am all ears. Thanks much.
Ok, that's good news. Please give me a few more details with regard to:

1. ESSID broadcast enabled or not.
2. WPA with TKIP or AES (WPA1 vs. WPA2) -> Check the router's settings please.
3. IP address of your router (which I seem to know already).

Once I know this I am sure we will be able to come up with a working script.

EDIT:
Have you got "wpa-supplicant" installed?

gejr
February 21st, 2007, 04:16 PM
I managed to connect to my wpa-psk network thanks to this guide. The problem is I'm moving my laptop around and sometimes I need to be easily able to connect to other networks. Isn't this type of solution a bit too static? How can I swap easily between networks? Do I have to reconfig /etc/network/interfaces every time?

wieman01
February 21st, 2007, 05:17 PM
I managed to connect to my wpa-psk network thanks to this guide. The problem is I'm moving my laptop around and sometimes I need to be easily able to connect to other networks. Isn't this type of solution a bit too static? How can I swap easily between networks? Do I have to reconfig /etc/network/interfaces every time?
Then you'd better install Network-Manager or Wifi-Radar. This is a static approach, I must agree.

ubuntu_demon
February 21st, 2007, 07:25 PM
I managed to connect to my wpa-psk network thanks to this guide. The problem is I'm moving my laptop around and sometimes I need to be easily able to connect to other networks. Isn't this type of solution a bit too static? How can I swap easily between networks? Do I have to reconfig /etc/network/interfaces every time?
Did you manage to get wpa-psk working with CCMP ? I would be very interested in this because I'm going to buy a PCI card soon. I want a PCI card which supports WPA2 personal with CCMP. Could you please try for me ? Also which step solved the problem ? What were you doing wrong to make it work ?

I use different networks and I use wpa-supplicant. IMHO wpa-supplicant can be a quite dynamic approach.

wpasupplicant.conf :


ap_scan=2

network={
ssid="myhomenetwork"
proto=WPA2
pairwise=CCMP
group=CCMP
key_mgmt=WPA-PSK
psk=********************************
}

network={
ssid="university"
key_mgmt=IEEE8021X
wep_key0=******************
phase2="auth=MSCHAPV2"
identity="************"
password="************"
}

network={
ssid="friend1
psk="******"
# this guy is is living with students in a house where they are using WEP encryption
}

network={
ssid="friend2"
proto=WPA2
key_mgmt=WPA-PSK
psk="******"
# you don't need to specifiy group and pairwise. wpasupplicant will figure it out.
}

network={
ssid="friend3"
proto=WPA
key_mgmt=WPA-PSK
psk="********"
}



my /etc/network/interfaces :



auto eth1
iface eth1 inet dhcp
wpa-driver wext
wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf


Now I only have to bring it up (wherever I am) using :
$sudo ifdown eth1 && sudo ifup eth1

The configuration of new networks is often easy because they tend to be like friend1,friend2 and friend3 in my experience (but I only have this laptop for a few months). There's good documentation available in /usr/share/doc/wpasupplicant especially the example configs for all kind of networks are handy.Those reside in /usr/share/doc/wpasupplicant/examples. Finally /usr/share/doc/wpasupplicant/wpa_supplicant.conf shows all the different options.

If you encounter a WPA2 enterprise network (such as universities and companies have). Making small adjustments to your wpasupplicant and looking at the resulting debugging output is your best shot (try both wext and madwifi) :
$ sudo wpa_supplicant -c/etc/wpa_supplicant/wpa_supplicant.conf -i ath1 -Dwext
$ sudo wpa_supplicant -c/etc/wpa_supplicant/wpa_supplicant.conf -i ath1 -Dwext -d
$ sudo wpa_supplicant -c/etc/wpa_supplicant/wpa_supplicant.conf -i ath1 -Dwext -dd

If you on the other hand log into new networks often and you don't want to edit wpasupplicant each time you want to access a new network and you never need WPA(2) then I would suggest network-manager.

networkmanager is often not an option when you need to connect to WPA2 enterprise networks such as universities and companies can have.

Personally I'm a fan of wpasupplicant because I like being in control. But networkmanager is easier. It's your choice :).

zcik
February 21st, 2007, 07:45 PM
I don't have wi-fi radar and I shut down knetworkmanager as specified in the howto. a couple of searches with ps aux revelaed that there was indeed a NetworkManager and NetworkManagerDispatcher running. I killed those and apparently the connection is still not there, but the error messages are different:


* Reconfiguring network interfaces... Ignoring unknown interface eth0=eth0.
wpa_supplicant: unknown or stale ctrl_interface socket located at /var/run/wpa_supplicant/eth1...aborting!
run-parts: /etc/network/if-pre-up.d/wpasupplicant exited with return code 1
There is already a pid file /var/run/dhclient.eth1.pid with pid 5798864
Internet Systems Consortium DHCP Client V3.0.4
Copyright 2004-2006 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

Listening on LPF/eth1/00:90:4b:9a:0e:d6
Sending on LPF/eth1/00:90:4b:9a:0e:d6
Sending on Socket/fallback
DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 8
DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 13
DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 15
DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 12
DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 13
No DHCPOFFERS received.
No working leases in persistent database - sleeping.

I had a problem that looked similar (the bold text). The reason was spa_supplicant, that was for some strange reason run twice during the bootup process.
TRY killing the wpa_supplicant by

sudo killall wpa_supplicant
and then restarting the network

sudo /etc/init.d/networking restart

If this works for you,
you can try adding an init script that will kill the other annoying instance of wpa_supplicant prior the network is configured durign the bootup:

sudo gedit /etc/init.d/kill-wpa
insert there:

killall -w wpa_supplicant
save
and make executable:

sudo chmod +x /etc/init.d/kill-wpa
make it run during the startup prior to the network config:

sudo ln -s /etc/init.d/kill-wpa /etc/rcS.d/40kill-wpa

I m not sure if this is the right solution but it worked for me :)

wieman01
February 21st, 2007, 09:04 PM
I m not sure if this is the right solution but it worked for me :)
Interesting solution, buddy. Thanks for the post.

gejr
February 22nd, 2007, 07:00 PM
When I installed networkmanager and clicked on the nmapplet, all I get is a "Wired network", no way to configure anything wireless. I might've overseen something essential here. Anyone able to point me in the right direction?:)

ubuntu_demon
February 22nd, 2007, 07:20 PM
When I installed networkmanager and clicked on the nmapplet, all I get is a "Wired network", no way to configure anything wireless. I might've overseen something essential here. Anyone able to point me in the right direction?:)

You can't combine this howto with networkmanager. So you have to choose.

If you want to use networkmanager you have to remove your wireless interface from /etc/network/interfaces

Then :
$sudo /etc/init.d/networking restart

Then logout of gnome and login again

good luck!

gejr
February 22nd, 2007, 11:25 PM
Ah..thanks man! That was the helping sentence I've been looking for a long time. Network manager seems SO much better than the default ubuntu network-admin. I've been tired of being unable to use WPA and having to use iwconfig to find essid's for me. Now networkmanager works perfectly for my needs! Thanks again! :)

arpad3
February 23rd, 2007, 01:29 PM
Hi all,
Read your post..nearly understood all of it (I'm new to Linux)..followed the process and it worked well. But,just as a follow up for those who refer this post for wireless connectivity..there is a program 'netmanager' that can be loaded/installed. This program allows you connect networks without much hassel ...great for laptops...supports encriptions....you may need a hard wired connection to download a few files that are not on your pc. It can be found in the Synaptic Package Manager. Ubuntu 6.10 :)

SVWander
February 24th, 2007, 10:13 PM
I have read through all the pages and printed out the howto but I am still confuse and haven't gotten my wireless card to work in a secure environment. You have asked a number of people that question. Mine will work flawlessly without security settings. If seems you say that certain cards are not supported and I am wondering whether the Ralink RT2500 802.11g is one of those cards.

When restarting the network I get this:

im2@tim2-desktop:~$ sudo /etc/init.d/networking restart
Password:
* Reconfiguring network interfaces... There is already a pid file /var/run/dhclient.ra0.pid with pid 4917
killed old client process, removed PID file
Internet Systems Consortium DHCP Client V3.0.4
Copyright 2004-2006 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

Listening on LPF/ra0/00:11:09:07:f4:1f
Sending on LPF/ra0/00:11:09:07:f4:1f
Sending on Socket/fallback
DHCPRELEASE on ra0 to 10.95.0.1 port 67
send_packet: Network is unreachable
send_packet: please consult README file regarding broadcast address.
ioctl[SIOCSIWAUTH]: Operation not supported
WEXT auth param 7 value 0x1 - ioctl[SIOCSIWENCODEEXT]: Operation not supported
ioctl[SIOCSIWENCODEEXT]: Operation not supported
ioctl[SIOCSIWENCODEEXT]: Operation not supported
ioctl[SIOCSIWENCODEEXT]: Operation not supported
ioctl[SIOCSIWAUTH]: Operation not supported
WEXT auth param 4 value 0x0 - ioctl[SIOCSIWAUTH]: Operation not supported
WEXT auth param 5 value 0x1 - There is already a pid file /var/run/dhclient.ra0.pid with pid 134993416
Internet Systems Consortium DHCP Client V3.0.4
Copyright 2004-2006 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

Listening on LPF/ra0/00:11:09:07:f4:1f
Sending on LPF/ra0/00:11:09:07:f4:1f
Sending on Socket/fallback
DHCPDISCOVER on ra0 to 255.255.255.255 port 67 interval 8
DHCPDISCOVER on ra0 to 255.255.255.255 port 67 interval 8
DHCPDISCOVER on ra0 to 255.255.255.255 port 67 interval 14
DHCPDISCOVER on ra0 to 255.255.255.255 port 67 interval 18
DHCPDISCOVER on ra0 to 255.255.255.255 port 67 interval 13
No DHCPOFFERS received.
No working leases in persistent database - sleeping.

My network configuration is:

auto ra0
iface ra0 inet dhcp
wpa-driver wext
wpa-conf managed
wpa-ssid NETGEAR
wpa-ap-scan 1
wpa-proto WPA
wpa-pairwise TKIP
wpa-group TKIO
wpa-key-mgmt WPA-PSK
wpa-pks 095b7f325ed7003f53fad72f8399effa4c37e <my code>



#iface eth1 inet dhcp

#auto eth1

#iface ra0 inet dhcp
#wireless-essid cctexas

and if of any value (I believe in one post you said it wasn't) ifconfig yields this:

tim2@tim2-desktop:~$ ifconfig
lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:130 errors:0 dropped:0 overruns:0 frame:0
TX packets:130 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:8376 (8.1 KiB) TX bytes:8376 (8.1 KiB)

ra0 Link encap:Ethernet HWaddr 00:11:09:07:F4:1F
inet6 addr: fe80::211:9ff:fe07:f41f/64 Scope:Link
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:117 errors:0 dropped:0 overruns:0 frame:0
TX packets:538561 errors:576 dropped:576 overruns:0 carrier:0
collisions:125 txqueuelen:1000
RX bytes:42097 (41.1 KiB) TX bytes:24730395 (23.5 MiB)
Interrupt:11 Base address:0x8000

Any ideas on how I can get this card secured?

Thanks, Tim

frioux
February 25th, 2007, 08:30 AM
Hi!
I am trying to get this LEAP stuff going and I am not really having a lot of luck. I am supposed to be authenticating w/ LEAP (I'm trying to use my school's wireless.) Here is the info you asked for:

Linux FrewSchmidt2 2.6.17-11-386 #2 Thu Feb 1 19:50:13 UTC 2007 i686 GNU/Linux
eth0 Link encap:Ethernet HWaddr 00:11:D8:C9:0B:89
inet addr:10.255.31.59 Bcast:10.255.31.255 Mask:255.255.255.0
inet6 addr: fe80::211:d8ff:fec9:b89/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:188 errors:0 dropped:0 overruns:0 frame:0
TX packets:28 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:80987 (79.0 KiB) TX bytes:2812 (2.7 KiB)
Interrupt:217 Base address:0x6c00

eth1 Link encap:Ethernet HWaddr 00:12:F0:21:E6:85
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:83024 errors:0 dropped:0 overruns:0 frame:0
TX packets:6839 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
Interrupt:177 Base address:0x8000 Memory:fe8ff000-fe8fffff

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:399 errors:0 dropped:0 overruns:0 frame:0
TX packets:399 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:134427 (131.2 KiB) TX bytes:134427 (131.2 KiB)

sit0 Link encap:IPv6-in-IPv4
NOARP MTU:1480 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
10.255.31.0 0.0.0.0 255.255.255.0 U 0 0 0 eth0
0.0.0.0 10.255.31.1 0.0.0.0 UG 0 0 0 eth0
eth1 unassociated ESSID:"letnet"
Mode:Managed Channel=0 Access Point: Not-Associated
Bit Rate:0 kb/s Tx-Power=20 dBm Sensitivity=8/0
Retry limit:7 RTS thr:off Fragment thr:off
Power Management:off
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

eth0 Link encap:Ethernet HWaddr 00:11:D8:C9:0B:89
inet addr:10.255.31.59 Bcast:10.255.31.255 Mask:255.255.255.0
inet6 addr: fe80::211:d8ff:fec9:b89/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:346 errors:0 dropped:0 overruns:0 frame:0
TX packets:48 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:142573 (139.2 KiB) TX bytes:5503 (5.3 KiB)
Interrupt:217 Base address:0x6c00

eth1 Link encap:Ethernet HWaddr 00:12:F0:21:E6:85
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:86004 errors:0 dropped:0 overruns:0 frame:0
TX packets:7083 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
Interrupt:177 Base address:0x8000 Memory:fe8ff000-fe8fffff

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:405 errors:0 dropped:0 overruns:0 frame:0
TX packets:405 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:136251 (133.0 KiB) TX bytes:136251 (133.0 KiB)

Module Size Used by
rfcomm 38936 0
hidp 32000 2
l2cap 23300 10 rfcomm,hidp
bluetooth 48996 5 rfcomm,hidp,l2cap
ipv6 257632 19
i915 20608 2
drm 72468 3 i915
video 16644 0
tc1100_wmi 7428 0
sbs 15776 0
sony_acpi 5516 0
pcc_acpi 13184 0
i2c_ec 5376 1 sbs
i2c_core 22288 1 i2c_ec
hotkey 10660 0
dev_acpi 11140 0
button 7056 0
battery 10756 0
container 4736 0
ac 5892 0
asus_acpi 16792 0
dm_mod 60088 4
af_packet 21768 6
md_mod 78740 0
cpufreq_ondemand 6944 1
speedstep_centrino 8576 1
freq_table 4996 1 speedstep_centrino
sr_mod 17060 0
sbp2 23304 0
scsi_mod 141320 2 sr_mod,sbp2
parport_pc 36132 0
lp 11972 0
parport 37320 2 parport_pc,lp
pcmcia 38972 0
8139cp 22528 0
ipw2200 113476 0
joydev 10304 0
usbhid 42464 0
8139too 27136 0
mii 6016 2 8139cp,8139too
ieee80211 33608 1 ipw2200
ieee80211_crypt 6016 1 ieee80211
sdhci 18316 0
mmc_core 30232 1 sdhci
tsdev 8256 0
yenta_socket 27916 1
rsrc_nonstatic 14336 1 yenta_socket
pcmcia_core 42128 3 pcmcia,yenta_socket,rsrc_nonstatic
snd_hda_intel 18580 1
snd_hda_codec 163712 1 snd_hda_intel
snd_pcm_oss 46080 0
snd_mixer_oss 18560 1 snd_pcm_oss
snd_pcm 80520 3 snd_hda_intel,snd_hda_codec,snd_pcm_oss
snd_timer 23172 1 snd_pcm
snd 55428 8 snd_hda_intel,snd_hda_codec,snd_pcm_oss,snd_mixe
r_oss,snd_pcm,snd_timer
soundcore 9952 1 snd
snd_page_alloc 10504 2 snd_hda_intel,snd_pcm
evdev 10496 2
psmouse 40072 0
pcspkr 3072 0
serio_raw 7300 0
intel_agp 25116 1
agpgart 33456 3 drm,intel_agp
rtc 12596 0
ext3 138888 2
jbd 55700 1 ext3
ohci1394 35248 0
ieee1394 302904 2 sbp2,ohci1394
ehci_hcd 32520 0
uhci_hcd 23176 0
usbcore 130304 4 usbhid,ehci_hcd,uhci_hcd
ide_generic 1536 0
ide_cd 32416 0
cdrom 37792 2 sr_mod,ide_cd
ide_disk 17664 4
piix 10628 1
generic 5252 0
thermal 14600 0
processor 26028 2 speedstep_centrino,thermal
fan 5124 0
fbcon 40480 0
tileblit 2944 1 fbcon
font 8448 1 fbcon
bitblit 6272 1 fbcon
softcursor 2432 1 bitblit
vesafb 8348 0
capability 5000 0
commoncap 7808 1 capability
eth1 Scan completed :
Cell 01 - Address: 00:19:A9:CC:85:70
ESSID:"<hidden>"
Protocol:IEEE 802.11bg
Mode:Master
Channel:1
Encryption key:on
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 6 Mb/s; 9 Mb/s
11 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
48 Mb/s; 54 Mb/s
Quality=78/100 Signal level=-51 dBm
IE: WPA Version 1
Group Cipher : WEP-104
Pairwise Ciphers (1) : TKIP
Authentication Suites (1) : 802.1X
IE: IEEE 802.11i/WPA2 Version 1
Group Cipher : WEP-104
Pairwise Ciphers (1) : CCMP
Authentication Suites (1) : 802.1X
Extra: Last beacon: 248ms ago
Cell 02 - Address: 00:19:A9:CC:9A:00
ESSID:"<hidden>"
Protocol:IEEE 802.11bg
Mode:Master
Channel:6
Encryption key:on
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 6 Mb/s; 9 Mb/s
11 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
48 Mb/s; 54 Mb/s
Quality=67/100 Signal level=-60 dBm
IE: WPA Version 1
Group Cipher : WEP-104
Pairwise Ciphers (1) : TKIP
Authentication Suites (1) : 802.1X
IE: IEEE 802.11i/WPA2 Version 1
Group Cipher : WEP-104
Pairwise Ciphers (1) : CCMP
Authentication Suites (1) : 802.1X
Extra: Last beacon: 100ms ago
Cell 03 - Address: 00:19:A9:CC:7E:30
ESSID:"<hidden>"
Protocol:IEEE 802.11bg
Mode:Master
Channel:6
Encryption key:on
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 6 Mb/s; 9 Mb/s
11 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
48 Mb/s; 54 Mb/s
Quality=42/100 Signal level=-75 dBm
IE: WPA Version 1
Group Cipher : WEP-104
Pairwise Ciphers (1) : TKIP
Authentication Suites (1) : 802.1X
IE: IEEE 802.11i/WPA2 Version 1
Group Cipher : WEP-104
Pairwise Ciphers (1) : CCMP
Authentication Suites (1) : 802.1X
Extra: Last beacon: 124ms ago
Cell 04 - Address: 00:13:C3:05:DD:F0
ESSID:"<hidden>"
Protocol:IEEE 802.11bg
Mode:Master
Channel:9
Encryption key:on
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 6 Mb/s; 9 Mb/s
11 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
48 Mb/s; 54 Mb/s
Quality=37/100 Signal level=-78 dBm
Extra: Last beacon: 92ms ago
Cell 05 - Address: 00:19:A9:CC:92:70
ESSID:"<hidden>"
Protocol:IEEE 802.11bg
Mode:Master
Channel:11
Encryption key:on
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 6 Mb/s; 9 Mb/s
11 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
48 Mb/s; 54 Mb/s
Quality=90/100 Signal level=-39 dBm
IE: WPA Version 1
Group Cipher : WEP-104
Pairwise Ciphers (1) : TKIP
Authentication Suites (1) : 802.1X
IE: IEEE 802.11i/WPA2 Version 1
Group Cipher : WEP-104
Pairwise Ciphers (1) : CCMP
Authentication Suites (1) : 802.1X
Extra: Last beacon: 44ms ago
Cell 06 - Address: 96:4D:AB:E5:A4:1F
ESSID:"WLCM"
Protocol:IEEE 802.11b
Mode:Ad-Hoc
Channel:11
Encryption key:off
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s
Quality=29/100 Signal level=-82 dBm
Extra: Last beacon: 40ms ago
Cell 07 - Address: 00:19:A9:CC:81:C0
ESSID:"<hidden>"
Protocol:IEEE 802.11bg
Mode:Master
Channel:11
Encryption key:on
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 6 Mb/s; 9 Mb/s
11 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
48 Mb/s; 54 Mb/s
Quality=48/100 Signal level=-72 dBm
IE: WPA Version 1
Group Cipher : WEP-104
Pairwise Ciphers (1) : TKIP
Authentication Suites (1) : 802.1X
IE: IEEE 802.11i/WPA2 Version 1
Group Cipher : WEP-104
Pairwise Ciphers (1) : CCMP
Authentication Suites (1) : 802.1X
Extra: Last beacon: 40ms ago
Cell 08 - Address: 00:19:A9:CC:99:B0
ESSID:"<hidden>"
Protocol:IEEE 802.11bg
Mode:Master
Channel:1
Encryption key:on
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 6 Mb/s; 9 Mb/s
11 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
48 Mb/s; 54 Mb/s
Quality=20/100 Signal level=-86 dBm
IE: WPA Version 1
Group Cipher : WEP-104
Pairwise Ciphers (1) : TKIP
Authentication Suites (1) : 802.1X
IE: IEEE 802.11i/WPA2 Version 1
Group Cipher : WEP-104
Pairwise Ciphers (1) : CCMP
Authentication Suites (1) : 802.1X
Extra: Last beacon: 2500ms ago
Cell 09 - Address: 00:19:A9:CC:85:70
ESSID:"letnet"
Protocol:IEEE 802.11bg
Mode:Master
Channel:1
Encryption key:on
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 6 Mb/s; 9 Mb/s
11 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
48 Mb/s; 54 Mb/s
Quality=76/100 Signal level=-53 dBm
IE: WPA Version 1
Group Cipher : WEP-104
Pairwise Ciphers (1) : TKIP
Authentication Suites (1) : 802.1X
IE: IEEE 802.11i/WPA2 Version 1
Group Cipher : WEP-104
Pairwise Ciphers (1) : CCMP
Authentication Suites (1) : 802.1X
Extra: Last beacon: 640ms ago
Cell 10 - Address: 00:19:A9:CC:9A:00
ESSID:"letnet"
Protocol:IEEE 802.11bg
Mode:Master
Channel:6
Encryption key:on
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 6 Mb/s; 9 Mb/s
11 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
48 Mb/s; 54 Mb/s
Quality=68/100 Signal level=-59 dBm
IE: WPA Version 1
Group Cipher : WEP-104
Pairwise Ciphers (1) : TKIP
Authentication Suites (1) : 802.1X
IE: IEEE 802.11i/WPA2 Version 1
Group Cipher : WEP-104
Pairwise Ciphers (1) : CCMP
Authentication Suites (1) : 802.1X
Extra: Last beacon: 540ms ago
Cell 11 - Address: 00:19:A9:CC:92:70
ESSID:"letnet"
Protocol:IEEE 802.11bg
Mode:Master
Channel:11
Encryption key:on
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 6 Mb/s; 9 Mb/s
11 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
48 Mb/s; 54 Mb/s
Quality=90/100 Signal level=-39 dBm
IE: WPA Version 1
Group Cipher : WEP-104
Pairwise Ciphers (1) : TKIP
Authentication Suites (1) : 802.1X
IE: IEEE 802.11i/WPA2 Version 1
Group Cipher : WEP-104
Pairwise Ciphers (1) : CCMP
Authentication Suites (1) : 802.1X
Extra: Last beacon: 408ms ago
Cell 12 - Address: 00:19:A9:CC:7E:30
ESSID:"letnet"
Protocol:IEEE 802.11bg
Mode:Master
Channel:6
Encryption key:on
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 6 Mb/s; 9 Mb/s
11 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
48 Mb/s; 54 Mb/s
Quality=41/100 Signal level=-76 dBm
IE: WPA Version 1
Group Cipher : WEP-104
Pairwise Ciphers (1) : TKIP
Authentication Suites (1) : 802.1X
IE: IEEE 802.11i/WPA2 Version 1
Group Cipher : WEP-104
Pairwise Ciphers (1) : CCMP
Authentication Suites (1) : 802.1X
Extra: Last beacon: 7992ms ago
Cell 13 - Address: 00:19:A9:CC:81:C0
ESSID:"letnet"
Protocol:IEEE 802.11bg
Mode:Master
Channel:11
Encryption key:on
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 6 Mb/s; 9 Mb/s
11 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
48 Mb/s; 54 Mb/s
Quality=39/100 Signal level=-77 dBm
IE: WPA Version 1
Group Cipher : WEP-104
Pairwise Ciphers (1) : TKIP
Authentication Suites (1) : 802.1X
IE: IEEE 802.11i/WPA2 Version 1
Group Cipher : WEP-104
Pairwise Ciphers (1) : CCMP
Authentication Suites (1) : 802.1X
Extra: Last beacon: 404ms ago

auto lo
iface lo inet loopback

auto eth0
iface eth0 inet dhcp

auto eth1
iface eth1 inet dhcp
wpa-driver wext
wpa-conf managed
wpa-ssid letnet
wpa-ap-scan 2
wpa-eap LEAP
wpa-key-mgmt IEE8021X
wpa-identity FrewSchmidt
wpa-password ###########

search lgv1.dungeon.letnet.net
nameserver 10.0.2.6


Any help at all would be killer.

wieman01
February 25th, 2007, 09:08 AM
Any ideas on how I can get this card secured?

Thanks, Tim
I used to mention this in the thread... the Ralink driver that comes with Ubuntu is not quite suitable and - as far as I know - won't work with this approach. But you will find help here:

http://rt2x00.serialmonkey.com/wiki/index.php?title=Main_Page

I will update my thread accordingly.

wieman01
February 25th, 2007, 09:18 AM
Cell 13 - Address: 00:19:A9:CC:81:C0
ESSID:"letnet"
Protocol:IEEE 802.11bg
Mode:Master
Channel:11
Encryption key:on
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 6 Mb/s; 9 Mb/s
11 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
48 Mb/s; 54 Mb/s
Quality=39/100 Signal level=-77 dBm
IE: WPA Version 1
Group Cipher : WEP-104
Pairwise Ciphers (1) : TKIP
Authentication Suites (1) : 802.1X
IE: IEEE 802.11i/WPA2 Version 1
Group Cipher : WEP-104
Pairwise Ciphers (1) : CCMP
Authentication Suites (1) : 802.1X
Extra: Last beacon: 404ms ago
This is definitely LEAP, right? I'd try this:

auto eth1
iface eth1 inet dhcp
wpa-driver wext
wpa-conf managed
wpa-ssid letnet
wpa-ap-scan 2
wpa-pairwise TKIP CCMP
wpa-group WEP104
wpa-eap LEAP
wpa-key-mgmt IEE8021X
wpa-identity FrewSchmidt
wpa-password ###########

Does your wireless driver support LEAP?

frioux
February 26th, 2007, 05:57 AM
I tried with the

wpa-pairwise TKIP CCMP
wpa-group WEP104
lines and it didn't help. My driver supports LEAP I think. It's the ipw2200. Also, I think that entry 13 is a false entry as our network doesn't broadcast their ESSID (I think). And my signal strength should be really high since I am about 12 feet from one of the wireless APs. I really appreciate your help. It would be so cool to have wireless in linux.

wieman01
February 26th, 2007, 11:28 AM
I tried with the

wpa-pairwise TKIP CCMP
wpa-group WEP104
lines and it didn't help. My driver supports LEAP I think. It's the ipw2200. Also, I think that entry 13 is a false entry as our network doesn't broadcast their ESSID (I think). And my signal strength should be really high since I am about 12 feet from one of the wireless APs. I really appreciate your help. It would be so cool to have wireless in linux.
Perhaps try this as well:

auto eth1
iface eth1 inet dhcp
wpa-driver wext
wpa-conf managed
wpa-ssid letnet
wpa-ap-scan 1
wpa-pairwise TKIP CCMP
wpa-group WEP104
wpa-eap LEAP
wpa-key-mgmt IEE8021X
wpa-identity FrewSchmidt
wpa-password ###########
Could you post the output of this please (try both scripts):

sudo ifdown -v eth1

sudo ifup -v eth1
Let's see what's going on then...

LanikSJ
February 26th, 2007, 05:32 PM
Thank you to those who took the time to write the above guide, once I found it took me about 10 mins to get my wireless up and running.

:popcorn:

pleurastic
February 27th, 2007, 04:08 AM
Toshiba Satellite L25-S1195 with D-Link DWL-G630 (AR5005G 01)
XUBUNTU 2.6.17.11
Working!

/interfaces
# see http://www.ubuntuforums.org/showthread.php?t=202834
# and http://www.ubuntuforums.org/showthread.php?t=225290
auto lo
iface lo inet loopback


iface eth0 inet dhcp

auto eth1
iface eth1 inet dhcp

auto eth2
iface eth2 inet dhcp


auto ath0
iface ath0 inet dhcp
wpa-driver wext
wpa-conf managed
wpa-ssid <my ssid>
wpa-ap-scan 1
wpa-proto WPA
wpa-pairwise TKIP
wpa-group TKIP
wpa-key-mgmt WPA-PSK
wpa-psk <generated per message 1>
wireless-essid <my essid>

After reboot I had to go to Applications>System>Networking and reenter the Network name (ESSID)

It took 10 days of messin' about to find this info....30 minutes to get up and running.
Thank You All!

H.E. Pennypacker
March 1st, 2007, 06:26 PM
I have read through all the pages and printed out the howto but I am still confuse and haven't gotten my wireless card to work in a secure environment. You have asked a number of people that question. Mine will work flawlessly without security settings. If seems you say that certain cards are not supported and I am wondering whether the Ralink RT2500 802.11g is one of those cards.

My network configuration is:

auto ra0
iface ra0 inet dhcp
wpa-driver wext
wpa-conf managed
wpa-ssid NETGEAR
wpa-ap-scan 1
wpa-proto WPA
wpa-pairwise TKIP
wpa-group TKIO
wpa-key-mgmt WPA-PSK
wpa-pks 095b7f325ed7003f53fad72f8399effa4c37e <my code>

#iface eth1 inet dhcp
#auto eth1
#iface ra0 inet dhcp
#wireless-essid cctexas

and if of any value (I believe in one post you said it wasn't) ifconfig yields this:

Any ideas on how I can get this card secured?

Thanks, Tim

Bro, don't you realize the simple mistake you've made? It may not be your only problem, but you want to get rid of typos first.

The last uncommented line in /etc/network/interfaces should be "wpa-psk," not "wpa-pks." Please review your entire /etc/network/interfaces matches the one on the first page of this thread.

wieman01
March 2nd, 2007, 09:07 AM
Bro, don't you realize the simple mistake you've made? It may not be your only problem, but you want to get rid of typos first.

The last uncommented line in /etc/network/interfaces should be "wpa-psk," not "wpa-pks." Please review your entire /etc/network/interfaces matches the one on the first page of this thread.
You are right actually. Have not noticed the typos. Thanks, bro.

cr4z3d
March 3rd, 2007, 12:16 AM
I have a Netgear WG511, which seems to have a Prism Duette chip in it. I'm able to connect to any WEP and unsecured networks with no problems. Also I've been using Network Manager, since i'm pretty new to Linux. I followed the steps and changed things where they needed changing. This is what i get when i try restarting the network:


All the commands from "post if stumped"


cr4z3d@cr4z3d-laptop:~$ sudo /etc/init.d/networking restart
* Reconfiguring network interfaces... Ignoring unknown interface eth0=eth0.
There is already a pid file /var/run/dhclient.eth2.pid with pid 134993416
Internet Systems Consortium DHCP Client V3.0.4
Copyright 2004-2006 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

Listening on LPF/eth2/00:09:5b:45:28:f5
Sending on LPF/eth2/00:09:5b:45:28:f5
Sending on Socket/fallback
DHCPRELEASE on eth2 to 192.168.1.1 port 67
send_packet: Network is unreachable
send_packet: please consult README file regarding broadcast address.
ioctl[SIOCSIWAUTH]: Operation not supported
WEXT auth param 7 value 0x1 - ioctl[SIOCSIWENCODEEXT]: Operation not supported
ioctl[SIOCSIWENCODEEXT]: Operation not supported
ioctl[SIOCSIWENCODEEXT]: Operation not supported
ioctl[SIOCSIWENCODEEXT]: Operation not supported
ioctl[SIOCSIWAUTH]: Operation not supported
WEXT auth param 4 value 0x0 - ioctl[SIOCSIWAUTH]: Operation not supported
WEXT auth param 5 value 0x1 - There is already a pid file /var/run/dhclient.eth2.pid with pid 134993416
Internet Systems Consortium DHCP Client V3.0.4
Copyright 2004-2006 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

Listening on LPF/eth2/00:09:5b:45:28:f5
Sending on LPF/eth2/00:09:5b:45:28:f5
Sending on Socket/fallback
DHCPDISCOVER on eth2 to 255.255.255.255 port 67 interval 8
DHCPDISCOVER on eth2 to 255.255.255.255 port 67 interval 11
DHCPOFFER from 192.168.1.1
DHCPREQUEST on eth2 to 255.255.255.255 port 67
DHCPACK from 192.168.1.1
bound to 192.168.1.109 -- renewal in 37296 seconds.
[ ok ]


cr4z3d@cr4z3d-laptop:~$ uname -a
Linux cr4z3d-laptop 2.6.17-11-generic #2 SMP Thu Feb 1 19:52:28 UTC 2007 i686 GNU/Linux
cr4z3d@cr4z3d-laptop:~$ ifconfig -a
eth0 Link encap:Ethernet HWaddr 00:0B:CD:33:A6:A6
BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
Interrupt:11 Base address:0x8000

eth2 Link encap:Ethernet HWaddr 00:09:5B:45:28:F5
inet addr:192.168.1.109 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: fe80::209:5bff:fe45:28f5/64 Scope:Link
UP BROADCAST MULTICAST MTU:1492 Metric:1
RX packets:1943 errors:0 dropped:0 overruns:0 frame:0
TX packets:1651 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:1362694 (1.2 MiB) TX bytes:238610 (233.0 KiB)
Interrupt:5

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:6 errors:0 dropped:0 overruns:0 frame:0
TX packets:6 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:300 (300.0 b) TX bytes:300 (300.0 b)

sit0 Link encap:IPv6-in-IPv4
NOARP MTU:1480 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)



cr4z3d@cr4z3d-laptop:~$ route -n
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
192.168.1.0 0.0.0.0 255.255.255.0 U 0 0 0 eth2
0.0.0.0 192.168.1.1 0.0.0.0 UG 0 0 0 eth2


cr4z3d@cr4z3d-laptop:~$ iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

eth2 IEEE 802.11b/g ESSID:"linksys"
Mode:Managed Frequency:2.437 GHz Access Point: 00:0F:66:83:AE:DE
Bit Rate:54 Mb/s Tx-Power=31 dBm Sensitivity=20/200
Retry min limit:8 RTS thr:2347 B Fragment thr:2346 B
Link Quality:181/0 Signal level:-56 dBm Noise level:-3 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

sit0 no wireless extensions.



cr4z3d@cr4z3d-laptop:~$ ifconfig
eth2 Link encap:Ethernet HWaddr 00:09:5B:45:28:F5
inet addr:192.168.1.109 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: fe80::209:5bff:fe45:28f5/64 Scope:Link
UP BROADCAST MULTICAST MTU:1492 Metric:1
RX packets:1955 errors:0 dropped:0 overruns:0 frame:0
TX packets:1653 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:1366240 (1.3 MiB) TX bytes:238762 (233.1 KiB)
Interrupt:5

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:6 errors:0 dropped:0 overruns:0 frame:0
TX packets:6 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:300 (300.0 b) TX bytes:300 (300.0 b)



cr4z3d@cr4z3d-laptop:~$ cat /etc/network/interfaces
auto lo
iface lo inet loopback

#auto eth0
#iface eth0 inet dhcp

#auto eth1
#iface eth1 inet dhcp

auto eth2
iface eth2 inet dhcp
wpa-driver wext
wpa-conf managed
wpa-ssid 2041 Red Light Room
wpa-ap-scan 1
wpa-proto WPA
wpa-pairwise TKIP
wpa-group TKIP
wpa-key-mgmt WPA-PSK
wpa-psk 8944ef49f8f357d014d060a07b855c5db6b519ad911f73d866 91a130dfb42a03

#auto ath0
#iface ath0 inet dhcp

#auto wlan0
#iface wlan0 inet dhcp


cr4z3d@cr4z3d-laptop:~$ cat /etc/modprobe.d/ndiswrapper
cat: /etc/modprobe.d/ndiswrapper: No such file or directory


cr4z3d@cr4z3d-laptop:~$ cat /etc/resolv.conf
search ph.cox.net
nameserver 68.2.16.30
nameserver 68.2.16.25
nameserver 68.6.16.30


EDIT: noticed some pasting issues, fixed them

wieman01
March 4th, 2007, 04:35 PM
Try "hostap" instead of "wext" (wpa-driver). Any better now?

cr4z3d
March 4th, 2007, 07:19 PM
I got it working using ndiswrapper and networkmanager. That worked fine and seems a little more stable.

wieman01
March 5th, 2007, 09:01 AM
I got it working using ndiswrapper and networkmanager. That worked fine and seems a little more stable.
NetworkManager is certainly the best option if you don't need a static IP address.

gatoruss
March 6th, 2007, 05:18 AM
[Note: You may have to choose a boot sequence other than S40.]



How do I know what "boot sequence" to choose?

Apperture
March 6th, 2007, 08:11 AM
This howto helped me a lot for making 1 connection.
But I have multiple Access Points to connect to (one home, one work, one at customer)
I can not find a good manual that explains how to configure more then one access point.
Can somebody help me with that? And maybe not a bad Idea to stick it to this howto.

Casla
March 6th, 2007, 08:23 AM
Hey wieman01, just want to say thanks for the brilliant HowTo. I v been working on setting up my wifi for ages, your guide cleared out lot of confusions i had, including not knowing that the PSK hex key is generated from wpa_passphrase. :)

I had a bit of trouble just after following your guide, for some reason "Networking restart" is not picking up the lines i added for the wifi interface (eth1 in my case). I went around a big circle reading heaps "info" of dhclient, wpa_supplicant, etc. But in the end, I got it working by removing all other lines in the "/etc/network/interface" file, just leave the wifi (eth1) lines. So if anyone else running to that problem may want try that.

Again, thanks for the guide, and good luck every1.

wieman01
March 6th, 2007, 09:00 AM
How do I know what "boot sequence" to choose?
You'd best choose S40. I guess this will do for you (it did the trick for me).

wieman01
March 6th, 2007, 09:02 AM
This howto helped me a lot for making 1 connection.
But I have multiple Access Points to connect to (one home, one work, one at customer)
I can not find a good manual that explains how to configure more then one access point.
Can somebody help me with that? And maybe not a bad Idea to stick it to this howto.
This HOWTO won't help you I am afraid. You need to go for Network-Manager for instance.

wieman01
March 6th, 2007, 09:04 AM
Hey wieman01, just want to say thanks for the brilliant HowTo. I v been working on setting up my wifi for ages, your guide cleared out lot of confusions i had, including not knowing that the PSK hex key is generated from wpa_passphrase. :)

I had a bit of trouble just after following your guide, for some reason "Networking restart" is not picking up the lines i added for the wifi interface (eth1 in my case). I went around a big circle reading heaps "info" of dhclient, wpa_supplicant, etc. But in the end, I got it working by removing all other lines in the "/etc/network/interface" file, just leave the wifi (eth1) lines. So if anyone else running to that problem may want try that.

Again, thanks for the guide, and good luck every1.
One thing that is important when trying to connect through wireless: You must unplug your Ethernet cable by all means. Not sure if that was your problem, but I am glad you solved it. Thanks for the note.

acconrad
March 7th, 2007, 08:07 AM
I was wondering if someone could tell me whether I will be able to connect to my campus' secure network. I'm currently connected via the open wireless network, but with the secure one it requires some software to install:

https://wiki.brown.edu/confluence/display/CISDOC/Wireless+-+Connecting+to+the+Brown-Secure+Wireless+Network+with+Windows

There it says you need to download this software because our secure network is WPA1/TKIP/EAP, and it requires the SecureW2 client software from Alfa and Ariss Network Solutions. I found that it's a Windows-only program which I guess I could run through Wine, but I don't see how that's going to help me with connecting to the network. Anyway so I did more perusing and I found this one for Mac

https://wiki.brown.edu/confluence/display/CISDOC/Wireless+-+Connecting+to+the+Brown-Secure+Wireless+Network+with+a+Mac

and that talks about 802.1X which my iwlist scan returns when I look at the secure network.

Anyone have any ideas how I would go about connecting to this network?