PDA

View Full Version : Alsa mixer capture feature always muted



smoczyna
July 10th, 2012, 08:13 PM
Hi

I've recently upgraded my ubuntu server to the latest 12.04 version. Almost everything is fine but experiencing few painful issues. Namely my alsa mixer shows capture features always muted, or rather turn down completely after restart. Each time I have turn up the volume to be able to use skype.
How can I set the volume of the capture input for good?

jmfal
July 10th, 2012, 10:38 PM
Welcome to Ubuntu.

I'm pretty sure that capture is muted at startup by default.

I tried looking for a work-around or script to add, but .........

smoczyna
July 10th, 2012, 11:29 PM
My previous version 10.04 LTS was fine about that so there is probably a file containing this settings. Or we've got a step back here. For instance playback is alway on the level of volume I set last time.

Besides what would be the reason to mute anything by default.

jmfal
July 10th, 2012, 11:37 PM
Capture is line input and there is for the most part no incoming sound at startup

I can't help thats the way it is .
I can turn up my mic and line in and restart and both will be muted at restart

flemur13013
July 11th, 2012, 03:17 AM
You might be able add "amixer" to a startup/login script:

Try:
$ amixer scontrols
$ amixer --help

-->
$ amixer sset Capture 100

I'm not sure about the "100" value.

beterhans
July 11th, 2012, 02:14 PM
open a command windows

use alsamixer to adjust your settings
and use


sudo alsactl store

smoczyna
July 23rd, 2012, 09:34 PM
and what is the location of the file where those settings are being saved by the ALSACTL command ? It is still not working although it looks like settings are being saved, I've got no error and any other feedback.

dda
February 12th, 2013, 02:31 PM
open a command windows

use alsamixer to adjust your settings
and use


sudo alsactl store


Thank you, that helped me too.