View Full Version : [ubuntu] Need Help With Path in Terminal

July 8th, 2012, 02:28 AM
I am not exactly a beginner but it's been awhile since I tried to anything technical in Ubuntu and I am forced to use a Windoze computer at work. I have forgotten how to write paths properly and Googling hasn't been any help. I need to install subsonic again and the directions on the site said do this:

Download (http://www.subsonic.org/pages/download.jsp) the Subsonic .deb package and install it: sudo dpkg -i subsonic-x.x.deb

I wrote to the app developer for help when I typed the above into the terminal and got this:

$ sudo dpkg -i subsonic-x.x.deb
dpkg: error processing subsonic-x.x.deb (--install):
cannot access archive: No such file or directory
Errors were encountered while processing:

He said Please replace "subsonic-x.x.deb" with the full path of the file you downloaded.

The file is here:


What exactly should I type because what I typed didn't work. I know I have typed the path/command wrong somehow.

July 8th, 2012, 02:37 AM
sudo dpkg -i /home/windyridge/Desktop/Downloads/subsonic-4.6.deb

When the dev said subsonic-x.x.deb the "x's" refer to the version number of file. In this case 4.6.

When you literally put in the command:
sudo dpkg -i subsonic-x.x.deb
It could not find the file because no file of that name exits.

As a shortcut, you can substitute the tilde key"~" for the /home/windyridge part so another way to type the command would be:

sudo dpkg -i ~/Desktop/Downloads/subsonic-4.6.deb

Hope this helps :popcorn:


You realize you can also just double click the subsonic-4.6.deb file and it will run the installer for you graphically. It will prompt you for your sudo password before installing anything.

July 8th, 2012, 02:42 AM
Yes it worked, thansk so much! And thanks for the very quick response!):P

July 8th, 2012, 02:56 AM
You're welcome....

July 10th, 2012, 11:12 PM
Well eveything worked and then stopped. All of a sudden my Subsonic server stopped working and wouldn't even load. The router port and IP's all are fine. I changed nothing. I decided to reinstall the server and then got this error.


is this the program or Ubuntu? Basically subsonic streams all my music to my android phone. The server stopped working and now nothing. :(

July 11th, 2012, 02:43 AM
Better error printout:

eption java.lang.OutOfMemoryError Message Java heap space Java version Sun Microsystems Inc. 1.6.0_24 Operating system Linux 3.2.0-26-generic-pae Server jetty-6.1.x Memory Used 96 of 96 MB Stack trace java.lang.OutOfMemoryError: Java heap space

July 11th, 2012, 03:15 AM
How do I uninstall this program? I think that's what I need to do.

July 11th, 2012, 03:37 AM
sudo dpkg -r subsonic


sudo dpkg -r subsonic-4.6

July 11th, 2012, 04:08 AM
Thanks. I think a Java update may have broken it. Is there a way to roll back to a previous Java? I have 12.04 LTS.

July 11th, 2012, 06:00 PM
This is apparently a known issue. Take a look here for clues to add memory to java: