View Full Version : [ubuntu] Grub change

July 5th, 2012, 03:11 PM
I installed ubuntu. With the start up i need to change the graphic settings to nomodset. Changedthis with the editor and saved succesfully. But the updat grub does not work i get no reaction and no change from the system. Changing the config file leaves me with no rights to change.

Any sugestions please?


July 5th, 2012, 03:24 PM
The changes needed are explained in the section headed
"How to permanently set kernel boot options on an installed OS (not wubi)"
in this thread
You could first check your changes.

It may also be possible to install an extra video card driver by running Additional Drivers. This might mean that the nomodeset option is no longer needed. Have you tried that?

July 5th, 2012, 04:33 PM
Thanks for the reply, but i have tried al the possibilities decribed in the forums but no result. The problem is I am on a yacht and have no cable and wireless is not working. So loading any drivers is at this moment not an option. May be my HP Pavilion dv7 is to new? I can see the changes in the file I but the update doesnt work.

July 5th, 2012, 04:45 PM
A few questions:

Are you trying to add the "nomodeset" option to the "linux" line of a Grub menuentry?

Are you editing /boot/grub/grub.cfg (the menu) or the settings file (/etc/default/grub)? If you edit the grub menu itself and then run "update-grub" it is going to remove the changes you made.

At the GRUB menu, until you get this resolved, you can highlight the menu item you wish, press 'e' to edit it, and cursor to the end on the 'linux' line. Backspace to remove 'quiet splash' and the 'vt...' entry and add nomodeset. Then ctrl-x or F10 to boot. Perhaps that is what you are already doing.

July 5th, 2012, 05:09 PM
I have changed this file /etc/default/grub and I can see the changes after saving and opening again. Then I run the sudo update-grub and nothing happens. At the start up I edit the start command with adding nomodeset to the line otherwise my screen does not work. ( as you already expected). I need the pc for running my navigation program. My old pc died two weeks ago. I a am not yet planning to go home.

July 5th, 2012, 05:11 PM
Did you save the file after edit?
Can you post the contents of the /etc/default/grub file here please?
Preferably in code tags (in New Reply click the # symbol and paste in between the two).

July 5th, 2012, 05:24 PM
Yes I saved the file and when opening again I can see the changes but they dont show in the opening screen at start up. I am working in windows now because i can not communicate in ubuntu yet so I cannot copy anything from there. sorry!

July 5th, 2012, 06:01 PM
I found a way to work around. hope this is what you want?

# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
# info -f grub -n 'Simple configuration'
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset"
# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
# Uncomment to disable graphical terminal (grub-pc only)
# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
# Uncomment to disable generation of recovery mode menu entries
# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"

July 5th, 2012, 06:56 PM
When you run update-grub and say "nothing happens" does it appear to run in the terminal (i.e. do you see "found..." , etc) or is the terminal blank?

If nothing seems to happen, perhaps you have removed the executible flag from the GRUB scripts in the /etc/grub.d folder. You can restore them with;

sudo chmod +x /etc/grub.d/*
sudo update-grub

Another possibility might be competing GRUBs. Do you have more than one OS with GRUB on it? If that is the case, the other OS might be controlling the boot and using its own files.

Can you use "sudo" with other commands without problems?

You could also try this to make sure your grub file is updated. This is what the "update-grub" command is supposed to do:

sudo grub-mkconfig -o /boot/grub/grub.cfg
This command will force it to write the output to /boot/grub/grub.cfg

July 5th, 2012, 07:18 PM
Drs305 ,sorry but none of the commands have any effect. I leave it for now and wait until I can put a network cable in the HP.

Thanks for the effort.