View Full Version : [ubuntu] Unable to install or remove anything- dependency problem

July 2nd, 2012, 10:40 AM
Here is the problem:

pedja@pedja-desktop:~$ sudo apt-get -f install
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following extra packages will be installed:
The following packages will be upgraded:
1 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
1 not fully installed or removed.
Need to get 0 B/5883 kB of archives.
After this operation, 1863 kB disk space will be freed.
Do you want to continue [Y/n]? y
dpkg: dependency problems prevent configuration of fglrx-amdcccle:
fglrx-amdcccle depends on xorg-driver-fglrx; however:
Package xorg-driver-fglrx is not installed.
dpkg: error processing fglrx-amdcccle (--configure):
dependency problems - leaving unconfigured
No apport report written because the error message indicates its a followup error from a previous failure.
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

I have tryed everything i can think of

sudo apt-get update
sudo apt-get upgrade
sudo apt-get -f install
sudo apt-get -f remove
Nothing helps
And also this error appears whenever i try to install or remove any program, and when using Synaptic Package Manager or Ubuntu Software Center

Please hel, i dont want to reinstall whole system

July 2nd, 2012, 11:06 AM
maybe try

sudo apt-get install xorg-driver-fglrx

July 2nd, 2012, 11:32 AM
maybe try

sudo apt-get install xorg-driver-fglrx

it tells me that xorg-driver-fglrx doesn't have installation candidates and to try fglrx-updates xorg (or something like that, not at home right now, can't check exactly what)
but when I try that same error as in first post

July 2nd, 2012, 11:34 AM
sudo aptitude reinstall fglrx-amdcccle

July 2nd, 2012, 11:35 AM
sudo aptitude reinstall fglrx-amdcccle

will try when I get home

July 2nd, 2012, 11:37 AM
may also be worth checking you have enabled proprietary drivers,

a quick google can guide you on that

July 2nd, 2012, 12:35 PM
Run this in a terminal:

sudo dpkg --configure -a

And try to update/upgrade.

July 2nd, 2012, 12:45 PM
As you've had a previous failed install "sudo apt-get purge fglrx-amdcccle" may be worth trying as a preliminary.

July 3rd, 2012, 01:32 PM
sudo aptitude reinstall fglrx-amdcccle

this worked, thanks