View Full Version : [SOLVED] 12.04 installation is a failure - NVidia GeForce 6100

July 1st, 2012, 08:58 PM
Is there a definitive guide somewhere with the steps to get the 12.04 version working with the NVidia GeForce 6100?

I have spent countless hours on this installation and now I have a system that will not even boot to the logon screen.

I have been doing apt-get stuff and following six articles on the web which told me to do conflicting things.

The open source drivers are unstable on my system. I am using at 64-bit version of Ubuntu.

The last thing I did was using the recovery CD I installed nvidia-current. It said there were problems processing the package.

"Sub-process /user/bin/dpkg returned an error code"


July 1st, 2012, 09:17 PM
For many nvidia cards you need the nomodeset parameter to boot, as explained here:

But if you suspect you installed a wrong driver, I guess it's better to remove that driver and try again. Not sure, I don't use nvidia myself.

July 1st, 2012, 11:37 PM
Thank you, but that did not help. I am reinstalling now.

July 2nd, 2012, 12:10 AM
Right now it is doing the step "restoring previously installed packages" which is good but I am waiting forever so I am typing on my smartphone. I am hoping this will allow me to enable the Nvidia driver and get into Gnome classic with no effects. If this does not work I will try the detailed instructions on the Nvidia web site.

If that does not work I will install Windows 7. Two days is my limit for a simple OS install.

July 2nd, 2012, 12:29 AM
I am now typing from my Vista machine.

I was reading the instructions on the Nvidia web site for my driver in case I have to go this route.

When the installer is run, it will check your system for the required kernel sources and compile the kernel interface. You must have the source code for your kernel installed for compilation to work. On most systems, this means that you will need to locate and install the correct kernel-source, kernel-headers, or kernel-devel package; on some distributions, no additional packages are required.

Does anyone happen to know if these things are included in the standard 12.04 installation?

July 2nd, 2012, 02:59 AM
If your still having problems PB check out this link:


I was having problems and added the ppa, installed the driver--good to go..

If you decide to add this open the Update Center and make sure that that there are checks in the boxes for the ppa in "other software" tab.

July 2nd, 2012, 05:51 AM
Thank you for trying to help but I did that yesterday and it did not help.

I tried installing nvidia-current and bumblebee and then deleted those and installed the open source drivers, that did not work. Then I could not install the built-in nvidia drivers because I was getting the error I put in my original post.

Then I installed 12.04 on top of itself and started all over with the proprietary drivers with Unity and Gnome and Gnome Classic and Gnome Classic no effects.

I just tried to install the driver from NVidia using their instructions but that did not work. It wants me to set something so an environment variable points to some kernel source. I have no idea.

I have been using Ubuntu since Fiesty Fawn back in 2007 and it has been a great ride but I guess all good things must come to an end.

Tomorrow I will format the hard drives and install Microsoft Windows. I cannot afford to spend days installing an OS. As I have said many times before, life is too short to spend days doing something that should take one hour.

The funny thing is, in the middle of this I discovered the Onieric live CD does not work with the GeForce 6150 either. This means the Ubuntu developers and Nvidia knew about this for over six months and it was not fixed.

I know that no one from Canonical ever looks at this forum because they don't care about the opinions of their users but this seems very sad to me.

July 2nd, 2012, 05:16 PM
Hi!, pbpersson,

You do not seem to have got an answer to your query about what is needed to install the nvidia downloaded driver.

If you still want to do so, the following is an excerpt from Post #280 - Page 75- of MAFoElffen's magnum opus:

Solution Step I
Possible problem may be that the nvidia package you are using through
ubuntu is not building correctly for "your" Linux kernel.

Please Print These Instructions

1.) First we'll do some cleanup, prep and make sure everything is there
or any dependencies.
sudo apt-get update
sudo apt-get install build-essential gcc-4.5 g++-4.5 libxi-dev libxmu-dev freeglut3-dev
sudo apt-get install linux-headers-'uname -r'
sudo nvidia-installer --uninstall
sudo apt-get remove --purge nvidia-* You may get some file not found messages on the 4th or 5th command.
That is okay. continue. We just want to make sure that older modules are
removed or not there so that they don't cause a conflict.

2.) Next we want to check and update our blacklist to make sure any
files and modules that we know of can cause conflicts are in there.
sudo gedit /etc/modprobe.d/blacklist.conf We want to make sure they have these lines...
Some of these wouldn't be on a fresh install but would be a problem
if it was updated from a previous version. Add these lines and save:
blacklist vga16fb
blacklist rivafb
blacklist rivatv
blacklist nouveau
blacklist lbm-nouveau
blacklist nvidiafb
blacklist nvidia-173
blacklist nvidia-96 The important part an a fresh install, is that nvidia and nouveou do not
like each other!!! They cannot coexist. The nvidia-X listed above would
be if you were going with whatever was current for a Geforce 6100 and
above nvidia card.
You could remove the nvidia-173 or nvidia-96 lines if you [are] using those
drivers. The top 6 in the list above should be there.

4.) Download Newest Nvidia drivers from here:
Please write down the filename and where you saved it to.

5.). To install these drivers, Xorg cannot be running. You need to shut
down the X-Session. You can either do this by going to a terminal session,

sudo service lightdm stop If you are using natty or earlier shut down GDM:
sudo service gdm stopIf that did not work, then another way is to reboot into a TTY Text Console:
Temporarily Booting Into a TTY Text Console (http://ubuntuforums.org/showpost.php?p=11383888&postcount=715)

6.) Login and change directory to the directory where you saved your file.
(Remember you wrote that down in step 4.)

7.) Mark the downloaded file as executable.
sudo chmod a+x NVIDIA-Linux-x86-270.41.19.run You may have to substitute the name of the "runfile" filename to the one
that you downloaded for your card. (Remember you wrote that down.)
The command above will mark this file as executable.

8.) Install drivers:
sh NVIDIA-Linux-x86-270.41.19.run You may have to substitute the name of the "runfile" filename to the one
that you downloaded for your card. (Remember you wrote that down...)
This will install and run the nvidia-installer.
You have to have a working Internet connection to run this installer.
{Edit: You may get a 'script failed' message, choose to continue. bogan}
9.) Some versions of the installer miss this step (configure X), if it did
skip it then
sudo nvidia-xconfig 9.) Start GDM or LightDM according to your version of Ubuntu. Example:
sudo service gdm start Or reboot.
Hopefully it will now load. At least if you did all this, we are pretty
sure that the correct current drivers are built for your current linux kernel. NB. The line:
sudo apt-get install linux-headers-'uname -r' # means:
# insert the output from running 'uname -r'. eg:
apt-get install linux-headers-!, bogan.

July 2nd, 2012, 08:48 PM
WOW! Those instructions are awesome! :) If I don't need them I know there are other people who do as I have seen many people in different forums with this same issue.

I was going to get Windows 7 Ultimate for 50% off but that deal fell through.

So I have now instead ordered a new video card that has a 5.0 rating on the Ubuntu Hardware compatiblity list and the reviews said it worked perfectly with 12.04. It costs $30 but there is a $15 rebate so if it works the price is right.

I will provide an update as to how this all turns out.


July 3rd, 2012, 04:59 AM
The card that I purchased is the EVGA GeoForce 8400 GS for $30. It goes in a PCI Express 16x slot. I booted up Ubuntu 12.04 and so far everything is working perfectly - even Unity! :guitar:

July 3rd, 2012, 05:42 PM
Thank you everyone for your help. I am marking this as solved. Now I am going through Ubuntu and fixing all the other little things that are wrong. I just discovered that Ubuntu-Restricted-Extras was not installed, I fixed the problem with Chromium always saying my Flash plug-in is out of date, and now I am looking at why Ubuntu keeps switching my keyboard to Irish.

One note on that $30 video card. The package says "do not install this card unless you have at least a 350 watt power supply that will provide at least 18A on the +12v rail". I did some research on the web and someone who has the card and measured the usage said the 18A was.....well, maybe if you are using super-duper games you might need that much. They said in monitoring the +12v rail it NEVER used that much. I have a 500 watt power supply in here that will supply a maximum of 17A on the +12v supply and it has been working perfectly. \\:D/=D>

If I was one who liked tinkering with the innards of the OS I might have decided to spend hours or days getting the GeForce 6100 working but I just don't have time. Getting this $30 card ($15 after the rebate) fixed the problem in a few minutes. I feel like I am cheating but it is my standard method of operation. :wink: