View Full Version : [SOLVED] Multisystem Shell Script Gives Syntax Errors..it worked 2 days ago?

June 29th, 2012, 11:34 AM
I searched all over the internets and could not find a solution to my problem. I have used Kubuntu for the last year or so and decided to give regular Ubuntu a try, so I loaded up my trusty MultiSystem (Which I Love) loaded Ubuntu on and began the installation via my USB stick.

Once I got Ubuntu running I had an issue with the system coming back after suspend, which is something I'm working on getting fixed. Anyway, I decided to go back to Kubuntu and load up Windows for an alternate.

So on Ubuntu I downloaded the shell script for Multisystem, and just like always I ran "sh install-depot-multisystem.sh" and of course it installed and I was able to move along just fine.

Well here I am with the exact same Ubuntu ISO, I cannot get install-depot-multisystem.sh to install. I keep getting this syntax error "Syntax error:redirection unexpected" and I have no clue how to even begin troubleshoting because I know the script works perfectly fine.

The other frustrating part is I am literally following the exact same steps and getting a different outcome, I'm not sure how this is possible. Maybe the Linux God's hate me, I know it is usually operator error but I cannot figure for the life of me what to do different; this has always just worked.

Please help Multisystem is a complete neccessity. :confused:

June 29th, 2012, 12:33 PM
Just to append to this a bit


I needed to do a chmod 777 on the script, I'm still getting a syntax error on Kubuntu...but it did install successfully. I'll mark this as resovled!

Thanks anyway, I'll try to spruse up on my Linux skills.