View Full Version : Discussion - https://help.ubuntu.com/community/GizmodIn11.10and12.04

June 29th, 2012, 09:54 AM
Please use this thread for discussion regarding


Support threads should be posted in normal forums.

Thank you.

September 8th, 2012, 04:25 PM
After following these instructions, I get this error during the compile:

/home/will/Downloads/gizmod-3.5/libGizmod/Processes.cpp: In static member function ‘static void Gizmod::Processes::updateProcessTree()’:
/home/will/Downloads/gizmod-3.5/libGizmod/Processes.cpp:157:27: error: expected unqualified-id before ‘;’ token
make[2]: *** [libGizmod/CMakeFiles/Gizmod.dir/Processes.o] Error 1
make[1]: *** [libGizmod/CMakeFiles/Gizmod.dir/all] Error 2
make: *** [all] Error 2

I did some Googling of the error, but unfortunately the last programming I've ever done was in Applesoft BASIC, so I'm at a bit of a loss to solve this. I know that this line in this file is one of the lines the instructions have us change, and I went back to make sure I copy-pasted everything perfectly, but I still get this error. Any ideas? I'm running 12.04 (with the 3.5 kernel branch, if that makes a difference).

edit: I get the same error even when I revert the line back to the original line (so that it's identical to a freshly-downloaded copy).

December 26th, 2012, 09:22 AM
I got gizmod working in 12.10 - had the same "expected unqualified-id before ‘;’ token" error. I fixed that by changing all the lines suggested on the wiki page, but wherever it said to change the line to 'iter->;path().string() + "\"', I deleted the semicolon, so it read 'iter->path().string() + "\"'

I had to make the changes suggested in the "Excessive CPU Usage" section too, since otherwise it consumed 100% of one CPU all the time.

Also, follow the instructions here:

...don't forget the colon in the MODE setting - eg: 'MODE:="660"'

June 23rd, 2013, 01:53 AM

i think i followed exactly this documentation :

but when i run make i get this error :

[ 88%] Building CXX object gizmod/CMakeFiles/gizmod.dir/GizmoDaemon.o
/home/krodelabestiole/Téléchargements/gizmod-3.5/gizmod/GizmoDaemon.cpp: In member function ‘void GizmoDaemon::initPython()’:
/home/krodelabestiole/Téléchargements/gizmod-3.5/gizmod/GizmoDaemon.cpp:1332:51: erreur: ‘initGizmoDaemon’ was not declared in this scope
make[2]: *** [gizmod/CMakeFiles/gizmod.dir/GizmoDaemon.o] Erreur 1
make[1]: *** [gizmod/CMakeFiles/gizmod.dir/all] Erreur 2
make: *** [all] Erreur 2
i found absolutely no information about this error anywhere

line 1332 looks like this :

void GizmoDaemon::initPython() {
try {
cdbg1 << "Embedding Python Interpreter..." << endl;
PyImport_AppendInittab((char *) "GizmoDaemon", &initGizmoDaemon);
what do you think ? have i forget to install any dependency or should i edit the source code ?

June 23rd, 2013, 03:04 AM
ok i found the issue

cmake was using python3.2 instead of python2.7