View Full Version : [ubuntu] 12.04 Fresh Install to RAID1 Mirror Fail

June 28th, 2012, 09:19 PM
System: Dell Precision T7400
Dual Xeon procs @ 3.2Ghz
Onboard 4x1TB SATA RAID5 volume

Completed installation of Ubuntu 12.04 server failed to install boot loader on SATA-1 or SATA-2

System will not boot; redo.

Followed instructions for Ubuntu 12.04 Installation -> Advanced Installation -> Software RAID (https://help.ubuntu.com/12.04/serverguide/advanced-installation.html) (mirrored both 80GB hard drives).

This produced same result, "'grub-pc' package failed to install into /target/"

Booted to recovery mode; ran the shell on /dev/md1 mounted as / ... what must done to install grub? :-|

June 28th, 2012, 09:45 PM
1. Where is your root partition, on the array or on one of the 80GB disks? How do you plan to use the system, 2x80GB raid1 for root and the 4x1TB for data?

2. Are any of the disks with gpt partition table, and which ones?

June 29th, 2012, 12:03 AM
Response 1 - Per Ubuntu 12.04 Server Guide >> Installation >>

Advanced Installation ->
Software RAID ->
Partitioning ->


Step 6. '/ partition' is created after 'swap partition' on free space of the first drive, then again on free space of the second drive. This makes '/ partition' sda2 and sdb2 in the following section, RAID Configuration.

RAID Configuration ->

Step 8. ... '/ partition' choosing sda2 and sdb2. Proceeding to the next section, Formatting.

Formatting ->


Step 5. ... select the "Mount point" and choose "/ - the root file system" ...

Yes; the 2x80GB Ubuntu software RAID1 is the target for root; the 4x1TB Dell SAS firmware RAID5 is for data.

Response 2 - Not sure what is meant by 'gpt'; simply followed the Server Guide steps. All three physical devices started out as 'free space' in 'Partition Disks' stage of install; including the RAID5 volume.

June 29th, 2012, 09:58 AM
So, you created sda1, sda2, sdb1 and sdb2 as partition for RAID, right?

After that you entered into the Software RAID configuration and configured the md0 and md1 devices?

When that is done, and the partitions list is shown back, you forget about the partitions on the disks and continue working with the RAID devices #0 and #1.

Use one as swap and the other as ext4 with mount point /.

Is that how you configured it?

If you can, you can also boot the server temporarily with the Desktop LiveCD and post the output of:

sudo parted /dev/sda print all

July 3rd, 2012, 01:40 AM
Thanks for your patient responses.

Pardon me; I ran off into the weeds with Dell Support to upgrade the ancient BIOS and a firmware driver for the 80GB HDDs.

Yes; the Advanced Install steps for RAID were followed exactly as described.

Discovered the Ubuntu ISO install CD was toasted, thus the inability to re-install; immediately burned a new Ubuntu Server 12.04 AMD64 CD.

Simplified the system configuration down to one 80GB HDD on SATA-1; CD on SATA-0.

Each time Ubuntu installer gave up on installing grub to '/target/' at the install bootloader step.

Each time; when skipped, that step teases with 'Boot manually with the /vmlinuz kernel on partition /dev/mapper/hostname ...

This is where I am stuck now.

Yes; it looks like something funky with the T7400; however, please tell me how to manually install grub; RAID or not.

July 3rd, 2012, 10:57 AM
The /dev/mapper/ devices are used for hardware raid (or bios fakeraid) or for LVM devices. Not for software raid.

Are you sure you have no fakeraid meta data remains on the 80GB disks? That might get into way.

If the 80GB disks are sda and sdb (connect them both), you can make sure you have no meta data remains if you boot into live mode, open terminal and try:

sudo dmraid -E -r /dev/sda
sudo dmraid -E -r /dev/sdb

That will tell you if it has meta data to remove or not.

Since you are planning software raid (that's the better option anyway), you don't need the meta data remains (if there are any).

In fact, remembering now that you do have onboard raid5 array, some boards are designed that all sata ports are raid or not. So by activating the raid option that might include the 80GB disks too.

Not sure if it can work in that case or not, honestly.

Would you consider linux software raid for the big array too? It seems you will be using only ubuntu, in that case the software raid is said to be better option.
The onboard raid is basically used if needed to dual boot on it.