View Full Version : [SOLVED] 12.04 upgrade interrupted, dpkg configuration hanging

June 26th, 2012, 04:00 PM
A couple days ago I attempted to upgrade to 12.04 through the update manager. After proceeding smoothly for a while, the upgrade hung for over 8 hours at 1 hour 44 minutes remaining while installing what appeared to be font files. I finally logged out and when I got back to the desktop, got the warning that the upgrade had been interrupted and I needed to run a partial upgrade to fix the problem.

I attempted to do the partial upgrade from update manager, but it said that it could not get an exclusive lock, probably because some other package management program was running. Sytem manager did not show any processes running that appeared to be package managers, but I logged out and back in again anyway. Same error message from update manager.

When I started Synaptic instead, I got the somewhat more helpful information that I needed to run sudo dpkg --configure -a. I have now tried to run that about 5 times. The first time, it appeared to run along fine until it got to installing nautilus-dropbox, which got up to 99% and then just sat there, A second time, it returned just a few lines until it again got to nautilus-dropbox, installed up to 99% and then hung. I've tried at least three more times since then, and every time now it just tries to install nautilus-dropbox and a percentage counter starts to tick. It gets to 99% and then it sits there and goes no further. I tried uninstalling nautilus-dropbox from the command line but I just get the same message that I need to run dpkg --configure -a. Any help in fixing this problem would be very much appreciated.

June 26th, 2012, 04:39 PM
Welcome to Ubuntu
Alot of people are having problems with dropbox.

Here is a kink scroll down to #3 fix it first, run those commands first then go back to top if you want to install drop box from the ppa:::


Maark thread as solved if this fixes the problem (forum tools)

June 26th, 2012, 06:23 PM
Thanks very much for that link; I did try searching for solutions to this problem but I didn't come across that one. I *think* I am all fixed now, though it didn't go too smoothly. I followed the instructions given at that link under "if you have dpkg errors..." but when I got the error message, clicked CLOSE and tried re-running sudo dpkg -r nautilus-dropbox, instead of completing I got a message that the dpkg status database area was locked by another process.

I tried logging out and back in to clear this process but it didn't work, same error message when I ran sudo dpkg -r nautilus dropbox OR sudo dpkg --configure -a. So I tried the solution posted by another user a little further down of running ps -a | grep dropbox but it didn't return anything. So I tried running sudo rm /var/lib/dpkg/lock and then sudo dpkg -r nautilus-dropbox and that seemed to work.

I got an unrecoverable error when I then ran sudo dpkg --configure -a, which made me a little worried, but after another restart, things seem OK. Update manager is no longer giving me a message that I need to do a partial upgrade, my login says I am on 12.04, and I was able to install updates normally. I haven't tried reinstalling dropbox since I don't use it much now anyway, but if I do, I will follow the instructions posted in the link you gave me.

Thanks again for your help!

June 26th, 2012, 08:08 PM
The "another process" message >>you cant have synaptic or update manager doing something while you are trying to do updates >>>>> close them and try again>>> only one manager should be open( running) while trying to configure or update!!