View Full Version : [ubuntu] unable to install 12.04 (64bit) on new Asus K53 laptop

June 25th, 2012, 01:39 PM
hi all,
long time fan of ubuntu here. i recently bought a Asus K53sd laptop with Windows 7 ultimate edtn (64bit) onboard. wanted to try out the 64bit version of precise pangolin.

downloaded the regular 64bit iso from the ubuntu website.
created a bootable usb with unetbootin.

rebooted the laptop, changed BIOS boot order, plugged in the USB on restart.

a message briefly flashed on top left corner of the screen, something about a "script error".

then loading screen with 3 options, try ubuntu without installing, install ubuntu and another option that i dont remember now.

tried both install as well as try ubuntu options.

but both the times, all i got was a blank screen, black, with everything including the USB on idle.

tried burning the iso to a dvd, with the same results.

downloaded the alternate iso file, with same results.

tried the usb on a different laptop, a toshiba, and it works with no issues.

i am at a loss as to what to do now. i really could use some help on this one. i dont want to be stuck with windows..... thanks in advance for your help.....

the laptop specs:
asus k53sd sx809d
intel core 13 2gen 2.3ghz
4gb ram
500gb hdd
geforce 610m gpu 2gb vram