View Full Version : [lubuntu] Help index build never completes in Eclipse

June 24th, 2012, 08:48 PM
After what appeared to be a successful Eclipse (Version: 3.7.2) installation in Ubuntu 12.04, I tried to use help but this was not possible. I get the following:


0% complete

Please wait while the online information is
indexed. This will happen only once.

And this never completes (tried on both a 32- and 64-bit PC platform). And if I try to use help (search) from the Eclipse platform I get the following error message:

An internal error occurred during: "Local Help".
invalid format:

I removed Eclipse and then did a reinstallation --- same problem!
Any ideas on why this occurs and how to fix this would be appreciated.

June 24th, 2012, 08:50 PM
online help.

June 24th, 2012, 11:16 PM
online help.

Yes, online help (at Eclipse) does allow one to use help. However, it would be useful to know why the help index is never built (even after 2 hours --- endless loop).

July 3rd, 2012, 05:03 PM
me too! Why doesn't Eclipse help work on 12.04? I know I got it all for free, but please, is this getting fixed?

July 6th, 2012, 12:50 PM

Any news on this? Same problem, Eclipse Indigo on Ubuntu 12.04.

An internal error occurred during: "Local Help".
invalid format:


July 10th, 2012, 12:19 AM
This bothered me a whole lot. Don't have a fix for indigo, but if you're willing to do the upgrade to juno, help seems to work there.

Or just install juno to use help and continue working in indigo. Juno doesn't seem to be a major change from indigo, so the help I've used has still been valid across versions.

July 10th, 2012, 02:31 AM
Any change you got a direct link for a repo to juno, for the sake of anyone who reads this topic? :D

June 12th, 2013, 01:33 AM
I have indigo on 12.04

I get an error message on starting eclipse

Indexing help has encountered a problem:

Errors while indexing
invalid format:

But if I just close the message and choose help from the dropdown - offline help is there just fine