View Full Version : [SOLVED] Ubuntu grub doesn't read Win 7 Ultimate 64bit...

June 24th, 2012, 03:17 PM
First, I installed "Windows7 Ultimate K 64bit" on my laptop.
While installing, I partitioned the harddrive as three parts:

c drive (60GB) - For Win7
d drive (60GB) - For Ubuntu
e drive (180GB) - Storage
( No "system reserved" partition. )

Then, to make a dual-boot system, I tried to install Ubuntu 12.04 64bit.

But the Ubuntu installer doesn't read any OS installed previously..
On Terminal, fdisk knows there's three partitions.
But gparted(&the installer) does not.
So It doesnt offer 'install alongside' option.

What should I do?

June 24th, 2012, 03:53 PM
First, delete the D: partition. If you created it in windows it would be NTFS and linux doesn't install on NTFS.

If the disk has been used in raid before and still has meta data remains, the ubuntu installer might ignore it.

Also, if there is some error or corruption in the partition table it might not recognize windows (and the partitions).

Can you post the fdisk results?

June 24th, 2012, 04:25 PM
Thank you for your response!

Here's fdisk results.
root@ubuntu:~# fdisk -l

WARNING: GPT (GUID Partition Table) detected on '/dev/sda'! The util fdisk doesn't support GPT. Use GNU Parted.

Disk /dev/sda: 320.1 GB, 320072933376 bytes
255 heads, 63 sectors/track, 38913 cylinders, total 625142448 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disk identifier: 0xa0e93598

Device Boot Start End Blocks Id System
/dev/sda1 * 2048 122882047 61440000 7 HPFS/NTFS/exFAT
/dev/sda2 245762112 625137663 189687776 7 HPFS/NTFS/exFAT

There's someting like "GPT" and "GNU"...
And no partition between C and E... Maybe it's because I unallocated it just before.

June 24th, 2012, 05:39 PM
I think the disk was used with GPT partition table before, and then you tried to convert it to MSDOS table with windows.

But windows doesn't delete the backup gpt table, so linux is detecting it.

Beofre doing anything else, boot with the ubuntu cd in live mode and try using fixparts on the disk. If I am right, that should offer you to remove the backup gpt table, and all should be fine after that. Fixparts instructions are here:

June 24th, 2012, 05:43 PM
You're right! I installed Ubuntu only on my laptop last week and used it
for a week.
I'll try it as soon as I understand the tutorial on your link!

June 24th, 2012, 06:43 PM
It worked perfect!!
Thank you for your help.