PDA

View Full Version : [SOLVED] CPU usage through the roof on login



ejordanholidayedition
June 19th, 2012, 12:58 AM
This just started a couple days ago- as soon as I log in to any of my desktop environments the system monitor looks like this:

http://ubuntuone.com/21S6nhZvWP01TXMxyTizMG

but the processes tab looks like this:

http://ubuntuone.com/7mi65fwsJrVARk23nRukI3

What is going on and can i fix it?

ejordanholidayedition
June 19th, 2012, 01:02 AM
Also, it's a Lenovo y560p laptop. Have Ubuntu 12.04 with cinnamon 1.04 installed

typhoon_tip
June 19th, 2012, 05:37 AM
Post the output of (when the CPU is sky high loll):

top

The System Monitor is not showing the process that is using your CPU, but top will.

vasa1
June 19th, 2012, 06:10 AM
I see something similar. I guess it's something that could be turned off in the start-up menu. I haven't bothered finding out what because things return to normal pretty quickly.

ejordanholidayedition
June 19th, 2012, 11:37 AM
Thanks! I didn't even know about the top command, it turns out it was whoopsie and kworker going crazy. Read around a little, and kworker will use a lot of cpu on some computers when the battery isn't fully charged or when running on battery power. As for whoopsie i just had to disable the crash reports to Ubuntu and it stopped.

http://askubuntu.com/questions/135540/what-is-the-whoopsie-process-and-can-i-remove-it

All normal once more, thanks again for the help!

m_duck
June 19th, 2012, 11:41 AM
For a more aesthetically pleasing top, try htop.