View Full Version : [SOLVED] Update Errors

Rex Bouwense
June 18th, 2012, 07:56 PM
Been awhile since I asked a question. I was manually doing an update through the terminal using apt-get and I got errors. I have posted a screen shot. I have not installed or uninstalled any software other than the kernal update last week I believe. I was getting updates regularly via apt-get and the update manager. Now what do I do?

June 19th, 2012, 01:20 AM
For one of the errors, you are missing the GPG key. To get it enter theses commands in a terminal.
gpg --keyserver keyserver.ubuntu.com --recv A8AA1FAA3F055C03
gpg --export --armor A8AA1FAA3F055C03 | sudo apt-key add -

It may fix another error you are getting.

The screenshot made it difficult for me. I couldn't just copy and past the GPG Key from a terminal output in your post and pasted into my response. I had to try to enter the GPG Key I was seeing from the screenshot. I hope I didn't miss a Hex value.

Rex Bouwense
June 19th, 2012, 02:07 AM
Thanks for your response. I copied and pasted the code and ended up with the errors in screen shot.

June 19th, 2012, 02:47 AM
Try these commands
sudo apt-get clean
cd /var/lib/apt
sudo mv lists lists.old
sudo mkdir -p lists/partial
sudo apt-get clean
sudo apt-get update

Rex Bouwense
June 19th, 2012, 10:45 PM
That did the trick. Drinks on the house. Thank you Old_Grey_Wolf. In the many years that I have been using Ubuntu and then Lubuntu, that has never happened to me. I got it bookmarked just in case.

June 19th, 2012, 11:55 PM
I'm glad it worked. Yesterday I was only getting a 50% success rate at solving problems; so, it makes me feel a little better. LOL

Rex Bouwense
June 20th, 2012, 12:14 AM
Hey OGW, 50% is better than what I was doing yesterday.:popcorn: