View Full Version : [ubuntu] Canon MF4690 doesn't work in 12.04

June 18th, 2012, 03:46 AM
This all worked in 11.04 and continued to work on 11.10 after upgrade. On a separate machine with 12.04 I installed the same Canon printer drivers:


(I converted rpms to deb with alien)

In installed the printer from the "Printing" GUI - it all seemed fine.

It was missing some print filter, I copied the file:
/usr/lib/cups/filter/pstoufr2cpca from the working (ubuntu 11.10) machine - it was no longer complaining about a filter.

It all seems fine - except that when I go to print a test page, the printer prints the following:

**** Unable to open the initial device, quitting.

No idea how to debug. Again, this is working on Ubuntu 11.10 laptop, but not in 12.04.

PS - I also tried Canon driver UFRII version 2.4 - same bug. I don't think it's Canon - I think it's Ubuntu 12.04

June 18th, 2012, 03:48 AM
Oh yes...I forgot to mention that this is a network printer

June 27th, 2012, 12:35 PM
I'have the same problem.

for pstoufr2cpca I make a symbolic link (ln -s /usr/lib64/cups/filter/pstoufr2cpca/usr/lib/cups/filter/pstoufr2cpca)

I'have put in /etc/apparmor.d/local/usr.sbin.cupsd this line:

/usr/lib64/cups/backend/cnusb Uxr,
/usr/lib64/cups/filter/pstoufr2cpca Uxr,
/usr/lib/cups/backend/cnusb Uxr,
/usr/lib/cups/filter/pstoufr2cpca Uxr,

But the printer print always "Unable to open the initial device, quitting"