PDA

View Full Version : [ubuntu] Installed Ubuntu 12.04 from Windows XP and can't locate Wireless



brevardo
June 16th, 2012, 07:19 PM
I've tried this now on a couple of different versions of ubuntu. I just installed Ubuntu 12.04 from Windows XP and I can only connect by ethernet. I've tried several things and it appears that it doesn't know that I have a wireless network card inside of the laptop.

It tells me the Broadcom STA Wireless Driver is currently in use however it's doing nothing to help me wirelessly. I'm guessing that I need to find out how to install a different proprietary driver that will work.
I click the top wired/wireless icon in the upper right and network connections opens up and you can see that the wired connection makes sense. There is a wireless tab however it asks for info such as SSID, BSSID, MAC address and it gives you an option to save but it doesn't connect? Also it doesn't ever recognize the other 8 routers in the area?

I also tried to install WICD network manager and that lets you refresh only to say "no wireless networks found"

It's a Dell Latitude D620 laptop.
It also didn't work on the previous version Oncelot that I installed before upgrading to 12.04
Does anyone have any suggestions on how I can connect first by wired to get me the proper driver to go wireless.

I also tried to use this NDISWRAPPER and that also is not user friendly. You open a program called Windows Wireless Drivers and It asks you to install a new driver. I tried to do that and then it doesn't recognize it as it says slect inf file and you can't execute a windows file on Linux. There has to be an easier way to do this?

brevardo
June 16th, 2012, 09:37 PM
Good news. I just went here and follwed these instructions and then as soon as I did that I went back up top to the icon for the Wired and this time it gave me about 35 other options instead of the 5 I had been getting and I noticed this time that it was recognizing other routers in the area including mine.

http://ubuntuforums.org/images/rebrand/misc/navbits_finallink_ltr.gif (http://ubuntuforums.org/showthread.php?t=1979521&highlight=broadcom+sta+wireless) [ubuntu] Error connecting to wifi after upgrading to ubuntu 12.04