PDA

View Full Version : Screen Brightness not working.



kiwimenace
June 16th, 2012, 01:29 AM
Laptop(netbook) in question is a Toshiba NB550D/02F PLL5FA-02F02C(amd c60/hd 6290).

I have searched quite a bit but to no luck. My problem is that i cannot set the brightness with the FN keys. The keys work, as in the wee indicter slider pops up in the top right of the screen and slides up or down as i try to change the brightness but the brightness does not change.

I hope somebody has a solution for this. Thanks in advance.

Toz
June 16th, 2012, 01:47 AM
According to here: http://www.kubuntuforums.net/showthread.php?58370-Precise-on-the-Toshiba-NB550D, blacklisting the toshiba_acpi module fixed the problem. To do so, add:

blacklist toshiba_acpi
...to the end of /etc/modprobe.d/blacklist.conf and reboot.

If that doesn't work, you could try using the acpi_backlight=vendor kernel parameter

kiwimenace
June 16th, 2012, 02:27 AM
Neither of those options worked.

Anybody else got any ideas?

hexion
June 16th, 2012, 11:46 AM
Check the instructions here: http://ubuntuforums.org/showthread.php?t=1985757

newboon2
June 16th, 2012, 07:32 PM
Check the instructions here: http://ubuntuforums.org/showthread.php?t=1985757

My Toshiba NB555D (older model than the OP's, with AMD C30; Radeon HD 6250) exhibited the same issue after upgrading from 11.10 to 12.04.

The instructions in the linked thread fixed it for me.

Thanks!

kiwimenace
June 17th, 2012, 09:32 AM
Still not luck guys. Thanks for the suggestions so far though.

I might actually do a fresh install of 12.04 anyway, this one has been a bit experimental so it a bit messy. Never know some of these solutions may even work after that who knows.

Keep those suggestions coming if your reading though.

cheers

kiwimenace
June 18th, 2012, 04:51 AM
Right, I did a fresh install 12.04 ubuntu(not lubuntu as this thread is tagged as, not sure why that is).
It worked!
Installed ati catalyst driver.
It stopped working!
Installed ati catalyst driver update.
It worked

So great i have brightness control again!

Thanks for taking the time to help me out guys, greatly appreciated.

kiwimenace
June 19th, 2012, 12:12 AM
I take it all back. It stopped working.

I did the three steps in the linked solution and it appears to have fixed it for now(fingers crossed).

If it has fixed it I will come back in a week or so and mark this solved.

Again, many thanks to the community for there inputs.