View Full Version : [ubuntu] 11.10 install problems with Lenovo Z570

June 13th, 2012, 06:55 PM

I recently purchased a Lenovo Z570, and one of the first things I've tried to do was install Ubuntu 11.10. Unfortunately I've run into a stream of issues.

Initially, when I tried to boot from the CD, and error message would show on the BIOS: "Error: prefix not set" and then a bunch of garbles text would show up. After searching for similar problems, I installed a BIOS update that Lenovo issued. That, paired with altering the boot order in the BIOS (USB:FDD, USB:HDD, USB:CD, CD-drive, HDD, network) let me get to a basic boot menu for Ubuntu, with three options: Try Ubuntu without Installing, Install Ubuntu, check disc for errors.

I've tried both "Try without Install" and "Install" the screen goes black/purple for a moment, and then there is a huge dump of text ending with :

udevd[110] '/sbin/modprobe -bv pci:[a bunch of alphanumeric] [152] terminated by signal 9

ata6: SATA link down (SStatus 0 SControl 300)

I've also heard that even after a successful install, there are issues with grub and the wireless.

If there is anyone who has encountered these same issues and successfully overcome them, your help would be greatly appreciated. Thanks.

June 15th, 2012, 05:19 AM
Have you not tried assigning a boot parameter such as 'nomodeset'? This is done at that menu where you saw the 3 options. Press F6 and try this parameter first. You can also remove the 'quiet splash' from the end of the line or replace it with 'nosplash' to get the verbose mode so you can be better informed of where the installer gets stuck instead of seeing a blank screen. Other than that, have you read the sticky on dealing with blank screen/blinking cursor issues while installing?

Also, for booting from a CD, the cd-drive should be first in the list of the boot order. I have a Lenovo B570 and I was using Ubuntu 11.10 without much problems. The only problem with the wireless was not being able to create a hotspot, but that particular problem has now disappeared after installing 12.04. Instead, I now keep getting an "internal error" message but it is not exclusive to the Lenovo. Another reason, I would recommend installing 12.04 over 11.10 is the improved power management which means you will get a bit improved battery life (though still not on par with Windows).

June 20th, 2012, 10:33 PM
Using 'nomodeset' as a boot parameter worked and I was able to install 11.10. I still had to manually set up grub, and configure the wireless card. My graphics card is still giving me grief, but at this point I'm just glad I got the OS installed.

Thank you very much for your help.